Bug Hunting Session
Bug 67112 - REPORTBUILDER - L10n - Many of the menu items are not translated (French and German user interface)
Summary: REPORTBUILDER - L10n - Many of the menu items are not translated (French and ...
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.3 rc
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:4.3.0 target:4.2.5
Keywords: regression
: 75507 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-07-20 09:17 UTC by pierre-yves samyn
Modified: 2014-05-31 07:20 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2013-07-20 09:17:45 UTC
Hello

Steps to reproduce (the report builder extension must be installed and user interface in french):

1. Fichier> Nouveau> base de données
2. Rapports> Créer un rapport en mode ébauche

File menu: Report Output format
Edit menu: Column header/footer, shape, control, section, execute
same for View, Insert, Format menus

Platform: windows 7 64bits & Version: 4.1.0.3
Build ID: 719826cd009b9a1fa43e253db0616288c682826

Reproduce (qa-fr) with W8 Pro 64 bits & 4.1.0.1 build 1b3956717a60d6ac35b133d7b0a0f5eb55e9155

Regards
Pierre-Yves
Comment 1 pierre-yves samyn 2013-07-20 09:40:43 UTC
Reproduce (qa-fr) with Ubuntu 12.04 32 bits & 4.1.0.3
Build ID : 0f08a823567f802c29cbaf2b327db19aaf72016
Comment 2 Robert Großkopf 2013-07-28 19:41:29 UTC
Isn't a special bug of the french user-interface. I am missing the same translations in the german UI of the Report-Builder. Couldn't say, which is the first version, where the translation is missed, because I haven't installed the langpack for all installed version.
The translation is right in LO 4.0.3.3
Comment 3 Robert Großkopf 2014-02-28 15:31:19 UTC
*** Bug 75507 has been marked as a duplicate of this bug. ***
Comment 4 Commit Notification 2014-04-28 07:56:16 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d6904736b9a07b2a321add96be4857ba41a7f370

fdo#67112 ReportCommands.xcu is localizable



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Andras Timar 2014-04-28 08:03:09 UTC
I could have fixed it long ago, if it was in the right component (Localization).
Comment 6 Commit Notification 2014-04-28 11:12:50 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=18439c59a11a9c3c6ece1792e8d465399c1c0e84&h=libreoffice-4-2

fdo#67112 ReportCommands.xcu is localizable


It will be available in LibreOffice 4.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 pierre-yves samyn 2014-05-31 07:20:17 UTC
Hi 

(In reply to comment #5)
> I could have fixed it long ago, if it was in the right component
> (Localization).

Probably yes. Very sorry for the delay and for this misclassification.

I confirm the resolution of the bug and thank you very much.

Verified on Windows 7/64 & Version: 4.2.5.1
Build ID: 881bb88abfe2992c6cede97c23e64a9885de87de

Regards
Pierre-Yves