Bug 67160 - FORMATTING: Wrong Standard formatted formula results representation when rotated
Summary: FORMATTING: Wrong Standard formatted formula results representation when rotated
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: Other All
: low normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-22 10:14 UTC by Viktor Mileikovskyi
Modified: 2017-10-09 21:29 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
The bug reproducing workbook (13.97 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-07-22 10:14 UTC, Viktor Mileikovskyi
Details
This is a screenshot reproducing current behaviour (335.16 KB, image/jpeg)
2013-07-22 10:16 UTC, Viktor Mileikovskyi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Viktor Mileikovskyi 2013-07-22 10:14:42 UTC
Created attachment 82811 [details]
The bug reproducing workbook

Problem description: 
Standard formatted formula results are incorrectly displayed if rotation is not 0 degrees. For example 1e100 displayed as 1000000... . The numbers are not rounded but truncated. 

Steps to reproduce:
1. Download and open attached worksheet BugStandardRotated.ods

Current behavior:
    Numbers in column C ("0°") is represented correctly but in columns D and E ("45°" and "90°") are incorrectly truncated. (Look at attached CurrentBehaviour.jpg)

Expected behavior:
    The numbers in columns C, D and E are represented the same way
              
Operating System: Ubuntu
Version: 4.0.4.2 release
Comment 1 Viktor Mileikovskyi 2013-07-22 10:16:05 UTC
Created attachment 82812 [details]
This is a screenshot reproducing current behaviour
Comment 2 Viktor Mileikovskyi 2013-07-22 10:38:01 UTC
The same bug appears in Windows 8. So Platform is changet to "ALL"
Comment 3 Joel Madero 2014-01-17 03:56:34 UTC
Interesting catch.

Thank you for reporting this issue! I have been able to confirm the issue on:
Version: 4.2.0.1
 Date:   Sun Dec 15 23:07:57 2013 +0100
Platform: Ubuntu Linux 13.04

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
As I've been able to confirm this problem I am marking as:

New (confirmed)
Normal - can prevent high quality work
Low - not going to affect too many people IMHO - no other users reporting in 6 months, no dupes, etc . . .

Keywords - 

Whiteboard Status - ProposedEasyHack

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 4 Joel Madero 2015-05-02 15:43:55 UTC Comment hidden (obsolete)
Comment 5 Buovjaga 2015-06-21 12:42:43 UTC
Confirmed.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-19_23:16:58
Locale: fi-FI (fi_FI)
Comment 6 QA Administrators 2016-09-20 10:11:04 UTC Comment hidden (obsolete)
Comment 7 Laurent BP 2017-10-09 21:29:29 UTC
I do NOT reproduce with Version: 5.4.2.2
Build ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4
Threads CPU : 8; OS : Linux 4.10; UI Render : par défaut; VCL : gtk2; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group