Bug 67326 - LibreOffice for OS X always crashing after starting the application.
Summary: LibreOffice for OS X always crashing after starting the application.
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: x86 (IA32) macOS (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-25 20:53 UTC by kposer
Modified: 2013-12-29 01:14 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
LibreOffice 4.1.0.2 Crash Report 2013.07.25 (59.75 KB, text/plain)
2013-07-25 20:54 UTC, kposer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kposer 2013-07-25 20:53:40 UTC
LibreOffice 4.1.0.4 and 4.0.4.2 and 3.6.7 are crashing on my Intel iMac with OSX 10.8.3 within seconds after opening the application. Always, without exception. Deleting all - visible and invisible - configuration files and restarting does not help.

NeoOffice 3.3 works without problems.

See attached crash report.

The error message in the crash report is always "Exception Type: EXC_BAD_ACCESS (SIGBUS)", and a search for this on Google shows that this seems to happen to quite some people and there have been also quite some bug reports about it.
Comment 1 kposer 2013-07-25 20:54:14 UTC
Created attachment 83009 [details]
LibreOffice 4.1.0.2 Crash Report 2013.07.25
Comment 2 Jorendc 2013-07-26 19:57:17 UTC
Hi,

Thanks for reporting, but sadly I can not reproduce this behaviour (and others can't too). So what we can try is to reset your user profile: https://wiki.documentfoundation.org/UserProfile#Mac_OS_X by renaming it.

If that doesn't work: you have installed special fonts or something like that? Can you provide any more information about how we can reproduce this behaviour?

Kind regards,
Joren
Comment 3 kposer 2013-07-27 22:35:32 UTC
Deleting the user profile file does not help. Repairing permissions does not help. Deleting all cache files does not help. 

What are "special fonts"? I have many fonts installed on my computer, managed by FontAgent Pro, but rarely more than 30 of them are activated at any given time.

If this is font-related: why do all my other applications that work with fonts - like Indesign, Quarkxpress, Neooffice, Word, Textedit, Illustrator, and others - don't crash as well (I have sometimes all of the above mentioned applications open at the same time)?

I actually think that Libreoffice has a conflict with one of my kernel extensions
or with one of my other login items - as I now found out Libreoffice is not crashing when I start in Safe Mode. However, since all of my other applications do not crash I think it is safe to assume that Libreoffice is the one that is creating the conflict.
Comment 4 kposer 2013-07-27 23:19:27 UTC
I found the conflict. It is a utility called "Deskovery" (http://www.neomobili.com/products/deskovery/) which is in my login items (and is being used by me multiple times every day in my work). 

When I quit Deskovery after startup Libreoffice does not crash. 

I hope this helps you guys to reproduce the crashes on your machines. It would be great if this conflict could get eliminated.
Comment 5 Petr Mladek 2013-07-31 13:01:29 UTC
kposer@, could you please get the debugging information as described at
https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Mac_OSX:_How_to_get_debug_information
It will hopefully point to the problematic piece of code.

I add some developers who are familiar with MAC.

Also, I reduce the severity a bit. I understand that it is critical for you but it seems to be an older problem. It probably affects only very limited group of users, otherwise people would have reported it earlier. Such bugs, could not suddenly start blocking the release with many other useful fixes and improvements.
Comment 6 Norbert Thiebaud 2013-07-31 13:35:43 UTC
"(In reply to comment #4)
> I found the conflict. It is a utility called "Deskovery"
> (http://www.neomobili.com/products/deskovery/) which is in my login items
> (and is being used by me multiple times every day in my work). 
> 
> When I quit Deskovery after startup Libreoffice does not crash. 
> 
> I hope this helps you guys to reproduce the crashes on your machines.

I looked-up Deskovery. it is for-pay + closed-source. iow one can't reproduce the bug, even less find out what they do that make things blow-up.

> It would be great if this conflict could get eliminated.

Yes it would be great. But I think Deskovery need to have a look at it. Only they know what they do (whereas our source code is free for them to look at)

Note: the backtrace show 'HIServices'
so they most likely use 'Accessibility' API to intercept things and do it their way... We have had issue with Accessibility in the past so it is possible that there is a disconnect between some assumption made by Deskovery and what we do. maybe we do it wrong, maybe their assumption should be checked... either way, there are plenty of other accessibility extensions that work with LibreOffice without making it crash, just like there is plenty of app that work with Deskovery... it is not that clear cut where the bug is (and even maybe in both side)
But as I said earlier, for practical reason, Deskovery's dev are in a better place to diagnose it.

PS: their web say that they are located in Lyon, but their mailing address is in Pertuis... closer to Aix or Marseille than Lyon which is 3 hours drive away from Pertuis.
Comment 7 kposer 2013-07-31 14:31:02 UTC
@Petr Mladek: My original post has exactly such a crash report attached to it. What more do you need?

@Norbert Thiebaud: I guess you are contacting the Deskovery makers, right?
Comment 8 Norbert Thiebaud 2013-07-31 15:00:11 UTC
> 
> @Norbert Thiebaud: I guess you are contacting the Deskovery makers, right?

on what ground ?
1/ I am not their customer
2/ I could not help them in any way with testing anything since I do not have their product
3/ I have no particular expertise in the Accessibility API. I am merely the greasemonkey that happen to run the release build for LibreOffice :-)

otoh I also speak french, so that may come handy with them :-)

I think, _you_ as the customer of their porduct should contact them... if they are willing to do anything about it, I'll be happy to be a contact and provide all the help I can. otoh using our public dev ML is probably a better way for them to find people in our side that can help should they have a technical question
Comment 9 Norbert Thiebaud 2013-07-31 15:03:24 UTC
(In reply to comment #7)
> @Petr Mladek: My original post has exactly such a crash report attached to
> it. What more do you need?

Petr was asking for a back-log with debug info... but since the thing crash asynchronously in a 3rd party system extension, it is very unlikely to provide more information in this case.
Comment 10 kposer 2013-07-31 15:16:00 UTC
"on what ground?"

On the grounds that Libreoffice might be interested to fix a bug. 

Remember that Deskovery has no problem with Libreoffice (it works whether being started before or after Libreoffice) but Libreoffice has a problem with Deskovery (it insists to being started before Deskovery and crashes otherwise). 

To say this is Deskovery's responsibility is kind of cocky in my opinion.

"I think, _you_ as the customer of their poroduct should contact them..."

Well, I'm Libreoffice' customer and contacted them and have spent quite some time to help them to fix one of their (not so rare) crashing bugs of their OS X product. What a pity that they don't seem to care. No wonder that people still buy Microsoft Office.
Comment 11 Norbert Thiebaud 2013-07-31 15:43:29 UTC
(In reply to comment #10)
> "on what ground?"
> 
> On the grounds that Libreoffice might be interested to fix a bug. 
> 
> Remember that Deskovery has no problem with Libreoffice (it works whether
> being started before or after Libreoffice) but Libreoffice has a problem
> with Deskovery (it insists to being started before Deskovery and crashes
> otherwise). 

You can switch LibreOffice and Deskovery and it will still hold true.

LibreOffice works just fine without Deskovery, and work fine with dozen of Accessibility based product...

> 
> To say this is Deskovery's responsibility is kind of cocky in my opinion.

I _cannot_ look into Deskovery's code to figure out on what they choke.
The abend does not occurs in LibreOffice code... maybe it is a consequence of what or how LibreOffice does things, but I have no access to the code that choke on it, no access to any documentation about what it does and how, nothing to work with.

Deskovery is in a position where they see their own code, and they can see LibreOffice code since we are Open Source.

The other difference is that Deskovery has not bugzilla or any equivalent way to report a bug, at least nothing I could find in their website.

> 
> "I think, _you_ as the customer of their poroduct should contact them..."
> 
> Well, I'm Libreoffice' customer and contacted them and have spent quite some
> time to help them to fix one of their (not so rare) crashing bugs of their
> OS X product. What a pity that they don't seem to care. No wonder that
> people still buy Microsoft Office.

You may be a 'customer' of LibreOffice, but _I_ am not an employee. I do that on my free time, and I am not going to spend 25 euro of my own money just to have a look at your problem.

I've already express a willingness to help if I can... but please take that in the spirit it was offered. I do not owe you anything. if you are unwilling to help solving your problem by taking action that only you can, then why should I ?
Comment 12 kposer 2013-07-31 15:56:58 UTC
> if you are unwilling to help solving your problem by taking action that 
> only you can, then why should I ?

I do not have a problem because I have Microsoft Office. I just took the time to find and report one of the reasons why LibreOffice for OS X is crashing so often.

I think it's best to forget about it.
Comment 13 retired 2013-12-29 01:14:55 UTC
This clearly is NOTOURBUG.

Deskovery was last updated 13 Apr 2012 and yet has to be updated to full Mavericks compatibility and even for the current version there are several reports about issues with Mountain Lion. This app is closed source so nothing we could look into or do about.

I suggest uninstalling this and move on with live.