Bug 67360 - [Gnome integration] File list has the focus after navigation
Summary: [Gnome integration] File list has the focus after navigation
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: x86 (IA32) Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-26 17:47 UTC by Ackbeet
Modified: 2013-07-27 06:19 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of Save Dialog box. (129.67 KB, image/png)
2013-07-26 17:47 UTC, Ackbeet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ackbeet 2013-07-26 17:47:30 UTC
Created attachment 83045 [details]
Screenshot of Save Dialog box.

In LO Draw, when I save a new file, I will usually do Ctrl-S to raise the Save dialog box, then navigate to where I want the file using the navigation at left under Places. Now, at this point, the highlighted text in the Name: textbox looks like where any text I type would end up. However, instead, my typed text goes into a strange new box that pops up right above the All Formats drop-down box. As I would think people wouldn't change the file format nearly so often as the filename, this is non-intuitive behavior. After navigation, the focus should return to the Name: textbox, so that typing text goes there instead of in the file format location.
Comment 1 Jorendc 2013-07-26 18:55:15 UTC
Thanks for reporting!

First of all, you have to activate this save dialog by going to Tools > Options > LibreOffice > General : Use LibreOffice Load/Save dialogs

I agree that it's not that efficient.
Actually this is an enhancement request, not a bug. Therefore I'm marking it as such.

Kind regards,
Joren
Comment 2 Urmas 2013-07-27 06:19:00 UTC
Looks like a GTK issue to me.