Download it now!
Bug 67430 - EDITING: Properties in Fields of a Form chaotically "sorted"
Summary: EDITING: Properties in Fields of a Form chaotically "sorted"
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.1.0.0.beta1
Hardware: Other All
: medium normal
Assignee: Stephan Bergmann
URL:
Whiteboard: target:4.2.0 target:4.1.1
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-07-28 07:25 UTC by Robert Großkopf
Modified: 2013-08-05 02:37 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Sorting of fieldproperties changed from LO 4.0 to LO 4.1 (232.20 KB, application/vnd.oasis.opendocument.text)
2013-07-28 07:25 UTC, Robert Großkopf
Details
German Property List (93.19 KB, image/png)
2013-07-28 21:23 UTC, Theo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2013-07-28 07:25:18 UTC
Created attachment 83114 [details]
Sorting of fieldproperties changed from LO 4.0 to LO 4.1

Since 4.1.0.0.beta1 there is a new "sorting" in the properties of a field in a form. I have searched some times to see, that there is nothing new but only changed the old sorting.
Don't know, if there is somebody who thought this "sorting" would be better than the old. For me it gives the impression that these sorting isn't changed by somebody, who wants to change the sorting. Seem to be a bug, not a feature.
Comment 1 Mas 2013-07-28 18:23:32 UTC
The list has been placed in alphabetical order. This is not a bug
Comment 2 Robert Großkopf 2013-07-28 18:59:18 UTC
(In reply to comment #1)
> The list has been placed in alphabetical order. This is not a bug

I don't know, what you mean with alphabetical order:
Nearly at the top of the list I see "Visible". "Anchor" is nearly at the bottom.

There is no order in English.

OK, my Desktop runs under German language. Lets see:
Second entrance is "Hintergrundfarbe". Last entrance is "Breite".

There isn't any visible order in this properties. An alphabethical order wouldn't work, when there is no function, which sorts the properties in the right way of different languages. Please have a look at the attachment.

I will reopen this bug-report.
Comment 3 Mas 2013-07-28 19:39:11 UTC
I viewed your attachment again .  The screen shot was presented in English and if you notice under the general tab. The list goes from A-Z -- alignment being the first and background color being next.  This is called alphabetical order from A-Z

 I checked under releases 4.1.03 and 4.1.04 Window and Linux. They are setup the same way.
Comment 4 Robert Großkopf 2013-07-28 19:55:42 UTC
(In reply to comment #3)
> I viewed your attachment again .  The screen shot was presented in English
> and if you notice under the general tab. The list goes from A-Z -- alignment
> being the first and background color being next.  This is called
> alphabetical order from A-Z
> 
>  I checked under releases 4.1.03 and 4.1.04 Window and Linux. They are setup
> the same way.

You have had a look at the first two words. But read a little bit more. There is no order!
The 7th is "Visible"
The 8th is "Enabled"
After "Tabstop" follows "Additional Information".

I have never heard about a software with menues ordered in an alphabethical order. 
Don't know, if you are working with databases. But it make no sense, when there appears the Anchor of a box at the bottom of the list, the Hight nearly at the top, the Width at the end and the Position in the middle.
The order of such entries must be logical, not alpabethical.
Comment 5 Theo 2013-07-28 21:23:19 UTC
Created attachment 83156 [details]
German Property List

In thist Screen-Shot you will see, its neither alphabetical nor logical assorted.
Comment 6 Mas 2013-07-28 21:47:25 UTC
confirming Regression ..
Comment 7 Mas 2013-07-28 21:57:16 UTC
additional comments, user is requesting the property fields be group by relevance as with release 4.0.*
Comment 8 Jochen 2013-07-28 22:01:28 UTC
I can confirm the regression. This is a bug (no enhancement).
IMHO the logical sorting must be (again)
Comment 9 Florian Reisinger 2013-07-29 06:21:14 UTC
[CONFIRM] with Version: 4.2.0.0.alpha0+
Build ID: d798d26bc4b7572ed10d6baf5aef7382269d7da5
TinderBox: Win-x86@6-debug, Branch:master, Time: 2013-07-29_00:38:14
Comment 10 Noel Power 2013-07-29 15:19:40 UTC
seems http://cgit.freedesktop.org/libreoffice/core/commit/?id=ca0600f0c9022d631317423ab5a59493b41906ab is the cause of that. cc'ing stephan who knows about this change
Comment 11 Stephan Bergmann 2013-07-29 16:03:36 UTC
So "The difference is that old indices were before calling std::sort in OPropertyInfoService::getPropertyInfo() while new ones are after, but that should probably be OK per the documentation of com.sun.star.inspection.XObjectInspectionModel.getPropertyOrderIndex (which appears to be the only client of that functionality)." was apparently a wrong assumption, and the elements of aPropertyInfos in OPropertyInfoService::getPropertyInfo (extensions/source/propctrlr/formmetadata.cxx) shall have a predefined order after all (thought the original code that established the order would only have worked by luck).
Comment 12 Stephan Bergmann 2013-07-31 12:00:40 UTC
To reproduce:
> <noelp> sberg, ok, in a calc doc for example, enabled the 'form' control toolbar, get it into design mode, select TextBox ( that's the one at least mentioned in the bug ) right click and select control from ctx menu then general tab,
> <noelp> s/enabled/enable
> <noelp> sberg, and of course draw a textbox on the sheet, then " right click " the textbox on the sheet etc.
Comment 13 Commit Notification 2013-07-31 12:05:43 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a6fe1fde409ff1accdea49ff9de69658de1e6f5f

fdo#67430 Keep original order of entry positions, not alphabetically sorted



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Stephan Bergmann 2013-07-31 12:52:32 UTC
requested backport of fix to libreoffice-4-1 towards LO 4.1.1 at <https://gerrit.libreoffice.org/#/c/5215/>
Comment 15 Commit Notification 2013-07-31 15:51:06 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b23a866a93e42467ef42c2d46735e1ffcf6f1c78&h=libreoffice-4-1

fdo#67430 Keep original order of entry positions, not alphabetically sorted


It will be available in LibreOffice 4.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.