Bug Hunting Session
Bug 67493 - documents with a special font aren't displayed correctly
Summary: documents with a special font aren't displayed correctly
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-29 17:40 UTC by bordfeldt
Modified: 2018-02-05 10:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
the font "Rotis Semi Sans 55" (77.01 KB, application/x-font-ttf)
2013-07-29 17:40 UTC, bordfeldt
Details
slide wrong displayed with Rotis (247.23 KB, image/png)
2013-07-30 08:15 UTC, bordfeldt
Details
slide right displayed with arial narrow (250.57 KB, image/png)
2013-07-30 08:17 UTC, bordfeldt
Details
FontForge screenshot of metrics for Rotis and DejaVu Sans fonts. (59.63 KB, image/png)
2013-08-03 04:33 UTC, Owen Genat (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bordfeldt 2013-07-29 17:40:48 UTC
Created attachment 83221 [details]
the font "Rotis Semi Sans 55"

LO 4.1.0.4 on Ubuntu 12.04 64bit

After updating from LO 4.0.2.2 to 4.1.0.4 documents written with the font "Rotis Semi Sans 55" (a special font from my company, that I have to use in many documents) aren't displayed correctly anymore. The distances between the paragraphs are too small. In 4.0.2.2 documents with this font worked without problems.
If I open a new document and change the font to "Rotis ..." and start writing the paragraph distance is too small. All other fonts are working normal.
This is a very severe problem for me, because all people in my company have to use this font for official documents.
In the attachment you can find the affected font for testing.
Comment 1 bordfeldt 2013-07-29 17:47:50 UTC
In my bug report before I forgot something. If I change the font for example in Arial Narrow, which is quite similar, the document is displayed in a normal way and the distances between the lines are normal.
Comment 2 bordfeldt 2013-07-30 08:12:34 UTC
Today I saw that impress shows the same behaviour. If I open a presentation with the font "Rotis..." the line height is too small. I think LO displays the signs not in the real height. I will add screenshots of the page in "Rotis" an the same page in "Arial narrow".
Comment 3 bordfeldt 2013-07-30 08:15:33 UTC
Created attachment 83276 [details]
slide wrong displayed with Rotis
Comment 4 bordfeldt 2013-07-30 08:17:18 UTC
Created attachment 83278 [details]
slide right displayed with arial narrow
Comment 5 Owen Genat (retired) 2013-08-03 04:33:52 UTC
Created attachment 83564 [details]
FontForge screenshot of metrics for Rotis and DejaVu Sans fonts.

This is not necessarily the cause of the problem, but it is worth noting that the SPACE (U+0020, named "glyph1") character in the provided custom font is mapped to the beginning of the Private Use Area (U+E001, named "space"). I am not sure why this would be necessary, but it seems erroneous.

A more likely cause of your problem is that LO is now (more) correctly interpreting the metrics of your font. I have attached a screenshot of what FontForge shows for the OS/2 > Metrics tab. There are significant differences e.g., a "Typo Line Gap" of zero for your font. It is possible this is contributing to the line spacing issue.
Comment 6 bordfeldt 2013-08-08 18:16:29 UTC
Today I tested LO 4.1.0 on Windows XP and here the font "Rotis Semi Sans" is displayed in the right way. So I think it's only a problem on linux machines.
Comment 7 bordfeldt 2013-09-10 08:51:07 UTC
After upgrading to 4.1.1.2 the problem still exists.
Comment 8 bordfeldt 2013-10-05 15:34:25 UTC
After upgrading to 4.1.2.3 the problem still exists.
Comment 9 bordfeldt 2014-01-30 18:35:52 UTC
After upgrading to 4.2.0.4 the problem still exists.
Comment 10 bordfeldt 2014-09-21 17:14:31 UTC
After upgrading to 4.3.1.2 the problem still exists. OpenOffice 4.1.0 on the same machine displays the font correctly.
Comment 11 bordfeldt 2015-02-27 10:57:33 UTC
After upgrading to 4.4.1.2 the problem still exists.
Comment 12 bordfeldt 2016-02-20 09:41:07 UTC
After upgrading to 5.1.0.3 the problem still exists.
Comment 13 bordfeldt 2016-08-03 16:04:41 UTC
After upgrading to 5.2.0.4 it works. I don't no why, but it works!
Comment 14 bordfeldt 2016-08-06 09:02:27 UTC
Sorry for this wrong information. I tested on Windows and in Windows this problem doesn't exist.
Todey tested under Linux with 5.2.0.4 problem is still present.
Comment 15 bordfeldt 2017-02-13 17:55:15 UTC
Tested under Windows 10 with LO 5.3.0.3. Problem now exists in windows too.
Comment 16 Xisco Faulí 2017-06-08 09:16:23 UTC Comment hidden (obsolete)
Comment 17 bordfeldt 2017-06-10 17:02:08 UTC
Sorry, it wasn't my intention to confirm my own bug. I only want to give a feedback that the bug is still present in newer versions.
Now I installed LO 5.3.3.2 and the problem still exists. This problem is very serious for me, because the affected font "Rotis ..." is the official font of my company and I run LO on over 50 desktops.
Comment 18 Buovjaga 2017-06-11 17:19:14 UTC
I confirm, but bordfeldt, please check the issue mentioned in comment 5. This is likely a problem in your font!!!
The reason you now see the "problem" on Windows is because the font layout engine is unified to use Harfbuzz on all platforms.
Comment 19 tommy27 2017-06-14 10:15:54 UTC
@bordfeldt
verify the possible bug reported against your font in comment 5
if it's confirmed it's not a LibO bug.

status NEEDINFO
Comment 20 QA Administrators 2018-01-02 10:15:27 UTC Comment hidden (obsolete)
Comment 21 QA Administrators 2018-01-29 10:36:29 UTC Comment hidden (obsolete)
Comment 22 bordfeldt 2018-02-04 13:27:15 UTC
Today tested with LO 6.0.0.3 on Windows 10 the problem is fixed. I will test this problem on linux-machines too.
Comment 23 bordfeldt 2018-02-05 09:42:38 UTC
Today tested with LO 6.0.0.3 on linux. Problem is solved on linux too.
Comment 24 Xisco Faulí 2018-02-05 10:25:38 UTC
Hi bordfeldt@web.de,
Thanks for testing it on Win and Linux, help is much appreciated.

In the QA Team we're always looking for contributors like you to help us to deal with LibreOffice's bugs.
I share some links with you in case you're interested in helping us a little more.
You can find more information about the QA in our wiki page[1], and if you need to can contact us, you can do it via IRC [2], Telegram [3] or the mailing list [4].

Keep up the good work.

Regards

[1]. https://wiki.documentfoundation.org/QA
[2]. https://wiki.documentfoundation.org/QA/IRC
[3]. https://t.me/LibreOffice_QA
[4]. https://wiki.documentfoundation.org/QA/Mailing_List