Bug 67847 - Auto icon size does not work or is inconsistent
Summary: Auto icon size does not work or is inconsistent
Status: RESOLVED DUPLICATE of bug 86445
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-06 22:09 UTC by Pedro
Modified: 2016-08-08 08:06 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro 2013-08-06 22:09:32 UTC
By default icon size is set to Auto. This should mean that there is an automatism that based on a given criteria (what is it?) it selects one of the icon sizes.

I believe it would make sense for that criteria to be the screen resolution but it doesn't seem to be so. On Windows the icon size is always small from 800x600 to 1280x1024 (haven't tried larger or smaller) but on Ubuntu it's always large.

Either the criteria is the OS or the Auto function is not working (or is working inconsistently from OS to OS)
Comment 1 ign_christian 2014-07-02 14:23:43 UTC
Hi Pedro.. Does LO 4.2.5.2 or 4.3.0.1 satisfy you? 

If no please change status back to UNCONFIRMED & give more details about last situation, otherwise RESOLVED WORKSFORME
Comment 2 Pedro 2014-07-03 19:00:52 UTC
Actually it's not any better. First it ignored my manually set Large size icons. Second the Galaxy theme was simply removed (in 4.3.0.2). Third "Automatic" icon size still automatically sets to Small on my 1280x1024 monitor? 

What is the criteria to switching to Large? Is it based on DPI?
Comment 3 Adolfo Jayme 2014-07-20 06:41:15 UTC
It’s based on the environment’s configuration. For example, GNOME defaults to large icons (you can tweak that), and most Windows applications use small icons (as seen in Office), but those are assumptions.
Comment 4 retired 2014-07-20 06:46:56 UTC
LO 4.3RC3 OSX 10.9.4

Switching LO > preferences > LibreOffice > View Icon size and style from Large to small for Sifr Icon set, does change the icon size here.

So maybe Linux only?
Comment 5 Pedro 2014-07-20 07:00:39 UTC
(In reply to comment #3)
> It’s based on the environment’s configuration. For example, GNOME defaults
> to large icons (you can tweak that), and most Windows applications use small
> icons (as seen in Office), but those are assumptions.

That is probably right. Automatic possibly means adjust to OS instructions (if any, I seriously doubt that Windows/Microsoft worries about icon size...)

But since LO already has implemented menu text size based on HiDPI (screen density) it would be more intelligent that the Toolbar icon size would adjust accordingly?

I will ping Keith Curtis who proposed (and partly developed?) the HiDPI changes
https://wiki.documentfoundation.org/ReleaseNotes/4.3#Initial_HiDpi_support
and ask his opinion.
Comment 6 Robinson Tryon (qubit) 2014-12-24 03:01:21 UTC
Component is ux-advise, so setting Status -> NEW.
Comment 7 Heiko Tietze 2016-08-07 08:47:40 UTC
Would say it has been fixed, right?
Comment 8 Pedro 2016-08-07 10:15:51 UTC
(In reply to Heiko Tietze from comment #7)
> Would say it has been fixed, right?

To be honest, I don't think so. I believe it was simply set to Large on all devices. No one could provide an answer to what the rule is in order for QA to test.

Obviously icon size has to be related to DPI (and not to screen resolution) so what is the DPI limit for this setting to change?
Comment 9 Yousuf Philips (jay) (retired) 2016-08-07 13:36:10 UTC
Auto used to have some code exclusively for windows but it was buggy and didnt work, so it was set to auto set it to large like all other OSes (bug 82309). I filed bug 86445 requesting that it check the screen size on load and set the icon size according, so likely it could be set as a duplicate of this.
Comment 10 Heiko Tietze 2016-08-08 08:06:58 UTC

*** This bug has been marked as a duplicate of bug 86445 ***