Download it now!
Bug 67892 - Linux LO 4.1.0.4 fails to open any OpenDocument format file from Samba Share
Summary: Linux LO 4.1.0.4 fails to open any OpenDocument format file from Samba Share
Status: RESOLVED DUPLICATE of bug 67527
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other Linux (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-08 09:48 UTC by grahha
Modified: 2013-11-13 19:18 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
error dialog 1 (21.84 KB, image/png)
2013-08-08 09:48 UTC, grahha
Details
error dialog 2 (9.44 KB, image/png)
2013-08-08 09:49 UTC, grahha
Details
error dialog 3 (9.35 KB, image/png)
2013-08-08 09:49 UTC, grahha
Details

Note You need to log in before you can comment on or make changes to this bug.
Description grahha 2013-08-08 09:48:28 UTC
Created attachment 83821 [details]
error dialog 1

Issue:
LibreOffice 4.1 on Linux can not open any OpenDocument files (.odt, .ods, etc) from Samba shares. It can however open Microsoft Office Created files (.doc, .docx, .xls, etc).

What happens:
1. Create a test.odt on your local machine, save it. Confirm it can be opened post save
2. Copy .odt to samba share
3. try and open test.odt (or any pre-exisiting file) you will be prompted with dialog box saying file is corrupt and do you want to repair (image1)
4. if you say 'yes' to repair it opens it in LibreOffice Math.
5. if you say 'no' you get a dialog box that says file could not be repaired, press ok. (image2)
6. It then repeats this process of steps 3&5 two more times before giving you 'General input / output error' (image3)

What should happen:
1. Create a test.odt on your local machine, save it. Confirm it can be opened post save
2. Copy .odt to samba share
3. Open file from share.

Software information:

Workstation:
$ lsb_release -rd
Description: Ubuntu 12.04.2 LTS
Release: 12.04

$ apt-cache policy libreoffice
libreoffice:
  Installed: 1:4.1.0-0ubuntu1~precise1~ppa1
  Candidate: 1:4.1.0-0ubuntu1~precise1~ppa1
  Version table:
 *** 1:4.1.0-0ubuntu1~precise1~ppa1 0
        500 http://ppa.launchpad.net/libreoffice/libreoffice-4-1/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status
     1:3.5.7-0ubuntu4 0
        500 http://ie.archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
     1:3.5.4-0ubuntu1.1 0
        500 http://security.ubuntu.com/ubuntu/ precise-security/main amd64 Packages
     1:3.5.2-2ubuntu1 0
        500 http://ie.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
Comment 1 grahha 2013-08-08 09:49:00 UTC
Created attachment 83822 [details]
error dialog 2
Comment 2 grahha 2013-08-08 09:49:19 UTC
Created attachment 83823 [details]
error dialog 3
Comment 3 Maxim Monastirsky 2013-08-08 11:18:18 UTC

*** This bug has been marked as a duplicate of bug 67527 ***