Download it now!
Bug 67899 - MS Word can't export to PDF a .doc file with a pasted shape from LibO Draw
Summary: MS Word can't export to PDF a .doc file with a pasted shape from LibO Draw
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-08 12:03 UTC by Reinhard Weber
Modified: 2015-04-27 09:43 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Word 2007 error message after trying to save as PDF with an embedded Libreoffice object. (69.61 KB, image/png)
2013-08-08 12:03 UTC, Reinhard Weber
Details
Word DOC with pasted rectangle form Apache Office (26.50 KB, application/msword)
2013-08-22 08:38 UTC, Reinhard Weber
Details
Word DOC with pasted rectangle form Libre Office (26.50 KB, application/msword)
2013-08-22 08:39 UTC, Reinhard Weber
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Reinhard Weber 2013-08-08 12:03:31 UTC
Created attachment 83831 [details]
Word 2007 error message after trying to save as PDF with an embedded Libreoffice object.

Problem description: 

Steps to reproduce:
1. Create an empty Word document.
2. Do the same with an empty Libreoffice Draw document.
3. Draw a simple shape and put it with [STRG] + [C] into the clipboard
4. Paste it to your Word document.
5. Try to save the Word document as PDF or XPS.

Current behavior:

In my german version of word 2007 an error message 'Unerwarteter Fehler beim Exportieren' appears. In english something like 'Unexpected error during export ...'. This effect happend first with version 4.1.0.4 of Libreoffice.

Expected behavior:

A hassle free export to PDF also from Word ;)

Regards
Reinhard Weber

              
Operating System: Windows 7
Version: 4.1.0.4 release
Comment 1 tommy27 2013-08-20 14:09:29 UTC
why don't you directly copy your Draw document to Writer and then export to PDF using LibO built-in feature?

I don't get the point of going trough Word...
Comment 2 Reinhard Weber 2013-08-20 18:04:49 UTC
The reason for using Ms Word is a present template, but the prefered document editor isn't important - the case is, that Draw obviously creates problematic enhanced meta files.
Comment 3 tommy27 2013-08-20 18:29:12 UTC
so why don't you open that MS Word template directly with Writer and paste content from Draw, then export as PDF?

Writer should be able to load .doc and .docx files, so I still don't see the reason for using 2 different softwares while you can do the whole thing with just one...
Comment 4 tommy27 2013-08-20 18:31:06 UTC
moreover, what do you use to convert the Word file to .pdf?
Comment 5 tommy27 2013-08-20 18:36:14 UTC
changed summary notes
Comment 6 Reinhard Weber 2013-08-21 19:55:27 UTC
(In reply to comment #4)
> moreover, what do you use to convert the Word file to .pdf?

Simply the build in function File > Save as > PDF or XPS ... is used to save the document as PDF. Btw: external tools like PDF-Printers are working.
Comment 7 tommy27 2013-08-22 07:26:11 UTC
IMHO this is a bug of Word PDF export feature.

if you do all the copy-paste-PDFexport procedure with LibO things work.
if you use a virtual PDF printer things work.

so why blaming LibO if the only program failing the PDF-export thing is MS Word?

I set status to RESOLVED NOTOURBUG.
Comment 8 Reinhard Weber 2013-08-22 07:52:12 UTC
(In reply to comment #7)
> IMHO this is a bug of Word PDF export feature.

if you do all the
> copy-paste-PDFexport procedure with LibO things work.
if you use a virtual
> PDF printer things work.

so why blaming LibO if the only program failing
> the PDF-export thing is MS Word?

I set status to RESOLVED NOTOURBUG.

Thanks for the info. In case of such ignorance I switched to Apache Open Office 4 where the described defect of LO Draw works quite well! I repent just of my payed donations to LO ...
Comment 9 tommy27 2013-08-22 08:12:59 UTC
(In reply to comment #8)
>
> ...
> 
> so why blaming LibO if the only program failing
> > the PDF-export thing is MS Word?
> 
> I set status to RESOLVED NOTOURBUG.
> 
> Thanks for the info. In case of such ignorance I switched to Apache Open
> Office 4 where the described defect of LO Draw works quite well! I repent
> just of my payed donations to LO ...


There's no reason reacting this way... You should have said before that Apache OpenOffice did not have this interaction bug with Word. No such information is present in your previsous posts.

I change status to REOPENED because of the new information provided.

please, upload that .doc file with pasted image from Draw so it can be exhamined by a developer.
Comment 10 Reinhard Weber 2013-08-22 08:38:36 UTC
Created attachment 84434 [details]
Word DOC with pasted rectangle form Apache Office
Comment 11 Reinhard Weber 2013-08-22 08:39:08 UTC
Created attachment 84435 [details]
Word DOC with pasted rectangle form Libre Office
Comment 12 Reinhard Weber 2013-08-22 08:42:03 UTC
(In reply to comment #11)
> Created attachment 84435 [details]
> Word DOC with pasted rectangle form Libre Office

Open the DOC with Word 2007 or 2010 and try to 'Save as' > 'PDF or XPS' ...
Comment 13 tommy27 2013-08-22 12:33:04 UTC
thanks 4 the attached files. they will help a lot.
unfortunately I don't have MS Word to test so I ask help from other QA guys.

modified the summary notes to make clearer that the PDF export has to be done with MS Word

just some final questions for you (please reply, feedback is important):

1- which Apache OO version did you use?

2- have you tried exporting to PDF with Word an .odt file with a Draw shape? is there still different behaviour between AOO and LibO?

3- why not opening the original .doc file with LibO Writer instead of MS Word? I suppose you know that LibO can read and save .doc files as well. Again, see Comment 3, I don't understand why using Word instead of Writer to open a file just to paste elements from Draw... you could do the whole thing with just one software.

changing status to UNCONFIRMED again.
when the bug will be independently reproduced by another user status can be changed to NEW which means the bug is confirmed.
Comment 14 Reinhard Weber 2013-08-22 13:18:25 UTC
(In reply to comment #13)
> thanks 4 the attached files. they will help a lot.
unfortunately I don't
> have MS Word to test so I ask help from other QA guys.

modified the summary
> notes to make clearer that the PDF export has to be done with MS Word

just
> some final questions for you (please reply, feedback is important):

1-
> which Apache OO version did you use?

2- have you tried exporting to PDF
> with Word an .odt file with a Draw shape? is there still different behaviour
> between AOO and LibO?

3- why not opening the original .doc file with LibO
> Writer instead of MS Word? I suppose you know that LibO can read and save
> .doc files as well. Again, see Comment 3, I don't understand why using Word
> instead of Writer to open a file just to paste elements from Draw... you
> could do the whole thing with just one software.

changing status to
> UNCONFIRMED again.
when the bug will be independently reproduced by another
> user status can be changed to NEW which means the bug is confirmed.

My last satement to clarify this issue: I've to write my thesis based on a Microsoft Word template. Writer cannot be used for this need, because it doesn't handle the styles correctly (but this isn't part of this ticket).

My drawings are all done with Libre Office Draw. These drawings are copied from a Libre Office Draw document ([CTRL] + [C]) into Word ([CTRL] + [V]. After that, it isn't possible to save the Word dokument as a PDF or XSP with the original build in Microsoft export feature.

When I open the same Draw ODG file with Apache Open Office 4.0.0 and copy the same sketch from the ODG file to the Word document it IS possible to save the Word document as PDF os XSP ...

This proofs, that there is a difference of handling enhanced meta files between Libre Office Draw and Apache Office Draw because using Apache the build in feature of Word to export the document as PDF (or XSP) still works ...
Comment 15 tommy27 2013-08-22 14:04:07 UTC
Ok, Reinhard. Everything is finally clear. I really hope some developer may identify the issue and fix the problem.

If you had given all the complete informations at the beginning (i.e. things don't work in LibO and work in AOO) there would not have been any dispute or anymosity during this dialog between you and me.

I'm just a QA volunteer, spending my time trying to triage bug reports and helping users like you... obviously if you don't describe the "whole picture" some misunderstandings may happen as it did.

I hope that after this clarification we could shake hands.
Comment 16 Reinhard Weber 2013-08-22 14:25:35 UTC
(In reply to comment #15)
> Ok, Reinhard. Everything is finally clear. I really hope some developer may
> identify the issue and fix the problem.

If you had given all the complete
> informations at the beginning (i.e. things don't work in LibO and work in
> AOO) there would not have been any dispute or anymosity during this dialog
> between you and me.

I'm just a QA volunteer, spending my time trying to
> triage bug reports and helping users like you... obviously if you don't
> describe the "whole picture" some misunderstandings may happen as it did.

I
> hope that after this clarification we could shake hands.

I've to appologize for my impatience. It was my fault, believing the first description was detailled enough to clear up the hole situation. Shaking hands with a smile!
Comment 17 Michel Rudelle 2013-09-14 12:53:50 UTC
Hi,
I confirm this bug:

1st test using your 2 examples:
"Word DOC with pasted rectangle form Apache Office" => export PDF from Word 2010 is ok
"Word DOC with pasted rectangle form Libre Office" => export from Word 2010 failed (with the same message in French you received)

2nd test using your initial procedure:
export from Word 2010 failed

Platform: windows 7
LibreOffice 4.1.1.2
Word 2010

Regards
Comment 18 tommy27 2013-09-14 13:04:04 UTC
bug officially confirmed. adding Writer expert to CC list.
Comment 19 QA Administrators 2015-04-01 14:42:07 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-01
Comment 20 Buovjaga 2015-04-27 09:43:36 UTC
Export from Word 2013 works. Setting to WFM. If you still have problems, set back to new.

Win 8.1 32-bit
MSO 2013
LibO Version: 5.0.0.0.alpha1+
Build ID: f0edb677f09ad338e22ac3b5d91497b4479e0b3c
TinderBox: Win-x86@39, Branch:master, Time: 2015-04-27_00:34:58
Locale: fi_FI