Download it now!
Bug 67912 - FORMATTING of dashed line has a different fill pattern than in Visio
Summary: FORMATTING of dashed line has a different fill pattern than in Visio
Status: RESOLVED WONTFIX
Alias: None
Product: Document Liberation Project
Classification: Unclassified
Component: libvisio (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-08 17:56 UTC by m_josenhans
Modified: 2017-10-30 11:44 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Diagramm with one dashed line. (42.71 KB, application/x-zip-compressed)
2013-08-08 17:56 UTC, m_josenhans
Details
screenshot - Visio (9.77 KB, image/png)
2015-12-30 16:15 UTC, David Tardon
Details
screenshot - LibreOffice (11.73 KB, image/png)
2015-12-30 16:16 UTC, David Tardon
Details
sample diagram (57.00 KB, application/vnd.visio)
2015-12-30 16:16 UTC, David Tardon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description m_josenhans 2013-08-08 17:56:15 UTC
Created attachment 83858 [details]
Diagramm with one dashed line.

The dashed line has more dashes in LibreOffice 4.0.3.3 than in Visio.

This bug has been verified with Windows and Linux.
Comment 1 Mike Kaganski 2013-08-09 01:32:00 UTC
Reproducible with 4.1.0.4 under Win7x64.

Also note that largest circle at the line end is misaligned (it should be aligned to center of vertical line).
Comment 2 m_josenhans 2013-08-09 17:52:16 UTC
(In reply to comment #1)
> Reproducible with 4.1.0.4 under Win7x64.
> 
> Also note that largest circle at the line end is misaligned (it should be
> aligned to center of vertical line).

Please also note that the misalinged circile is large, in fact too large. It seems that it should be of the same size as the other smaller circiles.
Comment 3 Julien Nabet 2013-08-24 06:35:23 UTC
On pc Debian x86-64 with master sources updated yesterday, I reproduced the problem.
Just several times this log:
warn:legacy.osl:14827:1:svx/source/sdr/contact/viewcontactofsdrpathobj.cxx:67: PolyPolygon object without geometry detected, this should not be created (!)
Comment 4 QA Administrators 2015-12-20 16:11:03 UTC Comment hidden (obsolete)
Comment 5 m_josenhans 2015-12-22 17:16:28 UTC
The bug remains. 
Tested with LibreOffice Impress Version: 4.4.6.3, Build ID: 40m0(Build:3) on linux. Locale: en_US.UTF-8
Comment 6 David Tardon 2015-12-30 16:15:44 UTC
Created attachment 121642 [details]
screenshot - Visio
Comment 7 David Tardon 2015-12-30 16:16:12 UTC
Created attachment 121643 [details]
screenshot - LibreOffice
Comment 8 David Tardon 2015-12-30 16:16:49 UTC
Created attachment 121644 [details]
sample diagram
Comment 9 David Tardon 2015-12-30 16:18:40 UTC
(In reply to m_josenhans from comment #5)
> The bug remains. 
> Tested with LibreOffice Impress Version: 4.4.6.3, Build ID: 40m0(Build:3) on
> linux. Locale: en_US.UTF-8

Citing from comment #4: "Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.4 or later)"
Comment 10 Fridrich Strba 2015-12-30 16:28:31 UTC
I understand that it might be confusing to see such differences between visio rendering and LO rendering. But...
Visio does not scale the line patterns, so if you scale the whole shape, the line pattern will be the same with the same length of gap and of dash. In ODF, the dashes are scaled with the shape.
There are these little conceptual differences that are preventing us from having the conversion result 100% visually equivalent. That is the life :(
Closing as WONTFIX, because there is no way to fix it reasonably
Comment 11 m_josenhans 2015-12-30 21:49:17 UTC
Thank you for the calrification. So it is an ODF issue? 
Is it worth for ODF Standardization to make ODF more generic to add scale attributes to have better compatiblity with Visio etc.?