Bug 67952 - Auto fit canvas to drawing
Summary: Auto fit canvas to drawing
Status: RESOLVED DUPLICATE of bug 81118
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-09 14:38 UTC by codobanmihai
Modified: 2016-06-30 14:02 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description codobanmihai 2013-08-09 14:38:35 UTC
In Libreoffice Draw, there is no way to auto fit the canvas size to the drawing. One has to painstakingly manually set the width and height until it encompasses the whole drawing through several trial and error runs.

This is a major drawback to the software, since it is a use case that I need to perform every time I make a drawing: Upon finishing the drawing, I would want the canvas to be as big as the drawing.

Feature request: Put an "Auto fit canvas to drawing" button that sets the canvas dimensions to the nearest rectangle that fits the whole drawing.

Alternative: Make the canvas automatically follow the drawing (call above function whenever something is changed).

Alternative: Loose / hide the canvas complexity entirely. It's either an implementation detail that the user does not need to know about when drawing, or it's a relic from the days we used paper, which had finite bounds.

The only time I may indeed have to worry about the canvas is when dealing with limited space, e.g., printing to finite sized paper.
Comment 1 codobanmihai 2013-08-09 14:42:39 UTC
There may also be times when you want your drawing to be encompassed in a rectangle of a certain ratio (user defined or paper standards (letter, A4, etc)). This would also be a place where you actually need a canvas.
Comment 2 Owen Genat (retired) 2013-12-21 11:09:49 UTC
Related AskLO thread:

http://ask.libreoffice.org/en/question/18185/how-to-adjust-page-size-to-fit-an-object/

I agree this would be a good feature to have. Confirmed. Status set to NEW. Component set to Drawing. Version set to Inherited From OOo as this has never been possible in LO.
Comment 3 emil 2015-08-31 03:11:57 UTC
I just encountered the same lack of feature, so I'd like to state here that I too would like it.
Comment 4 Heiko Tietze 2016-06-30 14:02:37 UTC
Same discussion on the other ticket. Copied the reference to asklibo to this bug.

*** This bug has been marked as a duplicate of bug 81118 ***