Bug 67984 - behaviour with repeated find
Summary: behaviour with repeated find
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-10 14:34 UTC by klausg
Modified: 2015-06-20 15:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description klausg 2013-08-10 14:34:57 UTC
1. correct behaviour:
search for aaa
  press contr f 
  enter aaa; press enter
  cell is found and put in a frame
  search field shows aaa
  click any other cell in table
search for bbb
  press contr f 
  enter bbb; press enter
  cell is found and put in a frame
  search field shows bbb
  click any other cell in table
a.s.o.

2. "crazy" behaviour
search for aaa
  press contr f 
  enter aaa; press enter
  cell is found and put in a frame
  search field shows aaa
  do NOT click any other cell now and do a new search
search for bbb
  press contr f 
  enter bbb; press enter
  cell is NOT found
  search field shows aaabbb

I would not expect this behaviour.
A new search (contr f) should REPLACE the previous search entry
Currently have no EXCEL at hand to compare behaviour, but the google free online spreadsheet is doing as expected

I would rate the behaviour in libre offic as nuisance or annoying
Comment 1 klausg 2013-08-10 14:37:19 UTC
same behaviour as well in LO 3.4
Comment 2 Urmas 2013-08-10 19:05:30 UTC
In a human language: if the search from Search bar was not interrupted, the entire text in it is not highlighted as when it takes the focus otherwise.
Comment 3 Joel Madero 2015-05-02 15:42:10 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02
Comment 4 Buovjaga 2015-06-20 15:04:15 UTC
If I press ctrl-f again after finding aaa, it highlights aaa in the search box and I will overwrite it with bbb.
WFM.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-19_23:16:58
Locale: fi-FI (fi_FI)