Bug 68050 - UI: Fields dialog does not preserve scroll position when focussed
Summary: UI: Fields dialog does not preserve scroll position when focussed
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Fields-Dialog
  Show dependency treegraph
 
Reported: 2013-08-13 10:14 UTC by freddi34
Modified: 2021-01-16 04:17 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample document with endnotes (12.04 KB, application/vnd.oasis.opendocument.text)
2015-03-11 17:23 UTC, Gordo
Details
LibreOffice Writer document to show the issue. (19.73 KB, application/vnd.oasis.opendocument.text)
2015-03-13 18:24 UTC, freddi34
Details

Note You need to log in before you can comment on or make changes to this bug.
Description freddi34 2013-08-13 10:14:43 UTC
Problem description: 
In the Cross-references tab of the Fields dialog, there is a scrollable Selection field with references. When the dialog has no focus and you scroll over it and click a reference, it will reset the scroll position to where it was left the last time the dialog had focus, and the click will insert the wrong reference.

Steps to reproduce:
1. Insert into a document several items for which cross-references can be created (end notes etc.)
2. Click in the menu Insert → Cross-Reference
3. Focus the document (for example to continue writing while keeping the dialog open)
4. Hover over the Selection list and scroll down
5. Click the reference that is below the cursor in order to insert it.

Current behavior:
As soon as the dialog gets focussed, the scrollable list resets to the position where it was when it had focus the last time. Now item below the cursor is a different one and the wrong cross-reference is inserted.

Expected behavior: 
The list does not change its scroll position when it gets focus. Thus the cross-reference is inserted that is below the cursor when the click happened.

This issue happens in both Ubuntu 13.04 (Unity) and 10.04 (Gnome).
Operating System: Ubuntu
Version: 4.0.1.2 release
Comment 1 ign_christian 2014-07-04 04:56:41 UTC
Hello.. Is it still reproduce in LO 4.2.5.2 ?

If problem solved please change status to RESOLVED WORKSFORME, else UNCONFIRMED & provide simple test file along with procedure to see the problem.
Comment 2 QA Administrators 2015-02-19 04:38:20 UTC Comment hidden (obsolete)
Comment 3 Gordo 2015-03-11 17:23:57 UTC
Created attachment 114044 [details]
Sample document with endnotes

1. Open attached document.
2. Place cursor after a sentence and after sentences with endnotes.
3. Insert → Cross-reference.
4. Select Type → Endnotes.
5. Scroll down list but don't select any of the endnotes (first item in list is still selected).
6. Click back on the document.
7. Select endnote xxii in cross reference dialog.
Expected Result:
Endnote xxii is highlighted.
Result:
Selection jumps to xxvii, which is highlighted.  At this point you don't have to insert the wrong reference.
Alternate:
6. Switch to another open application.
7. Switch back to document.
Result:
Scroll position has reset.

This is in Windows Vista (Really?!).  The only difference I had with how it was reported is that it was not possible to mouse wheel scroll when the cross reference dialog does not have focus.

Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Comment 4 A (Andy) 2015-03-11 20:42:49 UTC
Reproducible with LO 4.4.1.2, Win 8.1
Comment 5 freddi34 2015-03-13 18:24:33 UTC
Created attachment 114086 [details]
LibreOffice Writer document to show the issue.

This is still an issue in LibreOffice Writer 4.3.3.2, nothing has changed.

To enhance the bug description above:
You need to have enough foot/end notes so that the Cross Reference/Selection list is scrollable. This issue becomes only visible on operating systems that do scrolling on the UI element under the cursor position (and not on UI element that has keyboard focus as in Windows).
When focusing an unfocused Cross References window, the scroll position jumps back to the top, which results in that the wrong list element gets the mouse click event, and the wrong cross reference is inserted. Messing around with scroll position is not a good usability pattern.

Attached is an example document with clear instructions to show the issue.
Comment 6 tommy27 2016-04-16 07:28:24 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2017-05-22 13:26:20 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2021-01-16 04:17:48 UTC
Dear freddi34,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug