Bug 68074 - FILESAVE: Formula in calc disappear if there is a error result in cell and save from ods to xsl
Summary: FILESAVE: Formula in calc disappear if there is a error result in cell and sa...
Status: CLOSED DUPLICATE of bug 67571
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-08-13 17:40 UTC by vlb
Modified: 2013-11-20 15:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Test file (38.40 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-08-14 15:41 UTC, vlb
Details
Test file where d_ef is define (41.50 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-08-14 17:19 UTC, vlb
Details
Test file with non defined range in formula (41.47 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-08-14 19:58 UTC, vlb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vlb 2013-08-13 17:40:18 UTC
LO 4.1.04 windows 64 bits and master 4.2

LO 4.0.4.2 was save oke -> regression

When i save a sheet from ods to xls there are delete some formule in the sheet.
When i save the sheet to xlsx the formule is oke.
Comment 1 m.a.riosv 2013-08-13 22:40:42 UTC
Hi vlb, thanks for reporting.

Please can you attach an ods with which reproduce the issue.
Comment 2 vlb 2013-08-14 05:21:33 UTC
I have a sheet but isn't for public.
Comment 3 m.a.riosv 2013-08-14 12:08:26 UTC
Can't you prepare a simple sheet with one cell with the formula, to see the issue?
Comment 4 vlb 2013-08-14 15:41:55 UTC
Created attachment 84061 [details]
Test file

File for reproduce bug
Comment 5 vlb 2013-08-14 15:43:23 UTC
Reproduce:
1-open file H-test
2-change cel D11 in "Houtschroef"
3-save as *.xls
4-in cel j28..j33 and L28..L33 are lost formula
5-when open in excel there is a error notifier and a other formula

Not reproduce:
1-open file H-test
2-save as *.xls
Comment 6 m.a.riosv 2013-08-14 16:25:51 UTC
Seems the:
In the formula there is a range name d_ef that does not exist.
Comment 7 vlb 2013-08-14 17:19:38 UTC
Created attachment 84066 [details]
Test file where d_ef is define

It thoesn't matter that the name isn't defined, because the issue is that when er a cel is what isn't correct calculate then the cel isn't correct save to xls.
Comment 8 m.a.riosv 2013-08-14 17:39:50 UTC
Please vlb, to set the status as NEW, the right way is that other person different than the reporter confirm the bug.

Replacing the non existent range name d_ef with a value like 0, formulas do not disappear saving as xls.

Please can you verify if the formulas disappear only when a non defined range name is in the formula?
Comment 9 vlb 2013-08-14 19:56:43 UTC
(In reply to comment #8)
 
> Replacing the non existent range name d_ef with a value like 0, formulas do
> not disappear saving as xls.
Thats right!

> Please can you verify if the formulas disappear only when a non defined
> range name is in the formula?
When the formula have non defined range than the formula isn't deleted in ods, but in xls is there a error and is the formula incorrect!
See also file Test file 3 "H-test-2".
Comment 10 vlb 2013-08-14 19:58:05 UTC
Created attachment 84071 [details]
Test file with non defined range in formula
Comment 11 m.a.riosv 2013-08-14 21:05:42 UTC
Hi vlb, after several tries seems that the issue is whenever a formula has an error result, the formula disappear after reload, only the equal is there.

If you are agree please change the title to a more explicit explanation.

Changed the status to NEW.

Added to MAB 4.1 because there is a dataloss.
Comment 12 m.a.riosv 2013-08-14 21:15:04 UTC
Steps to reproduce the problem:

Open a new spreadsheet.
Enter in any cell:
+1/0
Save as xls.
Reload the file.
The formula is not there, only the equal.

Win7x64i3Ultimate
Version: 4.1.1.0.0+ Build ID: c1f0f890f5065f88164add33707228f8c6d5755
TinderBox: Win-x86@6-debug, Branch:libreoffice-4-1, Time: 2013-08-10_15:58:51
Comment 13 m.a.riosv 2013-08-14 23:09:33 UTC
This bug is a duplicate of 67571.

Hi @vlb if you are not agree, please reopen it.

*** This bug has been marked as a duplicate of bug 67571 ***