Bug 68141 - very high CPU and HDD load when making a LibO clipboard selection and NetBeans is on
Summary: very high CPU and HDD load when making a LibO clipboard selection and NetBean...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-15 10:11 UTC by Kai M
Modified: 2014-07-20 13:09 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kai M 2013-08-15 10:11:21 UTC
When I make a selection to the clipboard, one core of my cpu and even my harddisc(!) is under full load. This is always reproduceable on my system.

libreoffice does _not_ freeze and I can stop this immediately by making another clipboard selection anywhere on the system.

This affects writer, calc and impress.

Calc and Impress is affacted only when I select a cell respective an object. It is not affected by "normal" text selection e.g. when double clicking in a cell/object.

I am using Libreoffice 4.1.0.4 from ubuntu ppa now, but the previous version 3.5.4-0ubuntu1.1 had the same issue.

Steps to reproduce:
1) Open Writer
2) Write a few characters
3) Select the characters an press ctrl+c

My system:
Kubuntu 12.04.2 LTS 

Thanks for your help.
Comment 1 Jean-Baptiste Faure 2013-09-14 16:14:19 UTC
I do not remember I never had such problem with the generic Linux version downloaded from LibreOffice website.

I guess it is an Ubuntu bug, but could you try the generic Linux version to confirm this?

Best regards. JBF
Comment 2 Jean-Baptiste Faure 2013-11-10 16:19:30 UTC
Hi Kai M,
Current stable release is now 4.1.3, did you try it ?

Best regards. JBF
Comment 3 Kai M 2013-12-09 11:17:04 UTC
Sorry, for my late reply. I didn't get any notices via mail.

I installed the debian Packages from LO Website. Version now is 4.1.3.2.

Sadly, the problem stays the same.
Comment 4 Jean-Baptiste Faure 2013-12-11 18:41:34 UTC
Ok, will try something else:
Are you using some clipboard manager, such a software which allows to manage multiple clipboards? If it is the case, you should try with this software deactivated.

Best regards. JBF
Comment 5 Kai M 2013-12-16 14:15:03 UTC
Hello Jean-Baptiste,

thanks for your help.

KDE is shipped with the clipboard manager "Klipper".

Shutting it down didn't help.
Comment 6 Jean-Baptiste Faure 2013-12-17 20:40:29 UTC
Ok, another try: do you use some accessibility technology?

Best regards. JBF
Comment 7 Kai M 2013-12-20 12:41:51 UTC
I don't use accessibility technology.

It is the soffice.bin process that is causing the high load.
The IO Write is up to 87K/s. Apparently no IO Read.

I have been watching it more than 15 minutes writing to the disk, but I don't know what the process is writing.
Comment 8 Kai M 2014-05-07 16:04:19 UTC
I got a new Info about this.

This issue is related to Netbeans IDE (http://netbeans.org/). 
I use the Netbeans PHP version 7.3.

When shutting down Netbeans, the problem with LO causing high load is gone.

Immediately after starting Netbeans again, the high load returns, if I got something from Libre Office in the Clipboard.

As a developer, my Netbeans is always open. It is really critical to me.

Kai
Comment 9 Jean-Baptiste Faure 2014-05-07 18:59:47 UTC
Thank you for this informations. No other question for the moment. Set status back to unconfirmed until independent confirmation.

Best regards. JBF
Comment 10 tommy27 2014-06-22 07:09:50 UTC
(In reply to comment #8)
> I got a new Info about this.
> 
> This issue is related to Netbeans IDE (http://netbeans.org/). 
> I use the Netbeans PHP version 7.3.
> 
> When shutting down Netbeans, the problem with LO causing high load is gone.
> 
> Immediately after starting Netbeans again, the high load returns, if I got
> something from Libre Office in the Clipboard.

so it seems there's a conflict between LibO and NetBeans (and I wonder if this is a LibO or rather a NetBeans bug)

what about new 4.2.5.2 release? is issue still there.
set status to NEEDINFO
Comment 11 Kai M 2014-07-04 07:37:18 UTC
(In reply to comment #10)
> what about new 4.2.5.2 release? is issue still there.
> set status to NEEDINFO

I tried version 4.2.5.2 and the 4.3 prerelease.
The issue is still there.

Lately I went over to Kubuntu 14.04 on a SSD. I do not have this issue there.
Comment 12 Jean-Baptiste Faure 2014-07-20 13:09:00 UTC
(In reply to comment #11)
[...]
> Lately I went over to Kubuntu 14.04 on a SSD. I do not have this issue there.

Ok, thank you for the information. Closing as NotOurBug because the fix is external to LibreOffice (upgrading the distro & KDE). Feel free to reopen if the problem comes back for you.

Best regards. JBF