Bug 68154 - Excel Document Locks When Dropdown Cell Activated
Summary: Excel Document Locks When Dropdown Cell Activated
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-15 15:33 UTC by Dave Richards
Modified: 2015-06-18 15:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Document that deadlocks LO (59.00 KB, application/vnd.ms-excel)
2013-08-15 15:33 UTC, Dave Richards
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Richards 2013-08-15 15:33:06 UTC
Created attachment 84104 [details]
Document that deadlocks LO

In the attached documented, in the sheet labeled "Overlay Wishlist Form", if you select the drop down cell next to "OST Agency Name" the busy symbol appears and then it never opens.  This puts your mouse into an odd state from which it never returns.  LO has to be forced killed.

This document fails in LO 4.0 and 4.1 but seems to work in OpenOffice.

Tested only on Linux.
Comment 1 m.a.riosv 2013-08-16 01:07:44 UTC
Hi Dave, thanks for reporting.

The range for dropdow is "OST_Agency" = $'CCC Use Only'.$A$1:$A$1048576, the all column rows, a very long range for a dropdow list.

I have not excel to verify but maybe the issue is that the range is defined in excel as a column, and as LibreOffice does not support ranges defined only by their column/row, they are imported in LibreOffice as ranges addressed to the all rows/columns.

I think the workaround is change the range definition to a short range e.g.:
$'CCC Use Only'.$A$1:$A$500
which must work in both programs.
Comment 2 Dave Richards 2013-08-16 13:01:29 UTC
These documents are built by outside agencies and downloaded from their site by our employees.  We don't have control over the way they are built or work unfortunately.

This should just work, especially if it goes in OpenOffice.  This is a regression.

Thank you for the work around; it should assist us with this currently downloaded document.  But a long term fix is needed.
Comment 3 Dave Richards 2013-08-16 17:51:03 UTC
Our support staff indicated:

I changed .$A$1:$A$1048576 to .$A$1:$A$500 Same result Click on the drop down and it is blank except the first item then the document locks.
I have to keep killing myself out of libre.  The same thing happens with the libre office version on the pc.  Open Office works well
with the document.  The openoffice v 3.4.1.
Comment 4 m.a.riosv 2013-08-16 22:38:40 UTC
Hi Dave,
seems to work with only a little delay to show the list marking the sorting option in validity (Menu/Data/Validity - Criteria), and does not show blank cells.
Also changing the definition range to a formula:
OFFSET($'CCC Use Only'.$A$1;1;1;COUNTA($'CCC Use Only'.$A$1:$A$1048576);1)
even disable the sort option in validity, works nice. 

In any case the issue is reproducible with:
Win7x64i3Ultimate
Version: 4.1.1.0.0+ Build ID: c1f0f890f5065f88164add33707228f8c6d5755
TinderBox: Win-x86@6-debug, Branch:libreoffice-4-1, Time: 2013-08-10_15:58:51
Comment 5 QA Administrators 2015-04-19 03:22:44 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 6 Buovjaga 2015-06-18 15:24:01 UTC
Works now.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 437210d58f32177ef1829d704f7f4d2f1bbfbfdd
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-18_07:21:56
Locale: fi-FI (fi_FI)