Bug 68216 - Titlebar of some popup windows is hidden under Unity panel (Ubuntu)
Summary: Titlebar of some popup windows is hidden under Unity panel (Ubuntu)
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-17 11:38 UTC by pharmankur
Modified: 2014-07-17 11:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sound Player - Close-Minimise Buttons not present (84.99 KB, image/png)
2013-08-17 11:38 UTC, pharmankur
Details
Countour Editor - Close-Minimise Buttons not present (45.32 KB, image/png)
2013-08-17 11:40 UTC, pharmankur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pharmankur 2013-08-17 11:38:45 UTC
Created attachment 84172 [details]
Sound Player - Close-Minimise Buttons not present

Problem description: 
I am using Ubuntu 13.04 & Libreoffice 4.1.0
I Cannot See Close, Minimise, Maximise Buttons on some specific pop up windows.

Steps to reproduce:
1. Open Writer, Maximise the window (very important)
2. Open Gallary , Go to Sounds
3. Play any sound file (say "Apert")
4. A media player window will open & play the sound. But the window do not have Close, Minimise, Maximise Buttons. It keeps open & is very irritating.
Even if you close the Writer & reopen it, still you will find media player window open & it cannot be moved resized etc. It also hides all the menu items.

Exactly same behavior is there for COUTOUR EDITING window 
1. Search any .gif file on google image search in any browser
2. Copy original imager (by right clicking in browser window)
3. Paste the image in Writer
4. Right click on image --> Warp --> Edit Countour
Editing window will be opened. But again there will be no Close, Minimise, Maximise Buttons on the pop up window.
Even if you close the Writer & reopen it, still you will find countour editing  window open, which cannot be closed.

The only way I found to remove these Pop Up windows is --> go to home --. .Config --> delete 'Libreoffice' folder --> Restart Writer


Current behavior: As explained above

Expected behavior: There should be Close, Minimise, Maximise Buttons on the pop up window.
Operating System: Ubuntu
Version: 4.1.0.4 release
Comment 1 pharmankur 2013-08-17 11:40:01 UTC
Created attachment 84173 [details]
Countour Editor - Close-Minimise Buttons not present
Comment 2 tommy27 2013-08-23 13:04:07 UTC
tested on 4.1.0.4 under Win7 64bit.
the media player here has just one close button ("x") while reporter screenshot show no button at all.

probably a Linux specific bug.
Comment 3 tommy27 2013-09-10 19:25:13 UTC
(In reply to comment #0)
> Created attachment 84172 [details]
> Sound Player - Close-Minimise Buttons not present
> 
> Problem description: 
> I am using Ubuntu 13.04 & Libreoffice 4.1.0
> I Cannot See Close, Minimise, Maximise Buttons on some specific pop up
> windows.
> 

try upgrading to 4.1.1
is bug still there?
Comment 4 pharmankur 2013-09-11 13:55:22 UTC
Yes, The problem is very much there ...
Also I cannot move sound player window to any other place. It is fixed to
upper left corner.

Regards,
Ankur Joshi


On Wed, Sep 11, 2013 at 12:55 AM, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 3 <https://bugs.freedesktop.org/show_bug.cgi?id=68216#c3> on bug
> 68216 <https://bugs.freedesktop.org/show_bug.cgi?id=68216> from tommy27<barta@quipo.it>
> *
>
> (In reply to comment #0 <https://bugs.freedesktop.org/show_bug.cgi?id=68216#c0>)> Created attachment 84172 [details] <https://bugs.freedesktop.org/attachment.cgi?id=84172> [details] <https://bugs.freedesktop.org/attachment.cgi?id=84172&action=edit>
> > Sound Player - Close-Minimise Buttons not present
> >
> > Problem description:
> > I am using Ubuntu 13.04 & Libreoffice 4.1.0
> > I Cannot See Close, Minimise, Maximise Buttons on some specific pop up
> > windows.
> >
>
> try upgrading to 4.1.1
> is bug still there?
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 5 Maxim Monastirsky 2013-09-11 14:23:47 UTC
@pharmankur:
Hi,
In fact the popup window does have a close button, but it's hidden under Unity panel. Probably it's Unity bug, so closing as NOTOURBUG. You should open a bug for Ubuntu instead.

Workaround: Press Alt+Space and choose 'Move' from the popup menu. Then you can move the popup window.
Comment 6 Kevin Suo 2014-07-17 11:45:28 UTC
This is ubuntu's bug, and is now fixed, see:
 https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1303462