Bug 68345 - Libre Calc saving as XLSX
Summary: Libre Calc saving as XLSX
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-20 16:54 UTC by Help Desk
Modified: 2013-08-21 16:11 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
XLSX file with hidden columns... (10.28 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-08-21 12:59 UTC, Help Desk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Help Desk 2013-08-20 16:54:30 UTC
After saving a Calc spreadsheet as Microsoft Office XLSX (2007/2010), Microsoft Office users get an error stating the Converter failed to open the file.
There were no other error messages
Comment 1 Help Desk 2013-08-20 17:53:14 UTC
After further testing, we have found that if there are any hidden columns (or rows) in the Calc spreadsheet, the converter fails...as soon as we unhide those columns (or rows), Excel is able to open the file without issue...
Comment 2 retired 2013-08-20 20:24:00 UTC
If excel fails to open is this a LibreOffice bug?

Could you attach a sample document that produces the problem when saved as xlsx file? That would be very helpful to verify this bug.
Comment 3 Help Desk 2013-08-21 12:59:15 UTC
Created attachment 84389 [details]
XLSX file with hidden columns...

Here is an attachment of a file created in Libre Office, that will not open in Microsoft Excel 2003.
Comment 4 retired 2013-08-21 16:11:56 UTC
I cannot reproduce this problem.

The example file opens fine in Excel 2010 and LO 4.2 master on OS X 10.8.4.

@Help Desk: if you are using Excel 2003 I think xlsx 2010 files will not open. But that is expected.

Try saving the LO calc file to xls instead of the newer xlsx file format. That should work.

So this is NOTOURBUG if M$ isn't able to supply users with compatible file formats. They do of course want to sell their newer M$ Office version. ;)