Bug Hunting Session
Bug 68547 - Basic Runtime Error on Turkish locale with user names containin "i" letter
Summary: Basic Runtime Error on Turkish locale with user names containin "i" letter
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:4.5.0
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-25 21:02 UTC by Zeki Bildirici
Modified: 2016-07-03 10:31 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Fİle Converter Wizard -1 (55.06 KB, image/jpeg)
2013-08-25 21:02 UTC, Zeki Bildirici
Details
Fİle Converter Wizard -2 (38.13 KB, image/jpeg)
2013-08-25 21:02 UTC, Zeki Bildirici
Details
Fİle Converter Wizard -3 (159.51 KB, image/jpeg)
2013-08-25 21:03 UTC, Zeki Bildirici
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zeki Bildirici 2013-08-25 21:02:11 UTC
Created attachment 84622 [details]
Fİle Converter Wizard -1

Hi,

First of all i must say this is a Turkish locale spesific error. We have two letters; I and i in contrast; in English I is capital i is lowercase.

In Linux systems, if the system language is Turkish and the username is containing  "i"  like my name "zeki" LibreOffice wizards and extensions which are based on Basic and requires a file path, simply does not work and gives runtime errors.

and as shown points the following line:

bIsTemplatePath = FieldInList("vor", sFileContent)

I'am attaching two screenshots from he file converter wizard.

As you may see the paths contain my username zeki, thus Basic somehow gets a runtime error.

When i've created a new user like, zeklo, everything is fine.

I'm not sure if we can find a solution in LibreOffice side, or may be solved by other upstream. 

Best regards,
Zeki
Comment 1 Zeki Bildirici 2013-08-25 21:02:30 UTC
Created attachment 84623 [details]
Fİle Converter Wizard -2
Comment 2 Zeki Bildirici 2013-08-25 21:03:03 UTC
Created attachment 84624 [details]
Fİle Converter Wizard -3
Comment 3 Zeki Bildirici 2013-08-25 21:09:39 UTC Comment hidden (no-value)
Comment 4 Zeki Bildirici 2013-08-25 21:13:04 UTC
Sorry for the mess in Comment 3. Could you please delete it,
Comment 3 Zeki Bildirici 2013-08-25 21:09:39 UTC
I was just trying to change the attachment type. 

Best regards,
Zeki
Comment 5 Julien Nabet 2013-08-30 05:24:57 UTC
Zeki: could you translate the error message of the popup?
Comment 6 Zeki Bildirici 2013-09-02 20:48:19 UTC
(In reply to comment #5)
Hi,
> Zeki: could you translate the error message of the popup?

First popup says "Sorry, Filesystem Problem"
and the second popup in front of LibreOffice Macros&Dialogs.ImportWizard is: "BASIC runtime error.
Sub-procedure or function procedure not defined."

Best regards,
Zeki
Comment 7 Jean-Baptiste Faure 2013-12-14 12:12:39 UTC
Such a bug, if it was confirmed, can't block a new release.
https://wiki.documentfoundation.org/Release_Criteria#Blocker_Bug_Definition

Best regards. JBF
Comment 8 steve -_- 2014-10-27 13:01:05 UTC
Hi Zeki, ss this bug still valid / reproducible with the latest LO release?
http://www.libreoffice.org/download/libreoffice-fresh/

Please also try resetting your user profile and let us know if that helps: https://wiki.documentfoundation.org/UserProfile

Should this be still reproducible for you with the latest LO release please set this bug back to UNCONFIRMED. Should this issue be solved set it to WORKSFORME.

Setting to NEEDINFO until more detail is provided.
Comment 9 Zeki Bildirici 2014-11-04 07:51:11 UTC
(In reply to steve ... from comment #8)
> Hi Zeki, ss this bug still valid / reproducible with the latest LO release?
> http://www.libreoffice.org/download/libreoffice-fresh/
Hi, yes it is still reproducable.
> Please also try resetting your user profile and let us know if that helps:
> https://wiki.documentfoundation.org/UserProfile

No it's abuot a well known Turkish locale issue  "I" is not "i" in Turkish. This issue has been experienced in many software projects for example: 
- http://haacked.com/archive/2012/07/05/turkish-i-problem-and-why-you-should-care.aspx/ 
- http://mattryall.net/blog/2009/02/the-infamous-turkish-locale-bug
- http://java.sys-con.com/node/46241 

> Should this be still reproducible for you with the latest LO release please
> set this bug back to UNCONFIRMED. Should this issue be solved set it to
> WORKSFORME.

I'll set it to unconfirmed and i am waiting for an l10n master to confim and fix.

Best regards,
Comment 10 Julien Nabet 2014-11-05 21:49:48 UTC
FieldInList uses "equals" method, see http://opengrok.libreoffice.org/xref/core/vbahelper/source/vbahelper/vbahelper.cxx#534

Andras: one for you? Last links provided by Zeki show indeed a real point to deal with Turkish locale.
Comment 11 Matthew Francis 2015-03-24 13:53:51 UTC
I can confirm this, so setting to NEW

To reproduce, it's enough to install system Turkish language support, "export LC_ALL=tr_TR.utf8" in a terminal and run soffice. Neither changing the system/user locale as a whole nor using a Turkish language pack in LO are required
Comment 12 Commit Notification 2015-03-25 06:41:02 UTC
Matthew J. Francis committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ca07d5bef335b220139b858a5b54aa62983a66e1

tdf#68547 Turkısh "ı" ıs specıal

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Emel Simsek 2015-05-27 06:42:21 UTC
Hi,

  This fix is not mentioned in 5.0 release notes. There seems to be no 4.5 release. So, in what version the fix will be available?

Thanks,
Emel
Comment 14 Jean-Baptiste Faure 2015-05-27 07:24:04 UTC
(In reply to Emel Simsek from comment #13)
> Hi,
> 
>   This fix is not mentioned in 5.0 release notes. There seems to be no 4.5
> release. So, in what version the fix will be available?

5.0 is the new version number for 4.5. So the fix should be in LO 5.0. You can verify that by testing the first beta of LO 5.0. You can found it here: https://www.libreoffice.org/download/pre-releases

Please, could you confirm that the bug is fixed in the 5.0 beta1?

Best regards. JBF
Comment 15 Zeki Bildirici 2015-08-27 21:49:11 UTC
(In reply to Commit Notification from comment #12)
> Matthew J. Francis committed a patch related to this issue.
> It has been pushed to "master":
> 
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=ca07d5bef335b220139b858a5b54aa62983a66e1
> 
> tdf#68547 Turkısh "ı" ıs specıal
> 
> It will be available in 4.5.0.

Hi,

Thank you for your fix and sorry for being late. I can confirm that the problem is solved if you reach the wizard through:

1- Start Center, and
2- In a file for example you've opened test.odt(where the filename does not include "ı") file and clicked File - Wizards - Document converter.

I can reproduce this error in 
a- Opening a file like adsız1 (or whatever contains "ı") then clicking to File - Wizards - Document converter. 

Ouput:
1- Sorry, Filesystem Problem 
2- Inadmissible value or data type.
Index out of defined range.
3- GetFilterName = sLocFilterList(b) --- this is the highlighted string

Should i open a new bug report? 
Best regards,
Zeki
Comment 16 Julien Nabet 2016-07-03 10:31:02 UTC
(In reply to Zeki Bildirici from comment #15)
> (In reply to Commit Notification from comment #12)
>...
> Should i open a new bug report? 
> ...

Let's consider this one as FIXED.
If you reproduce the almost same problem with last stable LO version (5.1.4), indeed, it could be useful you submit a new bugtracker.
It'll be easier to manage it.