Bug 68577 - LO crash when opening PDF via Samba
Summary: LO crash when opening PDF via Samba
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-26 14:50 UTC by Petr Ledvina
Modified: 2019-04-12 10:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Part of /var/crash report (146.26 KB, text/x-apport)
2013-12-12 17:03 UTC, Petr Ledvina
Details
empty pdf file (from LO) (1.50 KB, application/pdf)
2014-06-02 13:49 UTC, Petr Ledvina
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Ledvina 2013-08-26 14:50:08 UTC
Problem description: 

Steps to reproduce:
1. I have opening Writer (e.g. empty page) 
2. I have selected file > open
3. I have select pdf file  (I know, that it is not good, but may be
it was mistake, I have selected e.g. file example.pdf instead of file example.odt

Current behavior:

LO has crashed.

Expected behavior:

No crash. May be write something "Could you realy convert PDF file?" and open in Drawing. Or write "It is PDF file, it is not possible to open"

The same (wrong), when I attempt open another "not good" format, e.g.  file example.php
              
Operating System: Ubuntu
Version: 4.0.2.2 release
Comment 1 Thomas van der Meulen 2013-08-27 06:07:33 UTC
Thank you for your bug report, I CAN'T reproduce this bug running Version:
4.1.1.2
Build ID: 7e4286b58adc75a14f6d83f53a03b6c11fa2903 on Mac osx 10.8.4. 

I also CAN'T reproduce this bug running LibreOffice:
Version: 4.1.0.4
Build ID: 410m0(build 4) on Linux mint 15: olivia
Comment 2 Petr Ledvina 2013-08-27 12:04:05 UTC
Also has crashed on (new) LO   4.1.0.4  - 410m0(Build:4)
The same system Ubuntu 13.04
Comment 3 ign_christian 2013-08-27 12:15:46 UTC
Not reproducible on LO 3.6.7 (Ubuntu 12.04 32bit). Open pdf from Writer suddenly open that in Draw.

Perhaps specific case to only "a" file?
Comment 4 Petr Ledvina 2013-08-28 13:38:10 UTC
It is O.K., when I have open "local" file, e.g. /home/my_user_name/example.pdf

Crashed during opening file via Samba. The server is Windows and I try open (pdf) file from the server (server has no password, no protection). Another work (open odt/odc,saving in LO; or working with another software and also with Samba - Firefox, Gimp, Inkscaoe, Thunderbird....)
are OK. My setting of Samba in /etc/fstab
//server_name/folder /media/short_name   cifs   guest,rw,hard,nosetuids,noperm,iocharset=utf8,sec=ntlm 0 0
Comment 5 tommy27 2013-12-12 02:42:47 UTC
did you try upgrading to 4.1.3.2?
Comment 6 Petr Ledvina 2013-12-12 17:03:04 UTC
Created attachment 90675 [details]
Part of /var/crash report
Comment 7 Petr Ledvina 2013-12-12 17:03:59 UTC
Comment on attachment 90675 [details]
Part of /var/crash report

I have just tried. And LO just crashed.
Comment 8 ign_christian 2013-12-13 10:02:47 UTC
I saw some incompatibility issues reported between Samba & LO. Please do searching in this Bugzilla, maybe your problem has been reported by someone.

You could also try different version of Samba since I also experience that different Samba version could generate different behavior.
Comment 9 Joel Madero 2014-06-02 05:35:14 UTC
Tested Environment:
Windows 7 x64
Ubuntu 14.04 x64
LibreOffice 4.2.4.2 release

Steps:
1. Shared a folder on Windows 7 machine
2. Put a pdf inside of folder
3. Accessed folder via nautilus in Ubuntu
4. Started writer
5. Selected File -> open & selected pdf from shared folder

Result: PDF opened in Draw

Closing as WFM

@Petr - please retest with 4.2.4.2. If you still get the crash please try with a fresh profile: https://wiki.documentfoundation.org/UserProfile

If you still experience the crash then please let us know your exact setup similar to how I have done and then mark the bug as UNCONFIRMED. Also confirm the problem happens with different pdf's (might just be that particular pdf?)
Comment 10 Petr Ledvina 2014-06-02 13:49:17 UTC
Created attachment 100314 [details]
empty pdf file (from LO)
Comment 11 Petr Ledvina 2014-06-02 13:54:49 UTC
I so sorry, but still crash. I have Ubuntu 13.10, LO 4.2.4.2, I remove the profile /.config/libreoffice (so open with fresh profile), try open pdf file from "Samba" (Win NT server) and LO has crashed. When I  try open pdf file from local folder, LO open Draw (correct).
It not depend on "quality"/"version" of pdf, the crash is in all cases (e.g. empty pdf generated from LO) - see attachment. I have tried e.g. 10 different pdf files.

Setting of Samba is the same (as I wrote 2013-08-28)
in /etc/fstab
//server_name/folder /media/short_name   cifs  guest,rw,hard,nosetuids,noperm,iocharset=utf8,sec=ntlm 0 0

(and as I wrote, I have no problem with another files or with another softwares, just with LO)
Comment 12 Joel Madero 2014-06-02 16:01:09 UTC
I wonder if it's the Windows NT server causing the issues for LibreOffice - very strange. Sorry but it's incredibly difficult to find someone with a setup that can confirm.

Are you willing to get a backtrace? That might help a ton.

https://wiki.documentfoundation.org/Development/How_to_debug#Start_LibreOffice_from_the_debugger_.28gdb.29
Comment 13 QA Administrators 2015-01-10 18:06:55 UTC Comment hidden (obsolete)
Comment 14 QA Administrators 2015-02-11 19:56:06 UTC Comment hidden (obsolete)
Comment 15 QA Administrators 2015-02-11 20:02:34 UTC Comment hidden (obsolete)
Comment 16 Petr Ledvina 2015-02-13 11:19:20 UTC
Still crashed, the same situation. I have Ubuntu 14.04 and LibreOffice 4.3.2.2 
ID: 430m0(Build:2)   /last version from repositary/ and the problem is the same.
I try open any PDF file from SAMBA and LO has crashed. When I try opened PDF from local adress, e.g. /home/user1/example.pdf, the document is correct open in LibreOffice Draw.
Comment 17 Joel Madero 2015-02-13 15:08:45 UTC
Version is the oldest version that the bug is confirmed on not the latest. Reverting update to version.
Comment 18 Jan 2015-02-13 15:30:51 UTC
I tried with your mount-options on Ubuntu 14.04 (LO Version: 4.2.7.2) and a solaris Samba server. Works for me. Can you tell us more about your setup?
Comment 19 Petr Ledvina 2015-02-19 13:13:46 UTC
(In reply to Jan from comment #18)
> I tried with your mount-options on Ubuntu 14.04 (LO Version: 4.2.7.2) and a
> solaris Samba server. Works for me. Can you tell us more about your setup?

As I wrote 1,5 year ago:
The server is Windows and I try open PDF file from the server (server has no password, no protection). My setting of Samba in /etc/fstab is:
//server_name/folder /media/short_name   cifs  guest,rw,hard,nosetuids,noperm,iocharset=utf8,sec=ntlm 0 0

Another working (open odt/doc,saving in LO; or working with another software and also with Samba - Firefox, Gimp, Inkscape, Thunderbird....) are OK. So I think, that the setting of Samba is good, another software has no problem.
Problem is just LO and crashing when I try open PDF file from server connect by Samba.
Comment 20 Jan 2015-02-24 17:06:57 UTC
Unfortunately, we cannot reproduce the bug. We cannot fix it until somebody in the QA Team is able to do it. Setting to NEEDINFO. Set back to UNVERIFIED if you have specified more information.

I looked at your crash report but there are not debug symbols. I crashes in libpdfimportlo.so. I could check the code if I knew the line.

Can you install a libreoffice version with debug symbols (libreoffice-gdb) and maybe start it with "libreoffice --backtrace"?
Comment 21 QA Administrators 2015-04-01 14:52:31 UTC Comment hidden (obsolete)
Comment 22 Petr Ledvina 2018-08-07 08:46:14 UTC
Still this bug in LO 6.0.6.2 (Ubuntu 16.04): still LO crash when try open PDF via SAMBA (from Windows server). And also no problem when open local PDF file (from /home/user1/xxxx.pdf) 
Petr Ledvina
Comment 23 Petr Ledvina 2019-04-12 10:25:36 UTC
It works! I can open PDF in LO from "network". I have now LO 6.0.7.3 and we have changed the server (to which we connect) from Windows 2000 to a new FreeBSD. 
Setting of Samba connection in /etc/fstab is now:
//server_name/folder /media/short_name cifs   user=xxx,password=xxx,noperm,nosetuids,noexec 0 0