Bug Hunting Session
Bug 68582 - split "Move/Copy Sheet" item in sheet tab menu
Summary: split "Move/Copy Sheet" item in sheet tab menu
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 89421 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-08-26 19:29 UTC by David Lynch
Modified: 2015-02-20 16:05 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Lynch 2013-08-26 19:29:48 UTC
When you right-click a sheet tab in Calc you get a menu:

Insert Sheet...
Rename Sheet...
Move/Copy Sheet...
Tab Colour...
etc

I would like this menu to be replaced by:
Insert Sheet...
Rename Sheet...
Move Sheet...
Copy Sheet...
Tab Colour...
etc

Currently when copying a sheet, you must remember to click the copy button on the next menu to copy rather than move the sheet. I have just overwritten data I needed by forgetting to click this button.

An alternative would be to make copy the default on the next menu rather than move.
Comment 1 tommy27 2013-08-27 12:43:10 UTC
basically you propose split the "Move/Copy Sheet" menu item in 2 separate items.
I changed summary notes according to this... feel free to edit it yourself if it's not what you asked.

I set status to NEW and I change version field to "inherited from OOo" since that menu item has always been like that.

I add UI and Calc experts to CC list to hear if this enhancement request is feasible or not.
Comment 2 Ivan Timofeev (retired) 2013-09-04 11:18:34 UTC
Well, modifying the UI per user requests is not a good trend I think. At least I'm not volunteering to do that.

(In reply to comment #0)
> I have just overwritten data I needed by forgetting to click this button.

How?
Comment 3 tommy27 2013-09-04 12:20:27 UTC
(In reply to comment #2)
> Well, modifying the UI per user requests is not a good trend I think. At
> least I'm not volunteering to do that.

@Ivan
I agree with you. I added to CC list just to know a developer advise.
a UI change needs more users asking forit, not just one.

@David
basically you should convince other users that you proposed change is worth it.
Comment 4 V Stuart Foote 2015-02-17 12:37:46 UTC
*** Bug 89421 has been marked as a duplicate of this bug. ***
Comment 5 V Stuart Foote 2015-02-17 13:38:43 UTC
Alternative solution to splitting the menu items might be to make the mode for the follow-on dialog (movecopysheet.ui) stateful.  Select as last used, rather than default as now to Move.

At the least provide UI selection of default action--Expert Configuration or Tools -> Options -> LO Calc -> Defaults panel.
Comment 6 David Lynch 2015-02-20 16:05:35 UTC
I am marking this as resolved because of the lack of support for my proposal.