Bug Hunting Session
Bug 68747 - PERFORMANCE: XLSX with circular reference, frozen panes, validation errors opens very slowly
Summary: PERFORMANCE: XLSX with circular reference, frozen panes, validation errors op...
Status: RESOLVED DUPLICATE of bug 89522
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: Confirmed:4.2.0.1:Ubuntu13.10 Confirm...
Keywords: filter:xlsx, haveBacktrace, perf
Depends on:
Blocks: XLSX
  Show dependency treegraph
 
Reported: 2013-08-30 09:02 UTC by Mohamed LYAHYAOUI
Modified: 2019-04-25 13:42 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
libreoffice crashing xlsx file (1.84 MB, application/x-xz)
2013-08-30 09:02 UTC, Mohamed LYAHYAOUI
Details
WinDbg from procdump on fileopen (9.68 KB, text/plain)
2017-02-27 14:36 UTC, Timur
Details
Callgrind output from master (8.74 MB, application/x-xz)
2019-02-08 08:12 UTC, Buovjaga
Details
Perf flamegraph (1.24 MB, image/svg+xml)
2019-04-25 13:36 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mohamed LYAHYAOUI 2013-08-30 09:02:08 UTC
Created attachment 84901 [details]
libreoffice crashing xlsx file

That xlsx File crash libreoffice 4.0 (it contains re crossed reference)
Comment 1 Julien Nabet 2013-09-01 12:11:30 UTC
Comment on attachment 84901 [details]
libreoffice crashing xlsx file

Mimetype fixed
Comment 2 retired 2014-01-03 13:35:11 UTC
Confirmed:4.2.0.1:Ubuntu13.10

This test file opens painfully slow in my test and then LO gets stuck.

NEW
Comment 3 retired 2014-01-03 13:36:58 UTC
Confirmed:4.2.0.1:OSX
Platform OS > ALL
Comment 4 Joel Madero 2015-05-02 15:40:56 UTC Comment hidden (obsolete)
Comment 5 Buovjaga 2015-06-20 10:56:06 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2016-09-20 10:09:51 UTC Comment hidden (obsolete)
Comment 7 Buovjaga 2016-09-20 10:47:54 UTC
Still hangs.

Win 7 Pro 64-bit Version: 5.3.0.0.alpha0+
Build ID: ba269f7294e2416659011cbb498a2c6b5f9d5199
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-09-12_02:36:16
Locale: fi-FI (fi_FI); Calc: CL

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 8 Timur 2017-02-27 14:36:02 UTC
Created attachment 131510 [details]
WinDbg from procdump on fileopen

SYMBOL_NAME:  sal3!osl_waitCondition+43

Actually, file get open after a looong time.
Comment 9 Timur 2017-02-27 14:54:33 UTC
MSO is somewhat slow, but it gives "circular reference warning", because J11=I11*J11.
Also, there are frozen panes here. 
And Open XML validation gives 1000 errors in this file. 
Plus this is not a minimal test case, there are 44 worksheets here. 
So, not a correct bug report.
Comment 10 QA Administrators 2018-02-28 03:39:07 UTC Comment hidden (obsolete)
Comment 11 Cor Nouws 2019-02-05 17:43:40 UTC Comment hidden (obsolete)
Comment 12 Luke 2019-02-06 22:54:02 UTC
Takes about 10 min to open in Version: 6.3.0.0.alpha0+ (x64)
Build ID: 4ed7f10d7676db0d20c706b915706d894e2113c5

Bugdoc needs to be reduced
Comment 13 Buovjaga 2019-02-08 08:12:52 UTC
Created attachment 149010 [details]
Callgrind output from master

I let callgrind run for the night.

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: 5408f0731b9cd8be0e1b7aa5145b825337baad84
CPU threads: 8; OS: Linux 4.20; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 5 February 2019
Comment 14 Roman Kuznetsov 2019-04-24 18:49:12 UTC
Noel, may be you'll want look at it?
Comment 15 Buovjaga 2019-04-25 13:36:54 UTC
Created attachment 151008 [details]
Perf flamegraph

It is already a lot better thanks probably to Noel's recent work.

Stopwatch times from Start center to the dialog warning about max number of columns:

6.2.3: 4m 21s
6.3.0: 28s

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: 3fef9fa3f5d260dd1264b67d8b42aad476332eea
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 25 April 2019
Comment 16 Xisco Faulí 2019-04-25 13:42:32 UTC
wait a second... the attach file is the same as in bug 89522, lol!
Closing as duplicated

*** This bug has been marked as a duplicate of bug 89522 ***