Download it now!
Bug 68798 - A gap between filling and border in ellipses
Summary: A gap between filling and border in ellipses
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-31 19:41 UTC by 0241586279
Modified: 2016-09-25 09:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample incomplete ellipses (8.02 KB, application/vnd.oasis.opendocument.graphics)
2013-08-31 19:41 UTC, 0241586279
Details
the gap exported to bmp (3.72 KB, image/bmp)
2013-10-27 10:20 UTC, Alexandr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 0241586279 2013-08-31 19:41:37 UTC
Created attachment 84977 [details]
sample incomplete ellipses

Problem description: 
incorrect filling ellipses
Steps to reproduce:
1. ....
2. ....
3. ....

Current behavior:

Expected behavior:

              
Operating System: Ubuntu
Version: 4.1.1.2 rc
Comment 1 Joel Madero 2013-09-24 13:34:27 UTC
We need more from you if we're going to do anything about this bug.

We need:

Your operating system and what version of libreoffice you're using.

Exact steps on how to reproduce

Exact issue that you are seeing

What you expect to see.

A much clearer title would be nice - the title should tell us what the problem is not just say a shape - if possible. We understand if there are language barriers or other reasons why the title isn't clear.


Marking as NEEDINFO. Once you provide all of the above, please mark as UNCONFIRMED.
Comment 2 Alexandr 2013-10-27 10:20:12 UTC
Created attachment 88170 [details]
the gap exported to bmp
Comment 3 Alexandr 2013-10-27 10:21:03 UTC
I can reproduce the bug (as far as I understand it) with libreoffice 4.1.0.4 from Debian Wheezy backports amd64. To do this you need to draw filled ellipse or filled curve and look at its right or bottom border. You can see a gap between filling and border. A scale or the ellipse size should be big enough. I attache a part with the gap after importing to bmp.

I can not reproduce the bug with libreoffice draw 4.1.2.3 on windows 7. Can somebody try this on other platforms?
Comment 4 Jean-Baptiste Faure 2013-11-16 10:25:25 UTC
Reproducible with LibreOffice 4.1.4.0.0+ under Ubuntu 13.10 x86-64.
The bug is related to the graphics antialiasing. Indeed if you disable antialiasing for graphics in menu Tools > Options > LibreOffice > View the gap disappears.
Reproducible with master too (Version: 4.2.0.0.alpha1+ Build ID: 9ab89a7599f79092027ae86b5b4cd0e3d67b8b4d).

Thank you for the bug report.

Best regards. JBF
Comment 5 QA Administrators 2015-04-19 03:22:17 UTC Comment hidden (obsolete)
Comment 6 Alexandr 2015-04-23 18:25:52 UTC
Reproducible with LibreOffice 3.5.4, 4.3.3, 4.4.0.0 beta2 and 4.5.0.0 alpha1 on Debian x86_64.
Comment 7 QA Administrators 2016-09-20 09:32:32 UTC Comment hidden (obsolete)
Comment 8 Jean-Baptiste Faure 2016-09-25 09:56:33 UTC
Not reproducible anymore in LO 5.2.3.0+ and current master, both built at home under Ubuntu 16.04 x86-64.

Closing as WorksForMe. Please, feel free to reopen if you disagree.

Best regards. JBF