Bug 68879 - WMF Picture Size problem after Export
Summary: WMF Picture Size problem after Export
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:emf
Depends on:
Blocks: EMF-WMF
  Show dependency treegraph
 
Reported: 2013-09-03 09:19 UTC by mmaurer
Modified: 2020-01-14 08:14 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
ODG File for exporting to WMF with Image (150.48 KB, application/zip)
2013-09-03 09:19 UTC, mmaurer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mmaurer 2013-09-03 09:19:55 UTC
Created attachment 85105 [details]
ODG File for exporting to WMF with Image

After inserting a small image to a drawing document,the SWM-Export image will be too big.

Export the attached document DrawingWithoutImage.odg --> WMFImage = 6,45KB.
After adding image (WMF-Test.jpg of 26,6 KB) (see DrawingWithImage.odg) the resulting WMFImage will be 849 KB. (this is more than 100 times greater)
Comment 1 Owen Genat (retired) 2013-09-29 23:04:35 UTC
I am confirming this bug. Status set to NEW. File sizes when exporting the provided ODGs to WMF under Ubuntu 10.04 running TDF/LO v4.1.0.4 are as indicated in the description. Using EMF as the export format, reduces the size of both files to 3.3 kB and 423.6 kB respectively (which although smaller is still more than 100 times greater).
Comment 2 mmaurer 2013-09-29 23:04:50 UTC

Danke für Ihre E-Mail. Ich bin bis einschließlich 10-06-2013 außer Haus.
In dringenden Fällen wenden Sie sich bitte an Johannes Matheis (Tel: +49 721 91430 212),
mailto:johannes.matheis@vector.com
Bitte beachten Sie: Ihre E-Mail wird nicht weitergeleitet.

Thank you for your e-mail. I am out of the office through 2013-10-06.
In urgent matters please contact Johannes Matheis  (Phone: +49 721 91430 212),
mailto:johannes.matheis@vector.com
Please note: Your e-mail will not be forwarded.
Comment 3 QA Administrators 2015-04-19 03:20:12 UTC Comment hidden (obsolete)
Comment 4 mmaurer 2015-04-20 08:34:55 UTC
Version: 4.4.2.2
Windows 7 Professional

The bug is still present. No changes in the bug behavior.
Comment 5 QA Administrators 2016-09-20 09:32:14 UTC Comment hidden (obsolete)
Comment 6 mmaurer 2016-09-26 14:30:43 UTC
Tested with 5.2.1.2: Bug is still present
Tested with OpenOffice 3.4.1: Bug was present in this version too.

Behavior has not changed.
Comment 7 QA Administrators 2017-12-04 09:54:00 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2019-12-11 03:37:33 UTC Comment hidden (obsolete)
Comment 9 mmaurer 2020-01-14 08:14:17 UTC
The bug is still present

Version: 6.3.4.2 (x64)
Build-ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
CPU-Threads: 8; BS: Windows 10.0; UI-Render: GL; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded