Bug Hunting Session
Bug 68943 - LibO cannot find JRE
Summary: LibO cannot find JRE
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-04 15:33 UTC by Phil Munck
Modified: 2015-04-20 18:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Phil Munck 2013-09-04 15:33:23 UTC
Problem description: LibreOffice no long works because it cannot find JRE.  If you are going to use JRE in this program, you have an obligation to see that it in fact runs.  Shame!

Steps to reproduce:
1. ....
2. ....
3. ....

Current behavior:

Expected behavior:

              
Operating System: Windows 7
Version: 4.1.0.4 release
Comment 1 tommy27 2013-09-13 03:03:16 UTC
have you tried using 4.1.1.2?
I have no troubles with it under Win7 64bit
Comment 2 Kumāra 2013-10-07 04:23:58 UTC
I believe you've installed the 64-bit JRE. LibO for Windows is 32-bit. (No 63-bit version available.) Please install the 32-bit JRE and report back.
Comment 3 ign_christian 2013-10-11 09:17:26 UTC
Hi Phil. Have you test LO 4.1.2.3? What java version installed on your machine? 32bit java? You have 32bit Win7?
Comment 4 Kumāra 2013-10-11 09:49:26 UTC
I can confirm that the problem exist when one needs JRE to work with LibO for Windows.

To solve such a problem, I suggest specifying/highlighting that LibO for Windows does not work with JRE 64-bit.

For those who think JRE is no longer needed for LibO, bear in mind that some extensions, such as LanguageTool (a grammar checker), depend on it.
Comment 5 tommy27 2013-10-11 10:34:49 UTC
set status to NEW according to Comment 4
Comment 6 Markus Mohrhard 2013-10-14 04:42:35 UTC
There was another issue that I just fixed. LibreOffice 4.1 did not detect JRE6 even in the 32bit version.

I fixed it in master and will backport the change to the 4-1 branch. It should be available in 4.1.3.2
Comment 7 QA Administrators 2015-04-01 14:40:17 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-01
Comment 8 Buovjaga 2015-04-20 18:18:59 UTC
Never had this issue with >4.3. Closing as WFM.
Phil: feel free to open, if this still occurs to you with LibO 4.4.x.