Bug 68996 - undefined dependency
Summary: undefined dependency
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-05 19:09 UTC by Jérôme
Modified: 2013-09-06 19:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jérôme 2013-09-05 19:09:27 UTC
When trying to start any libreoffice program from the menu, I get the below error message :
---
The program cannot be started.
A general error occurred while accessing your central configuration.
---

It seems that a package dependency isn't properly defined.

From the LibreOffice_4.1.1_Linux_x86-64_deb.tar.gz archive, I installed the below packages :
-----
libobasis4.1-base
libobasis4.1-calc
libobasis4.1-core01
libobasis4.1-core02
libobasis4.1-core03
libobasis4.1-core04
libobasis4.1-core05
libobasis4.1-core06
libobasis4.1-core07
libobasis4.1-draw
libobasis4.1-extension-presentation-minimizer
libobasis4.1-gnome-integration
libobasis4.1-graphicfilter
libobasis4.1-images
libobasis4.1-impress
libobasis4.1-math
libobasis4.1-ooofonts
libobasis4.1-writer
libreoffice4.1
libreoffice4.1-base
libreoffice4.1-calc
libreoffice4.1-debian-menus
libreoffice4.1-dict-en
libreoffice4.1-dict-fr
libreoffice4.1-draw
libreoffice4.1-impress
libreoffice4.1-math
libreoffice4.1-ure
libreoffice4.1-writer
-----
Comment 1 Cor Nouws 2013-09-05 19:36:55 UTC
Hi Jéôme,

thanks for reporting.
Just for info: no problem for me on 32 bits debian based linux...
Regards,
Cor
Comment 2 Jérôme 2013-09-06 06:16:05 UTC
The programs properly start when I install additionnal packages (from the same archive). This shows that it seems to be an issue in the "Depends" entry of the Debian package.
Comment 3 Cor Nouws 2013-09-06 07:40:21 UTC
OK, good to read that you found that out. I think I have to close this then as 'not our bug' ...
(Hope that is appropriate ;) )

thanks for confirming and such!
Cor
Comment 4 Jérôme 2013-09-06 19:20:03 UTC
Basically it is a bug of the packaging of the deb archive provided by libreoffice.org.