Download it now!
Bug 69137 - FILESAVE: Missing subtitle and changing orientation of Y axis label in XLSX
Summary: FILESAVE: Missing subtitle and changing orientation of Y axis label in XLSX
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-09 10:32 UTC by Leon Stringer
Modified: 2015-09-09 13:22 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leon Stringer 2013-09-09 10:32:21 UTC
Problem description: 
Chart elements subtitle and Y-axis orientation (and sometimes even chart data) are lost when saving to .xlsx format.

This may be a known limitation of the Office Open XML filter, I appreciate you get a warning that the document may not me saved correctly, but as you always get that it's hard to know if it actually applies.

Steps to reproduce:
1. Create a spreadsheet with some data.
2. Insert a chart for the data. Enter a subtitle and a Y-axis label.
3. Save the chart as a "Microsoft Excel 2007/2010 XML (.xlsx)" file.
4. Close the file.
5. Open the file.

Current behavior:
The subtitle is no longer present, the Y-axis label is no longer vertically oriented. (I've also had chart data no longer be displayed but this isn't consistent).

Expected behavior:
The subtitle is saved and displayed, the vertical orientation of the Y-axis label is retained.
Operating System: Windows 7
Version: 4.1.1.2 rc
Comment 1 A (Andy) 2013-12-28 21:39:23 UTC
reproducible with LO 4.1.4.2 (Win8)
Comment 2 Will Furnass 2014-07-23 16:09:54 UTC
Reproducible with version 4.2.4.2 (Build ID: 420m0(Build:2)) on Linux Mint 17.0 (64-bit)
Comment 3 ign_christian 2014-07-24 15:57:42 UTC
Moving to proper component: Chart
Change summary to be more spesific

Perhaps dev want this bug to be splitted since this bug reports 2 issues
Comment 4 QA Administrators 2015-09-04 02:48:27 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.0.5 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-09-03
Comment 5 Leon Stringer 2015-09-09 13:16:07 UTC
Re-tested with LibreOffice 5.0.1.2 on Microsoft Windows 7. Issue appears to be fixed.
Comment 6 Leon Stringer 2015-09-09 13:22:07 UTC
I'll leave this as RESOLVED WORKSFORME. The Y-axis label orientation is now retained as expected. The subtitle is still lost but it looks like Excel doesn't have a subtitle for charts so one couldn't reasonable expect it to be retained.