Bug 69153 - Other: LibreOffice Crashes if Extension Needs Java and Java is not Enabled
Summary: Other: LibreOffice Crashes if Extension Needs Java and Java is not Enabled
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: notBibisectable, regression
Depends on:
Blocks:
 
Reported: 2013-09-09 22:32 UTC by Harald Koester
Modified: 2015-12-17 10:55 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2013-09-09 22:32:41 UTC
Steps to reproduce:
[1] Start LibreOffice and install extension Language Tool.
[2] Enable use of Java Runtime Environment: Tools > Options... > LibreOffice > Advanced > disable Java, then OK
[3] Close LibreOffice.
[4] Start LibreOffice again. The message „LibreOffice requires a Java runtime environment ...“ is displayed. At this point a more specific message would be fine: e. g. „The extension Language Tool requires a Java ...“. Go on with steps [5a] or [5b] or [5c]
–------------
[5a] Click “Yes“. The message „Due to an unexpected error, LibreOffice crashed. ...“ is displayed. Expected: Start of LibreOffice with JRE enabled.
[6a] Click ”OK“ and wait. Now LibreOffice starts correctly.
–------------
[5b] Click “No“. The message „Due to an unexpected error, LibreOffice crashed...“ is displayed. Expected: Start of LibreOffice with JRE disabled.
[6b] Click ”OK“ and wait. LibreOffice starts again with message of step [4].
–------------
[5c] Click ”Cancel“. The message „Due to an unexpected error, LibreOffice crashed. ...“ is displayed. From my point of view a Cancel button does not make sense here. Either it should be greyed or a Cancel button should not be displayed.
–-------------
If you deinstall Java completely instead of only disable Java in LibreOffice you will get a never ending story. In this case you have to close LibreOffice with the Task Manager.

I checked this bug only with the extension „Language Tool“. Hence it is not sure if this problem also occurs with other extensions which need Java.

Bug also exists in Version 4.0.4. Bug does not exist in Version 3.6.7, hence regression.

              
Operating System: Windows 7
Version: 4.1.1.2 rc
Last worked in: 3.6.7.2 rc
Comment 1 Pedro 2013-12-09 10:14:49 UTC
Confirmed under Windows XP Pro x86 SP3 en_US using LO 4.1.4.1 and 4.2 Beta2

LibreOffice should NOT crash because of a misbehaved extension.
Comment 2 Michael Stahl (CIB) 2014-02-03 13:43:26 UTC
can't get a crash on Linux...

Stephan can you take a look?
Comment 3 Andras Timar 2015-07-03 07:50:23 UTC
It seems to be fixed in LO 4.3.5.2. I can reproduce the crash in 4.2/4.1/4.0 series, but not in 4.3.
Comment 4 Harald Koester 2015-08-20 09:45:45 UTC
I can confirm Andras: Bug exists in version 4.2.4 but not in 4.3.0. Also checked version 5.0.0.5. Also this version works for me. Hence Bug closed.
Comment 5 Robinson Tryon (qubit) 2015-12-17 10:55:18 UTC
Migrating Whiteboard tags to Keywords: (notBibisectable)
[NinjaEdit]