Bug 69158 - FILESAVE: Writer crashes with no warning while attempting to save
Summary: FILESAVE: Writer crashes with no warning while attempting to save
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
4.0.6.2 release
Hardware: Other Linux (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-10 02:11 UTC by abq911
Modified: 2014-04-05 10:11 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description abq911 2013-09-10 02:11:37 UTC
System Information:
Arch Linux, x86_64, LibreOffice Version: 4.1.1.2, Build ID: 4.1.1.2 Arch Linux build-2 (regular release channel).

Problem description: 
Self explanatory, Writer crashes very often while saving in the new rc/beta. This behavior is semi-random and does not always occur, but happens nearly all the time when an unsaved document is worked on for several minutes before saving.

Steps to reproduce:
Cannot be reproduced 100%, but editing an unsaved document and attempting to save several minutes later increases the chances dramatically.

Current behavior:
Writer crashes with no warning, file recovery fails.

Expected behavior:
Writer should present file dialog and user should be able to save. Worst case should be that Writer crashes but auto-save and recovery should work.
              
Operating System: Linux (Other)
Version: 4.1.1.2 rc
Last worked in: 4.1.0.4 release
Comment 1 Nikos Platis 2013-10-02 09:36:21 UTC
Possibly a duplicate of bug 69002
Comment 2 Julien Nabet 2013-10-19 17:15:38 UTC
Did you install any LO specific extensions?
Did you try to rename your LO directory profile? (see https://wiki.documentfoundation.org/UserProfile#GNU.2FLinux)

Finally, I know it might be tedious but since you don't know how to reproduce this easily, you can try to follow this
https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace
Comment 3 Rudolf Kollien 2013-11-26 10:32:19 UTC
I can confirm this behaviour on CentOS x64, 5.10 with versions 4.0.6.2 and 4.1.3.2 either in i686 oder x64 versions. There is no difference. Using the original LO saving dialogs minimizes the danger of crashes on save a little. More on the 4.0.x, less on the 4.1.x. We currently running a LO 3.5 with no such issues.

On the 4.0.6 we get the crashes from time to time when a big document is saved or when multiple documents simultaneously are opened and edited and you try to save one of them. On 4.1.x you can force the crash when you do a big copy-n-paste from one open document to an other (new or edited). Then LO crashes reliably saving a document. 

4.1.3 is most unstable and currently not useable for production at this point. The crash is 7 to 8 out of 10 saves. 4.0.6 seems more stable, it crashes 1 to 2 out of 20 or more.

A problem seem big spreadsheets, too. They crash on save very often. So it seems to me this is a memory problem.

We are running a X11 terminalserver, KDE 3.5, with 36GB or RAM, mostly 10GB to 14GB are unused. When running a 3.5 LO, it consumes a VSS of about 200000 to 300000. Regardless how many documents are open. All versions 4.x are starting(!) at 800000 and consume up to 16000000 and more. Per user!!! Increasing with time used, not with number or complexity of open documents.
Comment 4 Rudolf Kollien 2013-11-26 10:38:45 UTC
Forgotten: my test users reported to me, that the crash nearly always comes when more than one document was open, or when LO stayed open and the documents where loaded one after one into the running instance. F.e.: start LO, open a document by file dialog, edit, save&close document, open next document and so on. Or loading documents one by one without save and close. After a while, saving isn't possible (the save dialog hangs and LO can only be closed by the window manager). Users who open a document (ether by the LO open dialog or via file manager konqueror), edit and do a save and QUIT LO have no such issues.
Comment 5 Al 2014-04-01 20:29:09 UTC
Both Writer and Calc behave the same for me under SUSE13.1 and Sabayon 14.01. I cannot either open a document or save a document. In all cases the app crashes without warning. Upon re-opening the app, it  offers recovery but when I recover the file content is missint (a "new" document). Other apps seem to work fine, the problem  is confined to libroffice as far as I can determine.
Comment 6 Efe Gürkan YALAMAN 2014-04-04 00:29:07 UTC
(In reply to comment #5)
> Both Writer and Calc behave the same for me under SUSE13.1 and Sabayon
> 14.01. I cannot either open a document or save a document. In all cases the
> app crashes without warning. Upon re-opening the app, it  offers recovery
> but when I recover the file content is missint (a "new" document). Other
> apps seem to work fine, the problem  is confined to libroffice as far as I
> can determine.

I am on openSUSE 13.1 I can confirm the crash with latest build.
Build ID: 0695236cd7347134e53c81cf15f38b61ffe13255


Here is the back trace after SIGSEGV:
http://pastebin.com/7q5hbSX1
Comment 7 Julien Nabet 2014-04-04 05:36:10 UTC
This thread may help:
http://nabble.documentfoundation.org/master-crashes-when-open-save-dialog-opens-td4103012.html

Miklos: should we put "notourbug"?
Comment 8 Michael Stahl (allotropia) 2014-04-04 12:40:29 UTC
from comments #6 and #7 this is very likely a bug in "gtk2-engine-oxygen",
and can probably be worked around by using a different GTK+2 theme.