Download it now!
Bug 69343 - FILESAVE: saving odt as doc doesn't show last line if opened in Word 2013
Summary: FILESAVE: saving odt as doc doesn't show last line if opened in Word 2013
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.6.3 release
Hardware: x86-64 (AMD64) Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc
: 72242 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-09-14 05:05 UTC by Luke S
Modified: 2017-09-05 16:20 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
First, a .odt version of the file. (7.75 KB, application/vnd.oasis.opendocument.text)
2013-09-14 14:26 UTC, Luke S
Details
Second, the exact same file saved as .doc. (9.00 KB, application/msword)
2013-09-14 14:27 UTC, Luke S
Details
Writer 5.0 screenshot (42.07 KB, image/png)
2015-11-24 10:29 UTC, rpr
Details
MS Word 2013 screenshot (22.82 KB, image/png)
2015-11-24 10:29 UTC, rpr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke S 2013-09-14 05:05:44 UTC
Problem description: Save a LibreOffice Writer document as a .doc file. Open the resulting .doc file in Word (2013) — the last line is not displayed and does not print. If I close the file and open it again, the last line is now visible and prints correctly.

Steps to reproduce:
1. Create a new document in Writer. Add a few lines, with hard returns, of text.
2. Save it as a .doc file.
3. Open the resulting file in Word (only 2013 tested). The last line will be missing.
4. Save the file, close and reopen it. The last line will be present.

Current behavior: Last line is not present until saved in Word.

Expected behavior: Last line should be present immediately.
Operating System: Windows 7
Version: 4.1.1.2 release
Comment 1 ign_christian 2013-09-14 10:17:41 UTC
Hi Luke..could you attach your file that is saved with Writer? Please remove private informations in that.
Comment 2 Luke S 2013-09-14 14:26:58 UTC
Created attachment 85828 [details]
First, a .odt version of the file.
Comment 3 Luke S 2013-09-14 14:27:18 UTC
Created attachment 85829 [details]
Second, the exact same file saved as .doc.
Comment 4 Thomas van der Meulen 2013-09-15 06:30:36 UTC
Thank you for your bug report,I can not reproduce this bug.

Versie: 4.1.2.1 
Build ID: bf15ac65c2167fb1ef3daf3710609d4a4c369a9 
Microsoft word 2007
OS: Windows 7
Comment 5 Milos Sramek 2013-11-11 12:42:17 UTC
Hi,

I can confirm this problem, it is related only to MS Office 2013 but not MS Office 2010. So this may be the reason, why in has not been confirmed yet. 

My tests have shown that the problem is related to LO40, LO41, LO42Alpha1, AOO34 and AOO40, but NOT to OpenOffice.org 3.3.

I ran my test on Ubuntu 64 bit, MSO ran in Win7, 64bit.

So, it looks like the DOC reader in MS Office changed a bit. 

This may become a serious bug, once the 2013 version of MSO gets more popular - I would label it a blocker

Milos
Comment 6 ign_christian 2013-11-12 02:00:08 UTC
Change status per comment 5
Comment 7 Marco Guardigli 2014-10-07 07:12:25 UTC
I reproduced this bug as follows:

1. create a new writer document, add 5 lines of text. do not add an empty line at the end.
"
111111
222222
3333333
44444
55555(last carriage return here)
"

2. Save in .doc format

3. open it in MSword (i used MS word from office 2013), and the last line will not be seen. 


If you save it from Word, and reopen, it reappears.

NEW HINT: 
I discovered that If your last line is empty (there is a standalone paragraph at the end of the document) then this is not reproducible.


Marco
Comment 8 rpr 2015-11-23 13:45:09 UTC
*** Bug 72242 has been marked as a duplicate of this bug. ***
Comment 9 rpr 2015-11-24 10:29:07 UTC
Created attachment 120757 [details]
Writer 5.0 screenshot
Comment 10 rpr 2015-11-24 10:29:54 UTC
Created attachment 120758 [details]
MS Word 2013 screenshot
Comment 11 Robinson Tryon (qubit) 2015-12-09 18:43:17 UTC Comment hidden (obsolete)
Comment 12 rpr 2016-11-02 10:05:57 UTC
It seems this bug has been fixed. Here is a test in LibO Writer 5.2.2.2 x64:

(1) In Writer: open bug-report.odt and save it as bug-report.doc
(2) In MS Word 2013: open bug-report.doc - I can see all the text that is in bug-report.odt
Comment 13 Cor Nouws 2016-11-03 09:43:46 UTC
thanks for checking, rpr. When we don't know a specific commit, we set as WorksForMe
Comment 14 itjoker.kzi 2017-09-04 17:42:18 UTC
Problem still not solved completely for 
LibreOffice Version 5.4.1.2 Build-ID: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527 /
MSOffice 2016 Version 16.0.4266.1003
Testing environment on Windows 10 Pro Version 1703

The following test is working fine:
1. open new file
2. enter three lines of text.
3. save as file test1.odt
4. save as file test1.doc
5. close LO Writer
6. open file test1.doc with MS Word
7. MS Word shows the text entered with LO Writer (OK)

Next test is not working correctly:
1. open template "Modern business letter sans-serif" in LO Writer
2. just save as test2.doc 
3. close LO Writer
4. open file test2.doc with MS Word
5. last line doesn't show up!!!
6. save as test2-2.doc
7. close MS Word
8. open test2-2.doc with MS Word
9. last line is displayed correctly!