Bug 69344 - Unity launcher shows the StartCenter icon instead of the one of the used LO module
Summary: Unity launcher shows the StartCenter icon instead of the one of the used LO m...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 69665 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-09-14 06:37 UTC by Jean-Baptiste Faure
Modified: 2013-11-01 20:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2013-09-14 06:37:27 UTC
Something changed between LO 4.0 and LO 4.1 that affect the icon showed in the Unity Launcher in Ubuntu 13.04. 

With LO 4.0.5 (generic Linux build) when I open a text document, the Unity Launcher shows the Writer icon (blue icon), if it is a spreadsheet it shows the Calc icon (green icon), etc. 

When I open the same files with LO 4.1.2.1 or LO 4.1.3.0.0+ the Unity Launcher shows always the StartCenter icon (gray icon).

The problem concerns ODF files only, OOXML files are not affected.
The problem occurs whatever is the way that I use to open the file: double-click in the file manager, menu File > Open or Ctrl+O in LO

Best regards. JBF
Comment 1 Jean-Baptiste Faure 2013-09-14 06:41:10 UTC
More info: I use parallel installations of LO 4.0.5 and LO 4.1.x with 2 different user profiles.
Comment 2 Jean-Baptiste Faure 2013-09-22 07:07:29 UTC
If I remove LO 4.0.5 to keep only LO 4.1.x, I get the right icon only if I launch  an LO application from the dashboard but never when I double-click on a file in the files manager.

Added keyword regression because it works fine for LO 4.0.5.

Best regards. JBF
Comment 3 Kevin Suo 2013-09-22 10:21:16 UTC
I see this issue in 4.1.1.2, so I am changing the version.
Comment 4 Kevin Suo 2013-09-22 10:25:19 UTC
*** Bug 69665 has been marked as a duplicate of this bug. ***
Comment 5 Jean-Baptiste Faure 2013-09-22 11:10:47 UTC
Thank you. Set to NEW as there is at least one duplicate.

Best regards. JBF
Comment 6 Kevin Suo 2013-09-30 14:57:56 UTC
I am not sure whether this is a LibreOffice bug or a Ubuntu Unity bug,
 * It shows the wrong icon, while in my Lxpanel it shows the right one. (Unity and Lxpanel exist at the same time.
 * It's OK in LibreOffice 4.0.*
 * When startup (rather than open a existing ODF document) it shows the right icon.
Comment 7 Kevin Suo 2013-10-25 08:06:51 UTC
@ Jean-Baptiste Faure:

Today I upgraded my Ubuntu to 13.10, and installed LibreOffice 4.1.3 RC2, and the above metioned behaviour do not exist any more.

So, maybe this bug should be closed as WORKFORME?
Comment 8 Jean-Baptiste Faure 2013-10-25 08:18:34 UTC
Thank you for this information.

Under Ubuntu 13.04 I still have the bug with LO 4.1.3.2. I will upgrade my distribution next WE and try again. If that solves the problem, that will show that the problem is in Unity version Ubuntu 13.04, not in LibreOffice and I will close this bug report as NotOurBug.

Best regards. JBF
Comment 10 Jean-Baptiste Faure 2013-10-25 20:09:55 UTC
I tried to remove the the StartupWMClass line in the desktop files for LO 4.1.
That does not fix the problem completely. In fact that restore the behavior of LO 4.0. 
Precisely:
1/ when you launch LO by double-clicking on a file, LO starts with the correct module and Unity shows the icon of this module in the Launcher.

2/ when you open a second file, Unity groups it with the first under the same icon in the Launcher, whatever its type is. For example if the first file is a text document opened by Writer and second file is a spreadsheet it takes the same Writer icon as the first file. The behavior is the same if you open the file by double-click or by the menu File > Open.

3/ a text document being opened in LO, if you launch LO-Calc from the Dash (key Super > type Calc in the search field, choose LO 4.1 Calc) you get an empty spreadsheet. Then you can open a file from File > Open. In that case you get yet the same behavior as 2/.

If I understand correctly the first comment in https://bugs.launchpad.net/bamf/+bug/1238122, Ubuntu 13.10 does not fix this problem.

Best regards. JBF
Comment 11 Maxim Monastirsky 2013-10-26 17:08:38 UTC
(In reply to comment #10)
> If I understand correctly the first comment in
> https://bugs.launchpad.net/bamf/+bug/1238122, Ubuntu 13.10 does not fix this
> problem.
It says that it *does* fix that bug.
Comment 12 Jean-Baptiste Faure 2013-11-01 20:53:43 UTC
I upgraded my distribution from Ubuntu 13.04 to 13.10 and now it works for me as expected. I did my tests with LO 4.1.4.0.0+ with the same patch as the one submitted for bug 70553.
- each opened document has the icon of its type (text, spreadsheet, presentation, etc.) in the launcher;
- if several documents of the same type are opened, they are grouped under the same icon in the launcher.
Same behavior with the master.

So, as it works as expected in Ubuntu 13.10 but not in Ubuntu 13.04 with the same binaries, I conclude that the bug is on the Unity side, not on LibreOffice side.

Closing as NotOurBug

Best regards. JBF