Bug 69650 - FORMATTING: Paragraph Wrapping not identical to MS Word
Summary: FORMATTING: Paragraph Wrapping not identical to MS Word
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-21 16:30 UTC by Adam CloudOn
Modified: 2017-05-04 16:06 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
DOCX containing a paragraph (17.55 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-09-21 16:30 UTC, Adam CloudOn
Details
Screenshot comparison between MS Word and LibreOffice (176.33 KB, image/png)
2013-09-21 16:31 UTC, Adam CloudOn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adam CloudOn 2013-09-21 16:30:36 UTC
Created attachment 86267 [details]
DOCX containing a paragraph

Problem description: 
When LO opens the attached DOCX - it renders the paragraph different than in MS Word - specifically the paragraph wrapping (look at the last word in each line).

Steps to reproduce:
1. Load the attached DOCX in LO
2. Paragraph wrapping is different than in MS Word

Current behavior:
LO renders the paragraph different than MS Word (see screenshot)

Expected behavior:
LO should render the paragraph just like MS Word
              
Operating System: All
Version: 4.2.0.0.alpha0+ Master
Comment 1 Adam CloudOn 2013-09-21 16:31:32 UTC
Created attachment 86268 [details]
Screenshot comparison between MS Word and LibreOffice
Comment 2 m.a.riosv 2013-09-21 21:53:03 UTC
Hi Adam,
why is bad in LibreOffice?
Comment 3 Adam CloudOn 2013-10-10 09:50:51 UTC
(In reply to comment #2)
> why is bad in LibreOffice?

mariosv - I'm not sure what you mean by the question,
so I'll try to answer 2 questions:

Q:
"What exactly is wrong with the formatting? I don't see a difference"
A: 
If you look carefully - in Word the 1st line ends with the word 'people'.
In LibreOffice the 1st line ends with 'who'.

In Word the 2nd line ends with the word 'three-'.
In LibreOffice the 2nd line ends with 'wheeler'.

In Word the 3rd line ends right at the edge of the line.
In LibreOffice the 3rd line ends 80% towards the end of the line.



Q:
"Why is this considered a problem in LibreOffice ?"
A: 
This is a problem because LibreOffice doesn't render the lines correctly like in MS Word, and thus it could cause a document to appear differently.
The attached document is a simple example, but image you have a document with 10,000 lines of text - in MS Word it might take 30 pages, while in LibreOffice the same document will be 27 pages long because lines are rendered differently.

Hope this clarifies the bug.
Comment 4 m.a.riosv 2013-10-11 00:17:13 UTC
Hi Adam, LibreOffice it is not a MSoffice clone.

Seems that MS is not trying to facilitate the use of their files by other applications, and as I have read even between MSOffice versions not all looks equal.

I think a lot of things can make this difference, algorithms to generate the view sure are not equals, (MS it is not open source), when LibreOffice open docx files the parameters needs to be translated to the LibreOffice parameters and maybe not all have a direct equivalent.

On other hand, why is right in Word?, maybe is your personal assumption, e.g. I have not MSOffice. And if you want every one can see exactly the same, I think better use pdf files to distribute.

Changing the Pair Kerning in Character format to Expanded 0,1 seems fine (or in defined Paragraph style).

Please, do not set as New your reported bugs, the proper is someone, after verify the bug, doing it.

In any case, more than a bug it should be a request for enhancement.
Comment 5 Adam CloudOn 2013-10-11 09:40:46 UTC
(In reply to comment #4)

> On other hand, why is right in Word?, maybe is your personal assumption,
> e.g. I have not MSOffice. And if you want every one can see exactly the
> same, I think better use pdf files to distribute.
@Jorendc - any thoughts about this?

> Please, do not set as New your reported bugs, the proper is someone, after
> verify the bug, doing it.
@Jorendc - you might want to get the stories straight with @mariosv here who believes someone should approve my bug reports and switch them from 'UNCONFIRMED' to 'NEW'.
Comment 6 Jorendc 2013-10-11 19:40:49 UTC
(In reply to comment #4)
> Hi Adam, LibreOffice it is not a MSoffice clone.

Sure :)
 
> Seems that MS is not trying to facilitate the use of their files by other
> applications, and as I have read even between MSOffice versions not all
> looks equal.

Correct
 
> I think a lot of things can make this difference, algorithms to generate the
> view sure are not equals, (MS it is not open source), when LibreOffice open
> docx files the parameters needs to be translated to the LibreOffice
> parameters and maybe not all have a direct equivalent.

Ideally we should fine-tune our equivalent parameters so all documents looks the same in LibreOffice as well as Word (which a docx document is most probably created in). True about the fact sometimes not all documents are rendered the same in different M$ Office products, but in this case I can confirm it renders the same way as the screenshot of Adam (used Mac OSX 10.8.5 with Word for Mac 2011).
 
> On other hand, why is right in Word?, maybe is your personal assumption,
> e.g. I have not MSOffice. And if you want every one can see exactly the
> same, I think better use pdf files to distribute.

Yes, for distribution, but not for editing purpose. With that 'mentality' we should kill the docx import filter, because "you should use pdf for distribution". :)
 
> Changing the Pair Kerning in Character format to Expanded 0,1 seems fine (or
> in defined Paragraph style).
> 
> Please, do not set as New your reported bugs, the proper is someone, after
> verify the bug, doing it.

Very correct :)... unless the reporter is a known developer. You are right about the fact this isn't a "rule", but this is an "unwritten assumption" ("rule" is a wrong word :p) in our QA-system. I told Adam, who is a known developer in our community, in other bugs report he can mark mark his own bugs as NEW 
 
> In any case, more than a bug it should be a request for enhancement.

Mmh, hard one :). But yes, maybe enhancement request.

Okay, after all:

I _FAIL_ to reproduce this using Mac OSX 10.8.5 with LibreOffice version: 4.1.2.3 Build ID: 40b2d7fde7e8d2d7bc5a449dc65df4d08a7dd38
Document is rendered same way as in Word (screenshot Adam) and Word for Mac 2011.

But, nevertheless indisputable reproducible on Windows (screenshot Adam, known developer) -> NEW right away

I can't test on master 4.2.0.0 right now, there are no tinderbox builds for Mac OSX.

@Mariosv: I hope you agree :)?

Kind regards,
Joren
Comment 7 m.a.riosv 2013-10-11 23:32:38 UTC
Hi Joren,

Comment #6
> Yes, for distribution, but not for editing purpose. With that 'mentality' we
> should kill the docx import filter, because "you should use pdf for
> distribution". :)
Sorry, but I don't see the correlation.
But maybe a lot of project hours to make a better LibreOffice.:)

> 
> Very correct :)... unless the reporter is a known developer. You are right
> about the fact this isn't a "rule", but this is an "unwritten assumption"
> ("rule" is a wrong word :p) in our QA-system. I told Adam, who is a known
> developer in our community, in other bugs report he can mark mark his own bugs
> as NEW
I think this not about Adam as dev, but even devs like we all, can have some mistake.
Here we are.

> 
> But, nevertheless indisputable reproducible on Windows (screenshot Adam, known
> developer) -> NEW right away
Then when there is an screenshot, we don't need verify the bug. Wow, stupid me, I have invested a lot of time trying to find out if some option could make the difference. And we all have seen how many times complicated issues was only a profile problem, in fact I have not verify it in this case.

But if you know it is a bug, it's enough for me.

Regards.
Comment 8 Adam CloudOn 2013-10-13 07:52:01 UTC
(In reply to comment #7)
> > But, nevertheless indisputable reproducible on Windows (screenshot Adam, known
> > developer) -> NEW right away
> Then when there is an screenshot, we don't need verify the bug. Wow, stupid
> me, I have invested a lot of time trying to find out if some option could
> make the difference. And we all have seen how many times complicated issues
> was only a profile problem, in fact I have not verify it in this case.
> 
> But if you know it is a bug, it's enough for me.

Sorry mariosv - but I didn't understand your last paragraph..
I am not sure if you're cynical or being serious in your comment... ("wow stupid me").
Could you clarify that please ? :)
Comment 9 m.a.riosv 2013-10-13 13:49:19 UTC
Hi Adam, I was answering Comment #6, but how can you think it was a cynical comment? :(
Comment 10 Adam CloudOn 2013-10-13 14:00:27 UTC
(In reply to comment #9)
> Hi Adam, I was answering Comment #6, but how can you think it was a cynical
> comment? :(

It's a bit of a problem figuring out someone's tone when reading their text .. so I thought you might be cynical. My bad :)
Comment 11 m.a.riosv 2013-10-13 15:05:47 UTC
Sorry Adam, maybe may bad English, but in last comments there are nothing about the issue, so forgive, but this is for me finished here.
Comment 12 tommy27 2014-10-25 08:02:31 UTC
same different paragraph wrapping under Win7x64 using LibO 4.3.2.2 or recent 4.4.0.0 master. same issue with older releases like 3.4.3, in LibreOffice the 1st line ends with 'who'.
Comment 13 QA Administrators 2015-12-20 16:20:16 UTC Comment hidden (obsolete)
Comment 14 Jean-Baptiste Faure 2016-04-15 19:35:34 UTC
Same behavior with version 5.1.3.0.0+ built at home under Ubuntu 15.10 x86-64.

There is a font setting that gives for me the same result as MS-Word:
1/ select the paragraph
2/ Format > Character
3/ Tab Position -> Spacing -> Expanded -> by 0.2 pt

Please, can someone confirm that this bug is a regression? I do not see any comment stating that it worked as expected in some previous version.

Best regards. JBF
Comment 15 QA Administrators 2016-05-09 20:08:40 UTC Comment hidden (obsolete)
Comment 16 Jean-Baptiste Faure 2016-05-09 20:40:10 UTC
The status INVALID is wrong for this bug report, I set the status NEEDINFO less than one month ago.

Set status back to NEW.
Removed regression keyword because nobody said in which previous version it worked as expected (answering my own question in comment #14).

Best regards. JBF
Comment 17 Timur 2017-05-04 16:06:19 UTC
Sorry for not reading all, LO master 5.4+ renders the paragraph just like MS Word.
Maybe what Vitaliy did.