Bug 69657 - FILEOPEN: DOCX Import not showing deleted cells from table (table now has no deleted cells)
Summary: FILEOPEN: DOCX Import not showing deleted cells from table (table now has no ...
Status: RESOLVED DUPLICATE of bug 69644
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: filter:docx
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2013-09-21 17:34 UTC by Adam CloudOn
Modified: 2017-10-03 15:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
DOCX containing a table with deleted cells (19.89 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-09-21 17:34 UTC, Adam CloudOn
Details
Screenshot comparison between MS Word and LibreOffice (83.90 KB, image/png)
2013-09-21 17:37 UTC, Adam CloudOn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adam CloudOn 2013-09-21 17:34:27 UTC
Created attachment 86282 [details]
DOCX containing a table with deleted cells

Problem description: 
When loading the attached DOCX into LO - the deleted cells in the original DOCX's table become 'merged' cells in LO.

Steps to reproduce:
1. Load the attached DOCX in LO
2. Table contains no deleted cells

Current behavior:
LO imports and renders the table with no deleted cells (deleted cells are turned to merged cells in the table).

Expected behavior:
LO should import and render the table with the deleted cells.
              
Operating System: All
Version: 4.2.0.0.alpha0+ Master
Comment 1 Adam CloudOn 2013-09-21 17:37:54 UTC
Created attachment 86283 [details]
Screenshot comparison between MS Word and LibreOffice
Comment 2 Thomas van der Meulen 2013-09-29 06:57:03 UTC
Thank you for your bug report,
I can reproduce this bug running LibreOffice: 
Version: 4.2.0.0.alpha0+
Build ID: 164b6ce7b27c0a9ec19019e7b078b9f8f382007d
TinderBox: Win-x86@39, Branch:master, Time: 2013-09-28_16:39:4
And Mircosoft Word 2007
Comment 3 QA Administrators 2015-04-01 14:42:18 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2015-04-24 12:46:33 UTC
Confirmed.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha1+ (x64)
Build ID: f3375fa07f27bd2ade519af3c07d69040d10eaa9
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-22_23:38:50
Locale: fi_FI
Comment 5 QA Administrators 2016-09-20 09:33:17 UTC Comment hidden (obsolete)
Comment 6 Xisco Faulí 2017-10-03 14:46:02 UTC
I can no longer reproduce the issue in

Version: 6.0.0.0.alpha0+
Build ID: 34e8fd7e99489e9f50a512b07c6f3923b358b4d3
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Closing as RESOLVED WORKSFORME

[Improvement found by office-interoperability-tools]
Comment 7 Timur 2017-10-03 15:52:26 UTC
Fixed at least in 5.3.0.

*** This bug has been marked as a duplicate of bug 69644 ***