Bug 69687 - FORMATTING: Character spacing problem
Summary: FORMATTING: Character spacing problem
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: Other Mac OS X (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-23 01:31 UTC by Evgeniy
Modified: 2016-11-06 18:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Condensed character spacing 0.9 (on OS X 10.8) (283.39 KB, image/png)
2013-09-25 15:18 UTC, Evgeniy
Details
Default character spacing (288.60 KB, image/png)
2013-09-25 15:21 UTC, Evgeniy
Details
About LibreOffice version (84.96 KB, image/png)
2013-09-25 15:26 UTC, Evgeniy
Details
Default character spacing in 4.0.5.2 (319.67 KB, image/png)
2013-09-25 16:07 UTC, Evgeniy
Details
Condensed character spacing (0.9) version in Libreoffice 4.0.5.2 (318.42 KB, image/png)
2013-09-25 16:15 UTC, Evgeniy
Details
Test file (67.35 KB, application/vnd.oasis.opendocument.text)
2013-11-24 07:41 UTC, Evgeniy
Details
character spacing default (223.54 KB, image/png)
2014-01-24 20:50 UTC, d
Details
character spacing expanded (233.08 KB, image/png)
2014-01-24 20:51 UTC, d
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Evgeniy 2013-09-23 01:31:02 UTC
Problem description: 

Steps to reproduce:
1. Create a text document.
2. To choose Format-Character-Position: Spacing - condensed (any value from .1 to ...)


Current behavior:
There is no effect on line spacing. The document has different view in 4.1.1.2 version in comparison to 4.0.5.2. The same problem is occured in the same linux version.

Expected behavior:
It is expected to have correct character spacing in the new stable version like in previous one.
              
Operating System: Mac OS X
Version: 4.1.1.2 release
Comment 1 tommy27 2013-09-25 03:20:54 UTC
please provide a comparative screenshot of different behaviour between 4.0.5 and 4.1.1

I set platform to All since you say bug is present in Linux as well
Comment 2 Evgeniy 2013-09-25 06:37:40 UTC
It is strange situation, but now it is ok with formatting. I had the problem with my document file containing 440 pages where all my attempts to make appropriate character spacing were unsuccessful. I opened my document in Apache OpenOffice 4.0 and then saved it. After reopening the file in the LibreOffice Writer (4.1.1.2 archlinux build-2) the problem dissapeared. It seems my document was slightly damaged. I have only to test it in LibreOffice under OS X. I am sorry for the inconvinience!

(In reply to comment #1)
> please provide a comparative screenshot of different behaviour between 4.0.5
> and 4.1.1
> 
> I set platform to All since you say bug is present in Linux as well
Comment 3 Evgeniy 2013-09-25 15:18:58 UTC
Created attachment 86563 [details]
Condensed character spacing 0.9 (on OS X 10.8)

There is no effect in OS X LibreOffice Writer version 4.1.1.2 while choose any character space value.
Comment 4 Evgeniy 2013-09-25 15:21:37 UTC
Created attachment 86564 [details]
Default character spacing

Default character space value specified
Comment 5 Evgeniy 2013-09-25 15:26:24 UTC
Created attachment 86565 [details]
About LibreOffice version

LibreOffice version
Comment 6 Evgeniy 2013-09-25 15:28:08 UTC
The problem still exists in OS X 10.8....
Comment 7 Evgeniy 2013-09-25 15:46:00 UTC
Comment on attachment 86564 [details]
Default character spacing

4.1.1.2
Comment 8 Evgeniy 2013-09-25 15:46:47 UTC
Comment on attachment 86563 [details]
Condensed character spacing 0.9 (on OS X 10.8)

4.1.1.2
Comment 9 Evgeniy 2013-09-25 16:07:19 UTC
Created attachment 86568 [details]
Default character spacing in 4.0.5.2

Take a look at the different number of pages in LibreOffice 4.0.5.2 and 4.1.1.2. If I understood properly, the newest version gives incorrect text format due to the character spacing.
Comment 10 Evgeniy 2013-09-25 16:15:47 UTC
Created attachment 86575 [details]
Condensed character spacing (0.9) version in Libreoffice 4.0.5.2

4.0.5.2
Comment 11 Evgeniy 2013-10-25 01:34:48 UTC
The problem exists in LO 4.1.3.1 (mac) as well. Everyone can reproduce it by changing character space value for a text.
Comment 12 Evgeniy 2013-10-25 01:50:32 UTC
To be honest the symbol space seems to work, but there is no hyphenation for the paragraph. So there is no any action in case you change the character space value for the paragraph with width formatting.
Comment 13 retired 2013-11-23 19:06:38 UTC
Can you please provide a test document and exact step-by-step description of how to reproduce the problem?

Setting to NEEDINFO until more detail is provided.

After providing the requested info, please reset this bug to UNCONFIRMED. Thanks :)
Comment 14 Evgeniy 2013-11-24 07:41:43 UTC
Created attachment 89702 [details]
Test file

The third paragraph has character spacing that is equal to 0,9 and 6 lines. In case you open the file in previous version of the LibreOffice or in current version of OpenOffice (4.0.1) you can see 5 lines instead.
Comment 15 retired 2013-11-24 09:09:44 UTC
Confirming that third paragraph has 6 lines in LO Version: 4.3.0.0.alpha0+
Build ID: 73342dbb82ba074d01962359dac50fb2aa36cbeb
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2013-11-22_07:09:14

But is this really  a bug? Maybe LO just handles text slightly different than in previous versions? What leads you to the conclusion that what LO 4.0.x does is "correct" and LO 4.1.x behaves "incorrect"?
Comment 16 Evgeniy 2013-11-24 09:26:26 UTC
The test file is part of large text document with 440 pages. I deal with problem when open my file in the latest versions of the LO (445 pages instead). You can check the view of the third paragraph in case you change the character to condensed 1.9 (have a look at the top of the third paragraph (it has "normal" view) and check the tail of the paragraph - something terrible) or to standard (there is just no any effect). Is it normal behaviour? Really, I can't agree with that. There is no the problems in latest OpenOffice and previous LO versions.
Comment 17 Evgeniy 2013-11-24 09:32:11 UTC
The best way to check is to compare behaviour of some versions of the text processor using the test file enclosed.
Comment 18 tommy27 2013-11-24 13:06:06 UTC
loaded test file in multiple LibO versions under Win7 64bit

3.6.1, 3.6.7, 4.0.4, 4.0.5, 4.1.0, 4.1.1, 4.1.2, 4.1.3 and 4.2.0_alpha_2013-11-15.

the third paragraph lenght is always 5 lines.

as far as I can see, the issue doesn't affect Windows while is reproducible on MacOS according to Comment 15.

I change status to NEW and platform to MacOS.

@Evgeniy  
can you confirm if the issue still affects Linux as well?
Comment 19 Evgeniy 2013-11-24 13:18:02 UTC
I confirm that Linux version (4.1.3) works well (5 lines like all the Windows variants of LO you have said about). So, it seems that only the OS X version is affected.
Comment 20 d 2014-01-24 20:40:34 UTC
there's also a problem with expanded text under OS X ONLY in LibreOffice Writer all versions from 4.1 and higher (4.0.6 and earlier are not affected)

windows versions are don't affected, linux i don't know...

problem description:

lines of text no longer break automatically at the margin to the next line when character spacing is set to expanded (any value you want, eg. 0.5pt)

reproduction:

take a text (write new or copy/paste or open an existing document in Writer/LibreOffice 4.1 and higher on OS X)

when line spacing (character/position/spacing) is set to default all is fine (lines automatically break at the margin at the end of the line)

when set line spacing to expanded (any value, eg. 0.5pt) text no longer breaks automatically at the margin at the end of the line, the text lines run beyond the border of the page!
Comment 21 d 2014-01-24 20:50:46 UTC
Created attachment 92741 [details]
character spacing default
Comment 22 d 2014-01-24 20:51:34 UTC
Created attachment 92743 [details]
character spacing expanded
Comment 23 Joel Madero 2015-05-02 15:43:14 UTC Comment hidden (obsolete)
Comment 24 QA Administrators 2016-09-20 09:37:06 UTC Comment hidden (obsolete)
Comment 25 eisa01 2016-11-06 18:52:54 UTC
This works for me in latest release, the test case renders on five lines instead of six previously

Issue on comment 20 is also not present

Setting as resolved - works for me

Version: 5.2.3.3
Build ID: d54a8868f08a7b39642414cf2c8ef2f228f780cf
CPU Threads: 2; OS Version: Mac OS X 10.12; UI Render: default; 
Locale: en-US (en_NO.UTF-8); Calc: group