Bug Hunting Session
Bug 69745 - FORMATTING: optimal-row-height is ignored if there are some leading covered cells
Summary: FORMATTING: optimal-row-height is ignored if there are some leading covered c...
Status: RESOLVED DUPLICATE of bug 62268
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: bibisected, regression
Depends on:
Blocks: Calc-Cells
  Show dependency treegraph
 
Reported: 2013-09-24 06:45 UTC by Brigitte.Roschewski
Modified: 2018-06-18 16:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample-file content.xml (12.99 KB, text/xml)
2013-09-24 06:45 UTC, Brigitte.Roschewski
Details
Complete .ods-File (26.55 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-10-17 06:41 UTC, Brigitte.Roschewski
Details
used content.xml-file from BUG 69745.ods (437.53 KB, text/xml)
2013-10-17 06:42 UTC, Brigitte.Roschewski
Details
Screenshot (16.31 KB, image/png)
2013-10-17 06:44 UTC, Brigitte.Roschewski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brigitte.Roschewski 2013-09-24 06:45:16 UTC
Created attachment 86431 [details]
sample-file content.xml

We use the OpenDocument-Format for exporting data from our programs

the content.xml includes rows with an optimal-row-height style
this style is ignored if there is a leading covered cell
1. a style for a row is defined with use-optimal-row-height="true"
2. the corresponding row starting with a covered table cell doesn't appear with optimal row height


Current behavior: the row is displayed with the specified row-height and ignores the optimal-row-height flag

Expected behavior: the row should be displayed in optimal height

              
Operating System: All
Version: 4.1.1.2 release
Comment 1 Brigitte.Roschewski 2013-09-25 06:19:05 UTC
I made a mistake describing the bug:
It occurs on opening the file
It does'nt only occur with covered table cells
It also occurs if I use "min-row-height" instead of "row-height"
Comment 2 Dominique Boutry 2013-10-16 15:28:00 UTC
Hi, can you please give me the steps to open a .XML file with LibO Spreadsheet ?
Thanks
Comment 3 Brigitte.Roschewski 2013-10-17 06:41:35 UTC
Created attachment 87773 [details]
Complete .ods-File

Sample .ods-File
You can see the problem e.g. in table 3 (KST.094500 (3))
Comment 4 Brigitte.Roschewski 2013-10-17 06:42:25 UTC
Created attachment 87774 [details]
used content.xml-file from BUG 69745.ods
Comment 5 Brigitte.Roschewski 2013-10-17 06:44:16 UTC
Created attachment 87775 [details]
Screenshot
Comment 6 Dominique Boutry 2013-10-17 13:08:51 UTC
Thanks for the new attachments. I still need the info :
- what steps do you use to load the attachment 87774 [details] (1/ open Calc ; 2/ command File>Import ; in the dialog box, set X, Y ; 3/ press "GO"......)
- I would be able to confirm that the above scenario leads to the attachment 87773 [details]
- I can't find any "use-optimal-line-height" setting in the attachment 87774 [details] (after manual reading of the XML)
- so I suspect that the problem lies in the creation of the XML file.

Here too, please :
- what detailed steps do you use to generate the attachment 87774 [details] (1/ open Calc ; 2/ load attachment_X file ; 3/ set "use-optimal-line-height" to TRUE for lines A, B, C... ; 4/ command File>Import ; in the dialog box, set X, Y ; 3/ press "GO"...... or something else
Comment 7 Brigitte.Roschewski 2013-10-18 06:24:32 UTC
I don't use any LibreOffice tool for creating the .xml-files, they are produced by a program
I open the .ods-file e.g. by doubleclicking.
the parameter I use is "use-optimal-row-height"
Comment 8 Dominique Boutry 2013-10-19 06:53:30 UTC
I already pointed out that the provided XML attachment contains "<style:table-column-properties fo:break-before="auto" style:column-width="15.145mm" style:use-optimal-column-width="true"/>", but doesn't contain any "use-optimal-line-height".

So I persist that the problem lives in the input .XML file, not in LibO. I can't go further due to a lack of getting the details steps used to load those XML files.
Comment 9 Brigitte.Roschewski 2013-10-28 07:15:34 UTC
Please look at the lines with "use-optimal-row-height":

e.g.
<style:style style:name="ro0" style:family="table-row"><style:table-row-properties style:row-height="4.53mm" style:use-optimal-row-height="true" fo:break-before="auto"/></style:style>

<style:style style:name="ro35_KST_094500_5" style:family="table-row"><style:table-row-properties style:row-height="16.933mm" style:use-optimal-row-height="true" fo:break-before="auto"/></style:style>
Comment 10 Bernhard Dippold 2013-10-30 08:50:14 UTC
This bug seems directly related to bug 62268 and bug 62361 (with typo in the summary was probably not found in search for "height").
As I'm not a developer, I can't tell you, if one of these bugs is a duplicate of another one. Please feel free to test the attachments from these bugs and comment there.
Comment 11 Joel Madero 2015-02-22 06:37:45 UTC
Confirmed and bibisected

Ubuntu 14.10
LibreOffice 4.4.0.3 release

Good chance this is a dupe of bug 62268 or 62361

Setting:
New
Minor - can slow down professional quality work but won't prevent it
Medium - regression so bumped it a bit

regression.

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

7be7cf83087144563a18000acdae82c8fd6f4872 is the first bad commit
commit 7be7cf83087144563a18000acdae82c8fd6f4872
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Mon Dec 10 00:13:53 2012 +0000

    source-hash-d59024b652ccfaf7247da113ec36788fe260de74
    
    commit d59024b652ccfaf7247da113ec36788fe260de74
    Author:     Michael Stahl <mstahl@redhat.com>
    AuthorDate: Thu Jul 12 22:18:43 2012 +0200
    Commit:     Michael Stahl <mstahl@redhat.com>
    CommitDate: Thu Jul 12 22:18:43 2012 +0200
    
        warning C4101: unreferenced local variable
    
        Change-Id: I0648821a4d0c716371bb011df8cd9b21db79ccf5

:100644 100644 2e11de60e03551ff9cb9202630fabddffd9b4d03 13d66368624db1158439984d29b9b6b4e382edc1 M	autogen.log
:100644 100644 1aef3215ed700bc4e85fd12d18339c24ebf234a7 1c9624dd465ee0e59acd9c9dd05950b51be0c666 M	ccache.log
:100644 100644 f13bcc6696e46ed88900fa5b2390642319998036 b55a2bd9212e07b4042ebd0bb46515c8a4e76c04 M	commitmsg
:100644 100644 9d65d2f7c48177028e23641bc3eb0528844456f9 5270492409e164dc751ec11e4524f63b7739b35f M	dev-install.log
:100644 100644 9134f8edd2ee62e54d25821b3cc071e2aee24b5a f188090f0a4137ab411a3ff359ec440f0da4644c M	make.log
:040000 040000 e1e8f612101470e3ff2f6a53fc8c5e664103243f bb164bd44517d96b184ae0ecb1e8ccaf46ba0b4d M	opt


# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# bad: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect bad e02439a3d6297a1f5334fa558ddec5ef4212c574
# bad: [8f4aeaad2f65d656328a451154142bb82efa4327] source-hash-1885266f274575327cdeee9852945a3e91f32f15
git bisect bad 8f4aeaad2f65d656328a451154142bb82efa4327
# good: [369369915d3582924b3d01c9b01167268ed38f3b] source-hash-45295f3cdceb4c289553791071b5d7f4962d2ec4
git bisect good 369369915d3582924b3d01c9b01167268ed38f3b
# good: [6fce03a944bf50e90cd31e2d559fe8705ccc993e] source-hash-47e4a33a6405eb1b5186027f55bd9cb99b0c1fe7
git bisect good 6fce03a944bf50e90cd31e2d559fe8705ccc993e
# bad: [da317333e5675622f55c9dda17396c659af65320] source-hash-15af925c254f27046427de70a59011e2ac3d6bdb
git bisect bad da317333e5675622f55c9dda17396c659af65320
# good: [daa21bbd8c7b50e2ca1c2cbed0e39f0e7b5a1cb2] source-hash-6b11a18071254a443c8fe7e7b0b1c95b0f9fd35e
git bisect good daa21bbd8c7b50e2ca1c2cbed0e39f0e7b5a1cb2
# good: [a08143f4bae3d6658dd756b42b6f343298d1f48c] source-hash-b7822657fa67e7265d07f5852057e975e9efae0d
git bisect good a08143f4bae3d6658dd756b42b6f343298d1f48c
# good: [5255e1fbf1f3fa3ca61c4db3005940205577863c] source-hash-63c004fc3f0bc53ce888ef012f7993b9203a7503
git bisect good 5255e1fbf1f3fa3ca61c4db3005940205577863c
# bad: [7be7cf83087144563a18000acdae82c8fd6f4872] source-hash-d59024b652ccfaf7247da113ec36788fe260de74
git bisect bad 7be7cf83087144563a18000acdae82c8fd6f4872
# good: [ad874a5319e9f68e6b3a974e44de838b8a0a82e1] source-hash-4b4ca8030285bd66526ff5bb2b6ea5a75a6c6bc7
git bisect good ad874a5319e9f68e6b3a974e44de838b8a0a82e1
# first bad commit: [7be7cf83087144563a18000acdae82c8fd6f4872] source-hash-d59024b652ccfaf7247da113ec36788fe260de74
Comment 12 Robinson Tryon (qubit) 2015-12-13 11:16:15 UTC Comment hidden (obsolete)
Comment 13 Xisco Faulí 2016-10-07 10:14:16 UTC
Already reproduced in Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 15 Timur 2018-06-18 16:14:48 UTC
Repro 6.0. Works for me with master 6.2+. 
I just opened attachment 87773 [details] sheet 3 and compared with attachment 87775 [details].
I guess it's a duplicate of Bug 62268.
Feel free to set back to New if proved otherwise.

*** This bug has been marked as a duplicate of bug 62268 ***