Bug 69754 - FILEOPEN: CRASH when FILEOPEN certain docx files (MS Word 2007/2010 XML Format)
Summary: FILEOPEN: CRASH when FILEOPEN certain docx files (MS Word 2007/2010 XML Format)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-24 12:21 UTC by James Dietrich
Modified: 2013-09-26 19:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
contains two documents that cause LibreOffice to crash upon opening them (8.25 KB, application/zip)
2013-09-24 12:21 UTC, James Dietrich
Details
Crash log from opening file (65.34 KB, text/plain)
2013-09-25 16:38 UTC, James Dietrich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James Dietrich 2013-09-24 12:21:58 UTC
Created attachment 86445 [details]
contains two documents that cause LibreOffice to crash upon opening them

Problem description:
LibreOffice on Mac OS X crashes upon opening the attached document.
(I also have LibreOffice on a Linux machine, and this problem does not occur there.)

Steps to reproduce:
1. Open the attached documents in a Mac OS X version of LibreOffice.

Current behavior:
The program crashes on startup.

Expected behavior:
The program opens the file for viewing/editing/etc.

I have tried LibreOffice 4.0.5.2 on Mac OS X 10.8.4 and also LibreOffice 3.3.1 on Mac OS X 10.6.8. Both crash in the same way.

This problem has existed for some time. A couple years (?) ago I remember having this same problem, and I even tried installing a version of OpenOffice, but the problem was still the same.

I chose two files that caused a crash, and used LibreOffice on a Linux machine to trim them down to fairly minimal documents that still cause a crash. They are attached in crash.zip.

Please let me know if more information would be useful or if there is anything else I can do to help this get solved.
Operating System: Mac OS X
Version: Inherited From OOo
Comment 1 Thomas van der Meulen 2013-09-25 15:37:05 UTC
Thank you for your bug report, I CAN'T reproduce this bug running 
Version: 4.1.2.2
Build ID: 281b75f427729060b6446ddb3777b32f957a8fb 
and 
Version 4.0.5.2 
Build ID: 5464147a081647a250913f19c0715bca595af2f
on Mac osx 10.8.4.
Comment 2 James Dietrich 2013-09-25 16:38:52 UTC
Created attachment 86576 [details]
Crash log from opening file

Perhaps a crash log would help. I'll attach a file crash_log_1.txt, which results from attempting to open the file "crash MBF Year 2 Quarter 1 Unit 1.docx" on Mac OS X 10.8.4 with LibreOffice Version 4.0.5.2 (Build ID: 5464147a081647a250913f19c0715bca595af2f)

Is there anything else that would be helpful?
Comment 3 Julien Nabet 2013-09-25 21:07:28 UTC
On pc Debian x86-64 with master sources updated yesterday, I don't have a crash but I noticed these logs:
warn:legacy.osl:6727:1:svl/source/items/style.cxx:256: StyleSheet-Follow nicht gefunden
warn:writerfilter:6727:1:writerfilter/source/dmapper/DomainMapper.cxx:1484: DomainMapper::attribute() - Id: 92525 / 0x1696d value: 0 / 0x0
warn:writerfilter:6727:1:writerfilter/source/dmapper/DomainMapper.cxx:1484: DomainMapper::attribute() - Id: 92525 / 0x1696d value: 0 / 0x0
warn:writerfilter:6727:1:writerfilter/source/dmapper/DomainMapper.cxx:1484: DomainMapper::attribute() - Id: 92525 / 0x1696d value: 1 / 0x1
warn:writerfilter:6727:1:writerfilter/source/dmapper/DomainMapper.cxx:1484: DomainMapper::attribute() - Id: 92525 / 0x1696d value: 2 / 0x2
warn:writerfilter:6727:1:writerfilter/source/dmapper/DomainMapper.cxx:1484: DomainMapper::attribute() - Id: 92525 / 0x1696d value: 2 / 0x2
warn:writerfilter:6727:1:writerfilter/source/dmapper/DomainMapper.cxx:1484: DomainMapper::attribute() - Id: 92127 / 0x167df value: 92028 / 0x1677c
warn:legacy.osl:6727:1:oox/source/helper/storagebase.cxx:71: StorageBase::StorageBase - missing base input stream
Comment 4 Julien Nabet 2013-09-25 21:10:47 UTC
James: Thomas' feedback is very useful since he's got the same MacOs version as you and don't reproduce the pb with 4.1.1.2. Could you give a try to this version and see if you still reproduce this?
Comment 5 Thomas van der Meulen 2013-09-26 05:18:20 UTC
I CANNOT reproduce this bug of any of this versions:
Version: 4.1.2.2
Build ID: 281b75f427729060b6446ddb3777b32f957a8fb

Version: 4.1.1.2
Build ID: 7e4286b58adc75a14f6d83f53a03b6c11fa2903

Version: 4.1.0.3
Build ID: 0f08a823567f802c29cbaf2b327db19aaf72016

Version 4.0.5.2 
Build ID: 5464147a081647a250913f19c0715bca595af2f

Version 3.6.7.2
Build ID: e183d5b

All version tested with a new user. 
OS: 10.8.5
Comment 6 Julien Nabet 2013-09-26 05:24:20 UTC
Thomas: Thank you for this new feedback. BTW, my previous comment was for James, so please don't revert back status to "UNCONFIRMED".

James: I've got some other questions:
- did you install any LO specific extensions?
- could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#Mac_OS_X) and give it a new try?
Comment 7 James Dietrich 2013-09-26 13:51:02 UTC
Thomas: Thank you for the time you've taken to test with the various versions. It's much appreciated.

Julien: Thank you also for your helpful suggestions. Here's what I've done:

You asked me to test with 4.1.1.2, but Thomas had originally reported testing with 4.1.2.2, so that's what I downloaded (Build ID: 281b75f427729060b6446ddb3777b32f957a8fb).

I created a new user and tried opening the file in 4.1.2.2, and it opened just fine. Then I went back to the original user, and still was not able to reproduce the problem.

Then I installed 4.0.5.2 and that version crashed very reliably, just as I originally reported. (I still don't understand why Thomas couldn't reproduce the problem in 4.0.5.2.) Anyway, I've installed 4.1.2.2 again and hopefully this problem won't come up again. If it does, though, I can reopen this bug.

Also, I'm sorry I didn't test with the most recent version before submitting this bug report. This problem had been going on so long that I didn't think it would make a difference.

Thanks again, both of you, for your help on this.
Comment 8 tommy27 2013-09-26 19:22:34 UTC
@James
so I mark a s RESOLVED WORKSFORME (obviously is you)
by the way, I have no crash with test documents in 4.1.1.2 under Win7 64bit
Comment 9 Julien Nabet 2013-09-26 19:25:29 UTC
James: great for you!:-) Thank you for the feedback.