Bug 69758 - UI: Arrows missing from Dropdown Menu Buttons
Summary: UI: Arrows missing from Dropdown Menu Buttons
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-24 16:19 UTC by David Hicks
Modified: 2013-09-30 17:21 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
attachment-27055-0.html (3.67 KB, text/html)
2013-09-25 16:10 UTC, David Hicks
Details
attachment-27055-1.dat (1 bytes, multipart/alternative)
2013-09-25 16:10 UTC, David Hicks
Details
libreoffice-writer-missing-dropdown-arrows-1.jpg (296.19 KB, image/jpeg)
2013-09-25 16:10 UTC, David Hicks
Details
libreoffice-writer-missing-dropdown-arrows-2.jpg (76.52 KB, image/jpeg)
2013-09-25 16:10 UTC, David Hicks
Details
dropdown arrows missing from X-LibreOffice portable too (191.01 KB, image/jpeg)
2013-09-26 04:21 UTC, David Hicks
Details
Dropdown button problem solved by changing to a Windows theme other than Ventura (Startdock Windowblinds 8) (119.61 KB, image/jpeg)
2013-09-30 16:55 UTC, David Hicks
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Hicks 2013-09-24 16:19:07 UTC
Problem description: 

Down Arrows on Dropdown Menu Buttons are Missing

Steps to reproduce:
1. Install Release 4.1.0.4 or 4.1.1.
2. Look for dropdown menus for items like Apply Style, Font Name, Font Size in 'Styles and Formatting' Toolbar or in various dialogs such as Paragraph formatting -> Indents and Spacing Tab -> Line Spacing 

Current behavior: Down Arrows on Dropdown Menu Buttons are Missing (not displayed, not visible)

Expected behavior: Down Arrows on Dropdown Menu Buttons should be displayed

              
Operating System: Windows 8
Version: 4.1.1.2 release
Last worked in: 4.1.0.4 release
Comment 1 tommy27 2013-09-25 03:14:29 UTC
not reproducible on 4.1.1.2 under Win764. I see down arrows.
could you please provide a screenshot? is you Win8 a 32 or 64bit machine?
Comment 2 David Hicks 2013-09-25 16:10:51 UTC
Created attachment 86571 [details]
attachment-27055-0.html

On 9/24/2013 11:14 PM, bugzilla-daemon@freedesktop.org wrote:
> tommy27 <mailto:barta@quipo.it> changed bug 69758 
> <https://bugs.freedesktop.org/show_bug.cgi?id=69758>
> What 	Removed 	Added
> CC 		barta@quipo.it
>
> *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=69758#c1> 
> on bug 69758 <https://bugs.freedesktop.org/show_bug.cgi?id=69758> from 
> tommy27 <mailto:barta@quipo.it> *
> not reproducible on 4.1.1.2 under Win764. I see down arrows.
> could you please provide a screenshot? is you Win8 a 32 or 64bit machine?
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>

Hi,

Please see attached screenshots. The areas with missing dropdown arrow 
controls are circled. ("Spinner" controls do not have this problem.) I'm 
on Windows 8.0 x64 Build 9200, Samsung Series 7 all-in-one. I checked 
all other LibreOffice components--Calc, Draw, Impress, Base. They all 
have the same identical issue. Thank you.

David Hicks
Comment 3 David Hicks 2013-09-25 16:10:51 UTC
Created attachment 86572 [details]
attachment-27055-1.dat
Comment 4 David Hicks 2013-09-25 16:10:51 UTC
Created attachment 86573 [details]
libreoffice-writer-missing-dropdown-arrows-1.jpg
Comment 5 David Hicks 2013-09-25 16:10:51 UTC
Created attachment 86574 [details]
libreoffice-writer-missing-dropdown-arrows-2.jpg
Comment 6 tommy27 2013-09-25 16:27:53 UTC
maybe a Win8 specific bug...

downlaod this portable version: 
http://sourceforge.net/projects/winpenpack/files/X-LibreOffice/releases/X-LibreOffice_4.1.1_rev16.zip/download

and please tell me if it still has this arrow bug like the normal installed version.
Comment 7 David Hicks 2013-09-26 04:21:21 UTC
Created attachment 86610 [details]
dropdown arrows missing from X-LibreOffice portable too

dropdown arrows missing from X-LibreOffice portable 4.1.1.2 as well as regular Windows installed version
Comment 8 tommy27 2013-09-26 05:12:59 UTC
adding GUI expert to CC list.

according to reporter it has been a very recent regression (worked in 4.1.0.4)
Comment 9 Ivan Timofeev (retired) 2013-09-27 18:22:42 UTC
(In reply to comment #0)
> Steps to reproduce:
> 1. Install Release 4.1.0.4 or 4.1.1.
[...]
> Version: 4.1.1.2 release
> Last worked in: 4.1.0.4 release

I suppose it does *not* work for you in 4.1.0.4 after all? Secondly, is this bug related to that particular theme?
Comment 10 David Hicks 2013-09-27 21:18:18 UTC
Correct. I first saw it in 4.1.0.4 and my next install was 4.1.1.2, where it is also happening. With regard to Appearance/UI/Themes, everything is the default--no themes, small Galaxy icons, UI Scaling 100%, using default system font for Libre UI.
Comment 11 Ivan Timofeev (retired) 2013-09-28 07:36:07 UTC
I mean the Win8 theme. :)

Actually we do not draw an arrow separately, we draw a special "combobox dropdown button" which has an arrow. So it looks like a theme bug.

To be sure can you run http://privat.rejbrand.se/UxExplore.exe and select Class: COMBOBOX, Part: CP_DROPDOWNBUTTON, State: CBXS_NORMAL. I guess it will show the same button without an arrow.
Comment 12 tommy27 2013-09-29 06:15:41 UTC
(In reply to comment #10)
> Correct. I first saw it in 4.1.0.4 and my next install was 4.1.1.2, where it
> is also happening. 
 
@David
ok, so it was not a regression. I adjust version field.
have you ever tried earlier LibO versions on that Win8 PC or 4.1.0 and 4.1.1 were the only LibO install you tried?
Comment 13 David Hicks 2013-09-30 16:51:09 UTC
Per Ivan Timofeev suggestion, I changed the Windows theme/skin using Windowblinds 8 and the problem with the dropdown buttons has gone away. I did not think to check the Windows theme earlier and I did not think to consider the skinning application as a possible factor, my mistake. 

The problem appears to be associated with the particular theme I was using. I've tried the Windows 8 default theme and two additional themes and the problem did not recur. I'm posting a screen shot of the corrected problem.

FYI, before reverting to Win 8 default theme and trying other themes, I launched OpenOffice 3.4.1 and found that the same issue was also present on OO with the theme that caused the issue.

The theme causing the issue is Ventura by essorant on Windowblinds. 
Product details: 
Windows 8 (9200.win8_gdr.130531-1504)
WindowBlinds 8.01 (020 - Windows 8 Edition) - 64 bit OS

Please update the Bug status accordingly. The issue is resolved. I will take it up with the theme author.
Comment 14 David Hicks 2013-09-30 16:55:43 UTC
Created attachment 86858 [details]
Dropdown button problem solved by changing to a Windows theme other than Ventura (Startdock Windowblinds 8)

See my comment on 9/30/2013.
Comment 15 David Hicks 2013-09-30 16:59:49 UTC
The issue with the dropdown buttons under Windowblinds Ventura theme was seen only in LibO and OO. It did not appear in any other applications.