Download it now!
Bug 69766 - Problem with stock charts data ranges when saving
Summary: Problem with stock charts data ranges when saving
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-24 18:11 UTC by Mamoth
Modified: 2015-12-21 16:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
The file to reproduce the bug (48.40 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-09-24 18:11 UTC, Mamoth
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mamoth 2013-09-24 18:11:41 UTC
Created attachment 86467 [details]
The file to reproduce the bug

Hello.

This bug accured to me simultaneously with bug 69698, with the same file.

The version of LO is 4.0.4.2. The OS is Ubuntu 12.04 up-to-date.

To reproduce the bug : 
 - download the attachment. It's a .ods file. Open it.
 - There is only one sheet, called GES_sélection. It has 1 chart but also 1 image which is a screen capture of the same chart, when formatting was done, before saving the file.
 - Double-click the chart to edit it. Right-click to open the 'Data ranges' window. 
 - Choose the 'Data series' tab. 
 - Edit the existing 'Unamed series' to have as values : for the Name, cell A21, for the high value cell E21, for the low value cell B21.
 - Add four other series, one for each line of data (22 to 25) using the matching cells for Names (A22 to A25), high values (E22 to E25), low values (B22 to B25).
 - Close the 'Data ranges' window.
 - For each one of the data points in the chart : double click to open the 'Data series' window and change the width (I set it to 5 mm).
 - You end up having a graph similar to the one in the picture on the right-hand side, with the names of the series at the bottom, a thick line with a distinct colour for each.
 - Save the file and close it.
 - Open it again : all changes are gone.
Comment 1 ign_christian 2013-09-25 03:27:28 UTC
I can confirm that behavior on LO 4.0.5.2 (Win7 32bit). But still can't analyze what's going on there.

Emm..Have you ever tried fill in "Open Values" & "Close Values" so no ranges leave blank ?
I also saw "Categories" field filled in incorrectly & "First row as label" checked, were it by intention?
Comment 2 Mamoth 2013-09-25 12:58:54 UTC
Well .. I tried filling the Open and Close values, using the same cells as (respectively) the Low and High values, and deleting the Categories value.
After I save and re-open the file, the Data ranges are still there (that's already an improvement), but the Open values have disappeared. 
Besides, when I change the line width of the Data points in the charts, after re-opening the file, it is back to it's default value, save for the first point.
Comment 3 Jacques Guilleron 2013-12-21 14:03:59 UTC
Hello Mamoth,

Following your steps, I got the same results with LO 4.1.3.2 and LO 4.3.0.0.alpha0+ on Windows 7 Home Premium, but:
Opening this document in LO 3.6.6.2 portable show the changes, though edit the Chart return to the same state as we find by opening it in the higher versions.
Trying to resize the Chart, without moving the mouse, just by clicking on handle, show two supersosed views:
 the previous changes, and you can see that they were saved.
 the edit mode, with one Data point missing.
So, for me,the Edit mode can not be quit. this is the real bug.
Do you agree with that?

Kind regards,

Jacques
Comment 4 Jacques Guilleron 2013-12-21 21:56:56 UTC
Hello Mamoth,

Forget Edit mode. Nothing to see with that.

Jacques
Comment 5 Mamoth 2013-12-23 18:12:24 UTC
The bug still occurs in my file.
I have found a way to cope with it for my work but I wanted to report it to the developers.
Comment 6 Jan Zeleny 2014-11-07 09:51:56 UTC
I'm not sure if this is the same bug I'm hitting but I experience similar behavior. After some experimentation, I narrowed this down to the following behavior:

If I have a chart (I'm using column charts, not sure if this is chart type specific or not) where I define data series, the reference to the data series is lost and replaced by static data tables. There are some specifics though. This happens only when there are more than one data series in the chart. On the other hand this doesn't happen if there is a Data Range defined for the chart (which is the case when the data series constitute one continuous area).

I hope this information helps you at least a bit. If you need any more help debugging this behavior, feel free to let me know.
Comment 7 QA Administrators 2015-12-20 16:14:01 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.4 or later)
   https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 

4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-12-20
Comment 8 Mamoth 2015-12-21 16:34:30 UTC
I have tried with the new version of LO 5.

The chart used to reproduce the bug is now empty so it is not possible to reproduce it.
The bug may still exist but it is not possible to test it.