Bug 69829 - soffice executable should have another name to avoid conflicts with OpenOffice
Summary: soffice executable should have another name to avoid conflicts with OpenOffice
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: All Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-26 02:55 UTC by Ignacio Areta
Modified: 2013-10-05 05:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ignacio Areta 2013-09-26 02:55:17 UTC
LibreOffice and OpenOffice could be installed side to side. Unfortunaly, this is not possible (or at least, not OOTB) LibreOffice uses the same executable of OpenOffice.

I have LibreOffice installed first, and then I tried to install OpenOffice. But when I tried to install the OpenOffice's menus, the package manager gives an error because of the conflict.

Steps to reproduce:

1. Install LibreOffice.
2. Install OpenOffice base packages.
3. Try to install OpenOffice executable files (menus). The following error will appear:

rpm -Uvih openoffice4.0-freedesktop-menus-4.0-9702.noarch.rpm
Preparing...                          ################################# [100%]
        file /usr/bin/soffice from install of openoffice4.0-freedesktop-menus-4.0-9702.noarch conflicts with file from package libreoffice-4.1.1.2-1.1.x86_64
Comment 1 Jean-Baptiste Faure 2013-09-29 16:25:41 UTC
There is no problem to install both 4.0.5 and 4.1.x LibreOffice versions (generic Linux versions from TDF) side by side. Both have the same executable name, so I conclude that the problem is on the OpenOffice side. Please file a bug report on the AOO bugtracker against AOO.

Best regards. JBF
Comment 2 Ignacio Areta 2013-10-05 05:27:56 UTC
(In reply to comment #1)
> There is no problem to install both 4.0.5 and 4.1.x LibreOffice versions
> (generic Linux versions from TDF) side by side. Both have the same
> executable name, so I conclude that the problem is on the OpenOffice side.
> Please file a bug report on the AOO bugtracker against AOO.
> 
> Best regards. JBF

OK, you are right. I can install LibreOffice generic version from TDF and OpenOffice from Apache side to side, they don't use the same executable. The problem is in openSUSE. Reported.
https://bugzilla.novell.com/show_bug.cgi?id=844173