Bug 69857 - Other: Support OS X spotlight searches (indexing the content of LO ods and odt)
Summary: Other: Support OS X spotlight searches (indexing the content of LO ods and odt)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Mac OS X (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-26 19:03 UTC by retired
Modified: 2015-08-12 11:59 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description retired 2013-09-26 19:03:15 UTC
Problem description: On OS X when searching for something, OS X spotlight is what you use. Spotlight indexes all file on the machine. For iWork documents that worked great, because spotlight was even able to search through an iWork Writer text or iWork numbers sheet.

My personal use case is: I was doing budgeting with iWork. If e.g. then I wanted to know when I bought a certain item, I just entered that item in spotlight and *ping* there was the iWork numbers document showing me already in it's file name which month that item was bought.

There's a ton of other use cases.

Current behavior: no spotlight indexing (also no quicklook, which is a bug in itself: https://bugs.freedesktop.org/show_bug.cgi?id=35361 )

Expected behavior: search for LO document contents via spotlight

              
Operating System: Mac OS X
Version: unspecified
Comment 1 Emir Sarı (away) 2013-10-11 16:48:44 UTC
A valid request, therefore setting status to NEW.
Comment 2 steve -_- 2015-08-12 11:58:45 UTC
WORKSFORME

This is super awesome since it makes my life and the life of all OS X users *a lot* easier.

Being able to search all writer and table documents with spotlight is a huge win.

Tested on OS X 10.10.4 LO Version: 5.1.0.0.alpha1+
Build ID: 958ec9ccfe3bbe54369f9e9105c10beae80d9548
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2015-08-09_14:03:07
Locale: de-DE (de.UTF-8)