Download it now!
Bug 69932 - Toolbar elements flicker on resize (not with GTK3)
Summary: Toolbar elements flicker on resize (not with GTK3)
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.1.1 rc
Hardware: All Linux (All)
: low trivial
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: notBibisectable, regression
Depends on:
Blocks: Flickering-UI
  Show dependency treegraph
 
Reported: 2013-09-29 14:39 UTC by PedroNGV
Modified: 2019-09-30 12:03 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description PedroNGV 2013-09-29 14:39:06 UTC
--> Problem description: 

I've always used the Libreoffice versions 3.x.x on Linux without problems. With version 4.0.0.x I also had no problem.

However, starting with version 4.0.1.2, my libreoffice has a flicker on the toolbars icons. Right now I've tested versions 4.0.5.2 and 4.1.1.2 (Linux_x86) and continue with the problems visible in these screencasts:

http://goo.gl/VeVkHg 
http://goo.gl/4rkWJ 

If you look, when I put the toolbars loose, the error disappears. But the rest of the icons (up and down on the bottom right) or vertical and horizontal scroll bars are still blinking. I've tried disabling hardware acceleration in the options, but without success.

I'm using Xubuntu 12.04 32bits (kernel 3.2.0-54-generic) and nvidia drivers v319.49. The JRE is the Java Oracle v1.7.0_40. As I mentioned, this is happening since version 4.0.1.2, keeping the problem over the last versions of kernel and graphic drivers.


Operating System: Linux (Other)
Version: 4.0.1.2 release
Last worked in: 3.6.7.2 release
Comment 1 Robinson Tryon (qubit) 2013-10-16 04:04:33 UTC
Watching the provided videos, the flicker is very apparent. The toolbar appearance is much worse in the 2nd video -- is that video demonstrating LO 4.1.1.2?

Testing on Ubuntu 12.04.3, I see icon repaint flicker whenever I resize the main window of LibreOffice in *both* LO 4.1.2.3 and LO 3.5.7.2. As such, changing 'regression' -> 'PossibleRegression' until we can get independent confirmation of a regression.

Pedro - Could you please provide a video of 3.6.7.2 showing the previous behavior? It would be great to see the before/after comparison so that we can identify and track down this regression.

Thanks
Comment 2 Robinson Tryon (qubit) 2013-10-16 04:05:23 UTC
Joel -- Suggestions on flicker-related problems?
Comment 3 Joel Madero 2013-10-16 04:09:19 UTC
First thing I'd suggest is resetting the profile (unlikely to be the issue but always good to start with a fresh profile)

Next question - do you have a second system to test the same release in Xubuntu that does not have Nvidia driver? Perhaps some code cleanup on our side triggered a nvidia bug (not that hard to believe).

Lastly - PedroNGV - if we walked you through the steps to bibisect the bug would you be willing to do so? It would be very helpful to narrow down the range where things went wacky. If so, are you familiar with IRC at all? I'd be happy to walk you through the steps, they aren't that difficult but you do need about 20 gigs of free space and high speed net to download the daily bibisect package
Comment 4 PedroNGV 2013-10-16 14:25:14 UTC
Hi Qubit,

> Watching the provided videos, the flicker is very apparent. The toolbar
> appearance is much worse in the 2nd video -- is that video demonstrating LO
> 4.1.1.2?

No,

http://goo.gl/VeVkHg is LibO 4.0.1.2
http://goo.gl/4rkWJ is LibO 4.1.1.2

Despite everything, it is a little better in newer versions.

> Pedro - Could you please provide a video of 3.6.7.2 showing the previous
> behavior? It would be great to see the before/after comparison so that we
> can identify and track down this regression.

Yes, here it is: http://goo.gl/chu4d8 

Like you said, there is also some icon repaint flicker, but nothing to compare with versions 4.

Thank you very much!

Best regards,
Pedro
Comment 5 PedroNGV 2013-10-16 18:48:20 UTC
Hi Joel,

> First thing I'd suggest is resetting the profile (unlikely to be the issue
> but always good to start with a fresh profile)

Whenever I test a new version, I purge LibO and delete the folder /.config/libreoffice.


> Next question - do you have a second system to test the same release in
> Xubuntu that does not have Nvidia driver? Perhaps some code cleanup on our
> side triggered a nvidia bug (not that hard to believe).

Unfortunately, I only have another machine with Xubuntu, and is a laptop also with a nvidia graphic card. However, I have different versions of nvidia drivers - 319.49 on the desktop and 304.88 on the laptop.

The flicker is the same in both machines. It is even more noticeable on the laptop because it is a machine with less performance.


> Lastly - PedroNGV - if we walked you through the steps to bibisect the bug
> would you be willing to do so? It would be very helpful to narrow down the
> range where things went wacky. 

Yes, I would love to contribute, but I confess I do not know the process. If you can help me, I'm completely open!


> If so, are you familiar with IRC at all?

For a long time I do not use IRC, but if there is no alternative I can try to use IRC again.


> I'd be happy to walk you through the steps, they aren't that difficult but you
> do need about 20 gigs of free space and high speed net to download the daily
> bibisect package

Yes, I have these requirements.

Thank you very much Joel!

Best regards,
Pedro
Comment 6 Joel Madero 2013-10-16 20:08:06 UTC
No worries about IRC :) You can do one of two things and I'll walk you through the steps:

1. Try on your own following the wiki: https://wiki.documentfoundation.org/QA/HowToBibisect

Make sure to use the daily build (not the 4.0 branch one, as it only goes through 4.0beta0 (unless you experienced the problem in 3.6.x)

or

2. Email me and we'll either setup a IRC time or go through email one step at a time.


Thanks so much for offering to help bibisect, that'll help tremendously
Comment 7 Joel Madero 2013-10-17 21:14:55 UTC
I went ahead and prioritized, changed version (Thanks to Pedro for doing a ton of work to narrow it down to 4.0.1.1 rc. 

My setup:
Ubuntu 13.04
LibreOffice 4.1.1.2 release

New (I actually was able to confirm after looking at the video a couple more times)
Trivial - no impact on ability to do professional work
Low - default is lowest but low because of regression


Thanks to Pedro's work I'm convinced it's a regression, Marking as ConfirmedRegression
Comment 8 PedroNGV 2013-10-17 21:27:38 UTC
Thanks Joel!

If this can help, I leave here two screencasts where we clearly observe the emergence of the problem in version 4.0.1.1:

- LibreOffice_4.0.0.3_Linux_x86_deb: http://goo.gl/yYj6MV 

- LibreOffice_4.0.1.1_Linux_x86_deb: http://goo.gl/SdGEFk 

Thank you very much!

Best regards,
Pedro
Comment 9 Robinson Tryon (qubit) 2013-10-23 18:43:07 UTC Comment hidden (obsolete)
Comment 10 Robinson Tryon (qubit) 2013-10-29 14:28:24 UTC
ConfirmedRegression (in whiteboard) -> 'regression' in Keywords.

(Ideally both tags would be Keywords or both live in the Whiteboard)
Comment 11 Piotr Jurkiewicz 2014-08-17 02:14:11 UTC
I experience the same kind of flicker on Ubuntu 12.04 x64 (kernel 3.5).

Using Libreoffice:
Version: 4.3.0.4
Build ID: 430m0(Build:4)

Furthermore, window controls like buttons flicker too...
Comment 12 retired 2014-08-30 12:09:44 UTC
Is LO 4.3.1 any better? If not experienced any flickering here with Ubuntu 14.04.
Comment 13 Robinson Tryon (qubit) 2014-08-30 13:50:22 UTC
(In reply to comment #12)
> Is LO 4.3.1 any better? If not experienced any flickering here with Ubuntu
> 14.04.

I'm still seeing some (small) flickering issues with 4.3.1.1 on Ubuntu 14.04:

(In reply to comment #1)
> Testing on Ubuntu 12.04.3, I see icon repaint flicker whenever I resize the
> main window of LibreOffice in *both* LO 4.1.2.3 and LO 3.5.7.2.

For comparison, I do not see any flicker in the icons of Firefox 31 when I resize a browser window.
Comment 14 tommy27 2015-08-30 20:33:43 UTC
LibO 5.0.1 is out. has the Linux flickering changed?
Comment 15 guentherd 2015-11-24 23:59:41 UTC
(In reply to tommy27 from comment #14)
> LibO 5.0.1 is out. has the Linux flickering changed?

I can confirm that the windows build (LibreOffice 5.0.3.2) still has this problem
Comment 16 Robinson Tryon (qubit) 2015-12-14 05:33:50 UTC Comment hidden (obsolete)
Comment 17 QA Administrators 2017-05-22 13:19:14 UTC Comment hidden (obsolete)
Comment 18 Buovjaga 2018-04-30 17:27:03 UTC
Repro the flickering on resize, but not with GTK3.
No flicker on Windows.

Arch Linux 64-bit
Version: 6.1.0.0.alpha1+
Build ID: 632bc11ce8fab1c4046ab24810b90a7ce9ac5914
CPU threads: 8; OS: Linux 4.16; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on April 27th 2018

Version: 6.1.0.0.alpha1 (x64)
Build ID: cb47f0d320994e001bc38dc2ee9b7d957b15e6ab
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: fi-FI (fi_FI); Calc: group
Comment 19 Buovjaga 2018-06-30 16:44:58 UTC
With the default VCL backend in the Linux 43all bibisect repo builds, the toolbar icons flicker on resize already in the oldest commit (3.5.0).
With gen VCL backend I got a very rare flicker in the latest build, but I would not call this bibisectable.
Comment 20 QA Administrators 2019-07-01 02:46:38 UTC Comment hidden (obsolete)
Comment 21 Divakar Ramachandran 2019-09-24 18:20:23 UTC
Version: 6.2.7.1 (x64)
Build ID: 23edc44b61b830b7d749943e020e96f5a7df63bf
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: en-IN (en_IN); UI-Language: en-GB
Calc: threaded

This version shows a flicker of all toolbar icons when started with hardware acceleration with OpenGL not selected. The flicker is lost when hardware acceleration is turned off and OpenGL is used. 

System has NVidia GeForce 310 graphics card with NVidia Driver signed by Microsoft, version 21.21.13.4201 (latest available in Windows Update).

I know this is an old system with latest Windows OS - performance is in general not an issue and this flicker was definitely not present before the recent update to this version of LO.
Comment 22 Buovjaga 2019-09-30 12:03:37 UTC
As gtk3 and kf5 backends do not flicker and gtk2 backend is going away, I don't see much point keeping this open.

Note re: the preceding comment: this report was about Linux only.

Arch Linux 64-bit
Version: 6.4.0.0.alpha0+
Build ID: 2e347c94503321c2102c6f78f5f5bcb771727e69
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: kf5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 30 September 2019