Bug 69938 - Incorrect displaying doc document due to missing Calibiri compatible font
Summary: Incorrect displaying doc document due to missing Calibiri compatible font
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: NoRepro:4.2.0.1:OSX target:4.3.0 targ...
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-29 19:48 UTC by mikhail.v.gavrilov
Modified: 2014-08-07 11:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
doc file for demonstration (37.00 KB, application/msword)
2013-09-29 19:48 UTC, mikhail.v.gavrilov
Details
screenshot for comparing libreoffice and ms word (175.86 KB, image/png)
2013-09-29 19:48 UTC, mikhail.v.gavrilov
Details
Correct displaying with ubuntu 13.04 LibreOffice 4.1.2.3 RC. (91.69 KB, application/pdf)
2013-10-03 08:41 UTC, Kevin Suo
Details
Fedora 20 with LO 4.1.2.3 and problem present (158.82 KB, image/png)
2013-10-03 09:24 UTC, mikhail.v.gavrilov
Details
page 4 differences between LO and Word (154.75 KB, image/png)
2013-12-23 06:02 UTC, mikhail.v.gavrilov
Details
4.1.4.2 version and same result (160.52 KB, image/png)
2014-01-25 10:18 UTC, mikhail.v.gavrilov
Details
4.1.4.2 version + msttcorefonts (94.80 KB, image/png)
2014-01-26 21:16 UTC, mikhail.v.gavrilov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mikhail.v.gavrilov 2013-09-29 19:48:03 UTC
Created attachment 86812 [details]
doc file for demonstration

Incorrect displaying doc document
Comment 1 mikhail.v.gavrilov 2013-09-29 19:48:51 UTC
Created attachment 86813 [details]
screenshot for comparing libreoffice and ms word
Comment 2 Kevin Suo 2013-10-03 08:41:22 UTC
Created attachment 87019 [details]
Correct displaying with ubuntu 13.04 LibreOffice 4.1.2.3 RC.

Can not reproduce. Attached is a pdf file exported from LibreOffice, for your doc file.
Comment 3 mikhail.v.gavrilov 2013-10-03 09:24:45 UTC
Created attachment 87021 [details]
Fedora 20 with LO 4.1.2.3 and problem present
Comment 4 tommy27 2013-11-13 18:45:15 UTC
looks fine with 4.1.3.2 under Win7 64bit
maybe Linux specific bug? changing platform.
Comment 5 Jean-Baptiste Faure 2013-11-23 20:25:53 UTC
Not reproducible for me with generic Linux version 4.1.4.0.0+ under Ubuntu 13.10 x86-64.

I guess the problem is only a Fedora one. Please could you try the generic Linux version? You can download it here: http://www.libreoffice.org/download/

Best regards. JBF
Comment 6 mikhail.v.gavrilov 2013-12-23 06:02:03 UTC
Created attachment 91140 [details]
page 4 differences between LO and Word
Comment 7 mikhail.v.gavrilov 2013-12-23 06:12:21 UTC
Also begins troubles if try add header.
Comment 8 Jean-Baptiste Faure 2013-12-23 08:17:05 UTC
Please, don't set the bugs you reported yourself to NEW.

Best regards. JBF
Comment 9 retired 2013-12-23 12:12:41 UTC
Thanks for the test doc and screenshots clearly showing the glitch. But I cannot confirm this problem with LO 4.2.0.1 on OSX.

NoRepro:4.2.0.1:OSX

Could you try 4.2.0.1 and see if the issue persists? http://www.libreoffice.org/download/pre-releases/
Comment 10 mikhail.v.gavrilov 2013-12-24 16:11:05 UTC
Can't run 4.2.0.1

1. installer libreOffice not replaced my distributive version LO

2. when I run LO 4.2.0.1 from console I see error message:
Missing vcl resource. This indicates that files vital to localization are missing. You might have a corrupt installation.
Please see details on my video: https://drive.google.com/file/d/0B0nwzlfiB4aQVDU0TEcxX08zUlU/edit?usp=sharing
Comment 11 tommy27 2014-01-25 10:12:33 UTC
4.2.0.1 in an unstable release.
try upgrading to 4.1.4.2
Comment 12 mikhail.v.gavrilov 2014-01-25 10:18:43 UTC
Created attachment 92764 [details]
4.1.4.2 version and same result
Comment 13 Jean-Baptiste Faure 2014-01-25 16:56:36 UTC
(In reply to comment #12)
> Created attachment 92764 [details]
> 4.1.4.2 version and same result

You need to install Microsoft fonts on your system. On yous screen-copy the font name is in italic, that means that the font is not installed.

Best regards. JBF
Comment 14 mikhail.v.gavrilov 2014-01-26 21:15:22 UTC
(In reply to comment #13)
> You need to install Microsoft fonts on your system. On yous screen-copy the
> font name is in italic, that means that the font is not installed.
> 
> Best regards. JBF

OMG I am really don't understand how absence of some fonts broke drawing lines, but installing Microsoft TrueType Fonts really helps fully solve this issue.

msttcorefonts package not included in fedora and must builded manually:
http://sayaksarkar.wordpress.com/2013/06/02/installing-microsoft-truetype-fonts-in-fedora18/

Could there be another way to solve the problem?
Comment 15 mikhail.v.gavrilov 2014-01-26 21:16:25 UTC
Created attachment 92825 [details]
4.1.4.2 version + msttcorefonts
Comment 16 mikhail.v.gavrilov 2014-01-26 21:17:31 UTC
(In reply to comment #13)

> font name is in italic, that means that the font is not installed.

Strange bug font name still in italic after installing msttcorefonts and solving this issue.
Comment 17 Jean-Baptiste Faure 2014-01-27 20:44:18 UTC
(In reply to comment #16)
> (In reply to comment #13)
> 
> > font name is in italic, that means that the font is not installed.
> 
> Strange bug font name still in italic after installing msttcorefonts and
> solving this issue.

Probably because Calibri font is not part of msttcorefont package.

Best regards. JBF
Comment 18 Jean-Baptiste Faure 2014-01-27 20:52:41 UTC
(In reply to comment #14)
> [...]
> OMG I am really don't understand how absence of some fonts broke drawing
> lines, but installing Microsoft TrueType Fonts really helps fully solve this
> issue.

Because the rectangles are not drawings but frames.

Closing this bug report as WorksForMe.

Best regards. JBF
Comment 19 Michael Stahl (allotropia) 2014-08-07 11:41:01 UTC
this was fixed by bundling the Carlito font which is metrically compatible with Calibri

commit bde5e683286096b9255254b28a862e519d57f547
Author:     Caolán McNamara <caolanm@redhat.com>
AuthorDate: Wed Oct 23 14:57:32 2013 +0100

    bundle Carlito and Caladea

commit 97f63c17f7bc069a12e3afc3975f09897731a693
Author:     Andras Timar <andras.timar@collabora.com>
AuthorDate: Fri Jul 4 14:29:01 2014 +0200

    add Carlito/Caladea fonts to install script