Bug 70033 - Cells not interpreted correctly
Summary: Cells not interpreted correctly
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-02 10:58 UTC by bugzilla
Modified: 2017-02-03 08:07 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
the docx test file (90.38 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-10-02 10:58 UTC, bugzilla
Details
cell structure in LibreOffice (22.54 KB, image/png)
2013-10-02 10:59 UTC, bugzilla
Details
cell structure in MS Office (19.83 KB, image/png)
2013-10-02 10:59 UTC, bugzilla
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugzilla 2013-10-02 10:58:10 UTC
Created attachment 86959 [details]
the docx test file

Problem description: A MS Word docx file was opened in LibreOffice. Some cells  are not displayed correctly, and as a result, one additional line appears.

Steps to reproduce:
1. Open testdocument.docx in LibreOffice.
2. Open testdocument.docx in MS Office.
3. Show paragraph marks and other hidden formatting signs in both applications.
4. Scroll down to the last table and compare how the cells above the total amount (total amount in bold chracters) are structured. 
5. See yellow marking and encircled spots in the screenshots.


Current behavior:
In LibreOffice, there is a new cell but it should be merged.

Expected behavior: Merged cells should remain merged.

This bug may be a duplicate of Bug 54862.
Comment 1 bugzilla 2013-10-02 10:59:03 UTC
Created attachment 86960 [details]
cell structure in LibreOffice
Comment 2 bugzilla 2013-10-02 10:59:31 UTC
Created attachment 86961 [details]
cell structure in MS Office
Comment 3 tommy27 2013-10-03 09:39:57 UTC
issue confirmed in LibO 4.1.1.2 under Win7 64bit. set status to NEW
Comment 4 QA Administrators 2015-04-01 14:42:13 UTC Comment hidden (obsolete)
Comment 5 Buovjaga 2015-04-24 12:43:20 UTC
Confirmed.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha1+ (x64)
Build ID: f3375fa07f27bd2ade519af3c07d69040d10eaa9
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-22_23:38:50
Locale: fi_FI
Comment 6 bugzilla 2015-05-26 10:00:11 UTC
Confirmed

Windows Server 2008 R2 SP1
LibreOffice 4.4.3
Comment 7 QA Administrators 2016-09-20 09:46:34 UTC Comment hidden (obsolete)
Comment 8 bugzilla 2017-02-03 08:06:06 UTC
I re-tested the issue with LibreOffice 5.1.6.2 on Windows 10 x64.
The additional cell (which caused an extra line) is gone. Looks all right now.