Bug Hunting Session
Bug 70129 - [EDITING] Hitting F2 when a cell is in editing mode, should not leave editing mode
Summary: [EDITING] Hitting F2 when a cell is in editing mode, should not leave editing...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-04 13:39 UTC by Cor Nouws
Modified: 2018-03-01 23:31 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2013-10-04 13:39:09 UTC
- Start typing in a cell, that is not in editing mode, just has the focus
- Decide that you need to go back in what you typed (arrow left).
  Then first you need to hit F2

So far so good. But what if you work in the cell a bit longer and do not remember if you already hit F2 ?

- Hitting F2 again makes that the cell looses editing mode, because it works as toggle function.

This is not needed.
Hitting F2 when the cell is in editing mode, should not leave that mode
Comment 1 Cor Nouws 2013-10-04 13:39:37 UTC
obviously an enhancement
Comment 2 tommy27 2014-01-01 12:36:34 UTC
@Cor
do you think that Bug 73192 is somewhat related to your report?
Comment 3 Cor Nouws 2014-01-01 16:22:27 UTC
@tommy,

(In reply to comment #2)
> do you think that Bug 73192 is somewhat related to your report?

thanks for the hint. 'somewhat´'yes, maybe ;) but a developer will probably be able to show the problem is somewhere else in the code. So personally I would not link those.
Comment 4 tommy27 2014-01-02 14:21:07 UTC
probably Bug 63374 is more related.
Comment 5 almos 2014-02-04 10:08:58 UTC
This toggle behavior would be OK, if LO displayed the enter/edit state like MS Excel.
Comment 6 Cor Nouws 2015-02-05 21:24:42 UTC
*** Bug 89142 has been marked as a duplicate of this bug. ***
Comment 7 Jean-Baptiste Faure 2015-03-02 10:28:39 UTC
I do not experience this toggle behavior with LibreOffice 4.4.2.0.0+ built at home under Ubuntu 14.10 x86-64 in which I choose Enter as key to enter the edit mode (instead of moving the selection). If I restore the default behavior of the Enter key (move the selection), I still do not experience this toggle behavior of F2 key.

Best regards. JBF
Comment 8 pavelz 2015-04-03 18:28:46 UTC
With LibreOffice 4.4.2.2 under Ubuntu 14.04 x86-64 I can still reproduce the toggle behaviour (and with every second press of F2 key I can notice short flashing of the text in the cell).
Comment 9 Buovjaga 2017-08-27 13:08:51 UTC
According to this, F2 should toggle editing mode: https://help.libreoffice.org/Calc/Shortcut_Keys_for_Spreadsheets#Function_Keys_Used_in_Spreadsheets ..but it doesn't. Same result in my tests with 3.3 on Linux and 3.5 on Windows.

Same result in Ubuntu 17.04, LibO 5.4. Same result on macOS 10.12, LibO 5.4.

This came up in this discussion: https://www.reddit.com/r/libreoffice/comments/6w7fr9/how_to_continue_editing_the_cell_without_loosing/

So it seems Cor's wish is fulfilled and all we need would be to change the documentation.
Comment 10 Buovjaga 2017-08-27 13:11:45 UTC
(In reply to Buovjaga from comment #9)
> So it seems Cor's wish is fulfilled and all we need would be to change the
> documentation.

Added as bug 112057
Comment 11 Cor Nouws 2017-08-27 16:13:09 UTC
The problem does not occur when you start editing a cell with F2. In that case, indeed F2 doesn't leave edit mode..

However, reading the original description 
" 
 - Start typing in a cell, that is not in editing mode, just has the focus
 - Decide that you need to go back in what you typed (arrow left).
  Then first you need to hit F2
"

that is a different behavior. Can you please test this again :)
Comment 12 Buovjaga 2017-08-27 17:17:40 UTC
(In reply to Cor Nouws from comment #11)
> The problem does not occur when you start editing a cell with F2. In that
> case, indeed F2 doesn't leave edit mode..
> 
> However, reading the original description 
> " 
>  - Start typing in a cell, that is not in editing mode, just has the focus
>  - Decide that you need to go back in what you typed (arrow left).
>   Then first you need to hit F2
> "
> 
> that is a different behavior. Can you please test this again :)

Ok, I did not understand it.
Comment 13 Eike Rathke 2018-03-01 23:31:16 UTC
I can't reproduce. Start editing cell by typing, hit F2 (to be able to move cursor within cell), hit F2 again, cell is still in edit mode. Also in 5-3 already.
Let's close this.