Download it now!
Bug 70200 - EDITING: copy-paste from non-LibO-text-source pastes previous clipboard contents after copy-paste from within LiboO
Summary: EDITING: copy-paste from non-LibO-text-source pastes previous clipboard conte...
Status: RESOLVED DUPLICATE of bug 62196
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-06 16:54 UTC by Ed Barnat
Modified: 2014-02-20 17:46 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Barnat 2013-10-06 16:54:09 UTC
Problem description: 

Steps to reproduce:
1. ....open a LibO (writer) document.  Copy and paste from within that LibO (writer) document to within that LibO document.
2. ....Open a web page or non-LibO document and copy web page text or url 
3. ....Past that text/url into the still open LibO (writer) document

Current behavior: The copied text from step 1 is pasted into the document

Expected behavior: The copied text from the web page/non-LibO document should be pasted into the document.


Current work around is to close all LibO documents, which clears the LibO clipboard. Re-open the LibO document and paste before doing any cut/copy from within LibO


Previously reported in Bug 672196 which does not appear in current known bug list.
              
Operating System: Windows 7
Version: Inherited From OOo
Comment 1 Cor Nouws 2013-10-06 19:12:14 UTC
Hi Ed,

thanks for the report. I confirm in the sense that in some cases, the copy action is not added to the LibreOffice clip board.
Only question for me: what are the 'some cases'

cheers,
Cor
Comment 2 Ed Barnat 2013-10-06 20:44:04 UTC
Cor,

Not in "some cases" (not my words),don't know where you get that idea, it is quite consistent on the more than a dozen machines I have recently tested it on, several of them my own. I can produce the "bug" every time.

Hope that answers your question and helps speed the fix so I can confidently promote the product again.

If there is anything I can do to help, please don't hesitate to ask.


Amgeek
Comment 3 Cor Nouws 2013-10-06 21:14:26 UTC
Hi Ed,

(In reply to comment #2)

> Not in "some cases" (not my words),don't know where you get that idea,

that is just my own experience :)
Sometimes it's from a browser, sometimes another program, sometimes the first time I use the clicpboard..
I'll try to keep an eye on it.

(I did a query for clicpboard, but didn find any similar issue.)

Let status as NEEDINFO - see what others come up with :)
Comment 4 Ed Barnat 2013-11-16 16:29:27 UTC
Hi Cor,

I am still having issues with this on a daily and regular basis. I don't see any sign that this is actively being worked on. Am I reading that correctly and if so what can I do to get this attended to?

Thanks

Amgeek
Comment 5 V Stuart Foote 2014-02-20 17:46:12 UTC
Clearly a duplicate and continuation of bug 62196, comment there for OP

*** This bug has been marked as a duplicate of bug 62196 ***