Bug 70291 - FILEOPEN: Mac OS X: Report-Builder doesn't start with imagecontrol in a report
Summary: FILEOPEN: Mac OS X: Report-Builder doesn't start with imagecontrol in a report
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
(earliest affected) release
Hardware: Other macOS (All)
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2013-10-08 17:50 UTC by Robert Großkopf
Modified: 2014-05-31 07:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:

Unzip the folder and start the database inside the folder. Open "Bericht2". (360.91 KB, application/zip)
2013-10-08 17:50 UTC, Robert Großkopf
Base Report Builder Image control java errors list - Mac OSX (132.40 KB, image/png)
2014-01-05 04:16 UTC, frofa

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2013-10-08 17:50:18 UTC
Created attachment 87296 [details]
Unzip the folder and start the database inside the folder. Open "Bericht2".

Following is reported in a German forum for MAC OS X:
Every report of the Report-Builder, which is linked to external pictures, gives a Java-error. The person, who reported this, created an example. 
Try to open the report, which doesn't start the legacy report-engine. Seems it doesn't work with MAC OS X, LO and Java Version 7 Update 40 (Build 1.7.0_40-b43), Oracle.
I can't confirm this with OpenSUSE 64bit rpm Linux - so we think this is a special problem with Mac.
Comment 1 Julien Nabet 2013-11-11 15:06:15 UTC
On pc Debian x86-64 with master sources updated today, I had these same popup errors with both reports:
The connection to the data source "Neue Datenbank" could not be established.

SQL Status: S1000
Error code: -29

File input/output error /home/julien/compile-libreoffice/bugs/70291_report/Neue Datenbank.odb.properties java.io.IOException: No OutputStream

console logs:
warn:legacy.osl:18104:17:/home/julien/compile-libreoffice/libo_4_1/connectivity/source/drivers/hsqldb/HStorageMap.cxx:323: Storage could not be found in list!
warn:legacy.osl:18104:17:/home/julien/compile-libreoffice/libo_4_1/connectivity/source/drivers/hsqldb/HStorageAccess.cxx:424: Stream is NULL
Comment 2 Robert Großkopf 2013-11-11 16:30:19 UTC
I have tried with the version from 2013-11-06 (pre-release). Don't find any other.
I download the zip-archiv, open the folder "Archiv" and start "Neue Datenbank.odb" in this folder. Works here with OpenSuSE 12.3 64bit rpm.

@Julien: Did you copy the whole content from the folder to the path /home/julien/compile-libreoffice/bugs/70291_report/ ? The report must have the connection to the *.jpg-pictures inside the folder, and this files had to be in the same folder as the database.
Comment 3 Julien Nabet 2013-11-11 18:52:37 UTC
yes images are in the same directory.
julien@julienPC:~/compile-libreoffice/bugs/70291_report$ ls -1
Neue Datenbank.odb

(local drive, no network, soft link or other things)
I unzipped the odb file, the only file where test1/2/3 are present is in:
Comment 4 retired 2013-11-21 11:28:02 UTC
Tried reproducing.


on OS X 10.9, LO Version:
Build ID: d93433ba1181f5d8f6ded0ed0c103df10ebb1f22
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2013-11-20_13:04:00


* download zip
* extract
* open db file
* go to reports
* open report 2
-> opens correctly in new writer

then tried with
same steps -> LO crash

Setting to WORKSFORME.

See if it works for you as well with the nightly from 20th nov: http://dev-builds.libreoffice.org/daily/master/MacOSX-x86@49-TDF/2013-11-20_13.04.00/

Please re-open if the problem persists with the latest nightly build.
Comment 5 Robert Großkopf 2013-11-21 15:06:10 UTC
(In reply to comment #4)
> then tried with
> same steps -> LO crash
> Setting to WORKSFORME.

How could you set this to Worksforme, when you could reproduce a crash with LO When there aren't planned any fixes for 4.1 it would be the right way.

I can't confirm anything of this report, because it seem to be a special MAC-bug. And you have just confirmed this special bug for So I set this bug to Reopened and the version to the first where it is reported for.
Comment 6 frofa 2014-01-05 04:16:02 UTC
Created attachment 91510 [details]
Base Report Builder Image control java errors list - Mac OSX
Comment 7 frofa 2014-01-05 04:18:30 UTC
Confirming this problem with Mac OS X.6.8 and LO (HSQLDB 2.3 'split' configuration). If the image control has image_path (pointing to the linked images) as data source, the RB throws a heap of Java errors (see attachment). If no data-source is set, the report runs normally (but, of course, without images).
Comment 8 frofa 2014-01-08 22:23:09 UTC
It seems this is a long-standing bug affecting images in Report Builder reports in both AOO and LO on the Mac platform.

Some links to document this...

1. Linked images using the PICTURE CONTROL in a FORM works properly on a Mac.
2. Reports containing linked images generated with the legacy Report Wizard do seem to work without a problem.

As reports containing images would seem to be very useful (for pictorial catalogues and the like), it is hoped this apparently Mac-only problem gets addressed sooner rather than later. (We don't want Mac users feeling like second-class citizens.) Anyone got any ideas about this?
Comment 9 frofa 2014-05-31 04:35:06 UTC
Just tested the sample database "Bericht2" (with 3 images) on Mac OS 10.6.8 with LO version and both reports open correctly showing the images. So it appears this bug has been fixed in the current LO version. Can anyone else confirm this. Perhaps this bug should be closed now?
Comment 10 retired 2014-05-31 07:05:09 UTC
Robert / Frofa: 

https://wiki.documentfoundation.org/ReleasePlan/4.1 4.1 is end of life.

Also 4.2 was already available and as frofa now also correctly concluded this bug was and still is WORKSFORME.

If you want a backport, please request a backport but if things work they work - simple as that. Not sure what is being discussed here.

Not everything that works e.g. in latest nightly or beta release does get a backport to all versions currently "supported". That's just how it is. If you do not like this, maybe we need to discuss in QA / DEV to backport all changes. But since we even do not have a commit fixing the problem this will waste more time of the development team.

Any user affected by this could just have installed LO 4.2.

Time is sparse for both QA and DEV team so things like this (I'm pretty sure) will happen in the future.