Bug 70309 - Other: Crash in XSL processing
Summary: Other: Crash in XSL processing
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: Other All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-09 08:21 UTC by Jonas Walldén
Modified: 2013-11-07 13:42 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Minimal test document. (25.28 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-10-09 08:21 UTC, Jonas Walldén
Details
OS X crash log (54.87 KB, text/plain)
2013-10-09 08:22 UTC, Jonas Walldén
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonas Walldén 2013-10-09 08:21:28 UTC
Created attachment 87322 [details]
Minimal test document.

Problem description: 

I'm trying to invoke unoconv script (https://github.com/dagwieers/unoconv) to get XHTML output from a .docx file using the LibreOffice UNO interface. This invokation terminates LibreOffice with the attached crash dump on OS X.


Steps to reproduce:
1. Get unoconv from the git repository.
2. Grab the attached (completely trivial) .docx document.
3. Run the following command:

dhcp1:unoconv-git $ ./unoconv -T 30 -f xhtml --stdout ~/Desktop/crash.docx 

Current behavior:

libc++abi.dylib: terminate called throwing an exception
unoconv: RuntimeException during export phase:
Office probably died. Binary URP bridge disposed during call
Traceback (most recent call last):
  File "./unoconv", line 1172, in <module>
    die(exitcode)
  File "./unoconv", line 1032, in die
    if convertor.desktop.getCurrentFrame():
uno.DisposedException: Binary URP bridge already disposed

Expected behavior:

XHTML output.

Operating System: Mac OS X
Version: 4.1.2.3 rc
Comment 1 Jonas Walldén 2013-10-09 08:22:32 UTC
Created attachment 87323 [details]
OS X crash log
Comment 2 Julien Nabet 2013-10-15 19:35:38 UTC
Comment on attachment 87323 [details]
OS X crash log

Mimetype fixed
Comment 3 Caolán McNamara 2013-11-07 13:41:32 UTC
Seems that the problem is in unoconv in that python3 needs sys.stdout.buffer.write not sys.stdout.write in writeBytes

I've submitted a fix to unoconv as https://github.com/dagwieers/unoconv/pull/170
Comment 4 Caolán McNamara 2013-11-07 13:42:04 UTC
You could fix your local copy of unoconv using https://github.com/caolanm/unoconv/commit/3249fd3df136f1a859ac0272f75fcbf010926d58 its a trivial one-liner