Bug 70352 - Not all border line styles are available at all levels of line thickness
Summary: Not all border line styles are available at all levels of line thickness
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: Other All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2013-10-10 18:53 UTC by tmacalp
Modified: 2018-12-16 19:01 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of border thickness affecting presented line styles (15.08 KB, image/png)
2013-10-10 18:53 UTC, tmacalp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tmacalp 2013-10-10 18:53:51 UTC
Created attachment 87410 [details]
Screenshot of border thickness affecting presented line styles

Problem:
When applying a border to objects in various components(writer tables/calc cells/etc...), at the default border thickness of .05px, many of the styles are not shown as available.  Only by first upping the line thickness will these styles be visible.  Many users will simply never know that they exist.

Here's the breakdown of line thickness to how many styles are shown:
less than .50pt shows 8 line styles
.50pt 		shows 10 line styles
.75pt 		shows 12 line styles
1.0pt and above	shows 14 line styles

I could possibly understand why some of the fancier line styles wouldn't be applicable to very small thicknesses, but the interface should at least give some indication that they are available.  I might also be reading too much into this behavior and the real bug is that all styles really should be presented/applied at every thickness.  I could see it going either way, but I'll write the rest of this under the assumption that it is behaving based on intended behavior.

Suggestions:

The most reasonable solution I can think of in terms of ease of implementation/efficacy is to simply add a text field or tool-tip simply stating, "Increase line thickness for more line styles."

Also, the interface is set up with line style chosen first and thickness second.  If these were reversed, users would at least potentially set their thickness first and then be presented with all of the options for the chosen thickness.  Of course, this still isn't horribly intuitive, looks funny, and users will still probably select style first.  It'd be easy to implement, but I don't like this option.

It would be more costly to implement, but the drop down line style list could even be enhanced to show all line styles, but with the ones that aren't available at the current thickness greyed out.  I can't think of an elegant way to also notify users that the styles are greyed out because the thickness is too small.
Comment 1 ign_christian 2014-07-05 09:19:05 UTC
Hello..borders now have significant difference in LO 4.2 and 4.3

If you satisfy with those changes please change status to RESOLVED WORKSFORME, unless UNCONFIRMED
Comment 2 tmacalp 2015-01-09 20:35:09 UTC
I guess I'll mark this back to unconfirmed, since this is still an issue when I tested 4.4.0.1 rc1.

Things are slightly different with newer versions, since there are more line styles shown for each level:

less than .50pt shows 10 line styles now
.50pt 		shows 14 line styles now
.75pt 		shows 16 line styles now
1.0pt and above	shows 18 line styles now

But the originally reported problem of not being shown the various line styles at smaller line thicknesses is valid.  At least LO seems to handle invalid thickness/line style combinations gracefully and falls back to a plain line.

Granted, this is a VERY minor bug, but I still think my original report is valid.  I will go ahead and also mark the importance down to low.
Comment 3 Robinson Tryon (qubit) 2015-01-15 21:40:26 UTC
An enhancement for the UX Brigade.

Status -> NEW
Component -> UX-Brigade..I mean ux-advise
Comment 4 Michael Stahl (CIB) 2015-01-15 23:13:19 UTC
yes the UI is awful, see also bug 47194
Comment 5 Robinson Tryon (qubit) 2016-08-25 04:45:04 UTC Comment hidden (obsolete)
Comment 6 Heiko Tietze 2017-08-01 12:45:31 UTC
That issue is solved. Line style dropdowns show the style visually and textually, not depending on the line width.