Download it now!
Bug 70630 - EDITING: Incompatibility with Word in Comments
Summary: EDITING: Incompatibility with Word in Comments
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other All
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
Depends on:
Blocks: Writer-Comments
  Show dependency treegraph
 
Reported: 2013-10-18 19:10 UTC by Rogier van Vlissingen
Modified: 2017-04-13 09:05 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
a chapter from a book where this problem occurs. (137.00 KB, application/msword)
2013-10-18 19:10 UTC, Rogier van Vlissingen
Details
attachment-22532-0.html (2.88 KB, text/html)
2013-10-19 01:35 UTC, Rogier van Vlissingen
Details
attachment-22532-1.dat (1 bytes, multipart/alternative)
2013-10-19 01:35 UTC, Rogier van Vlissingen
Details
TGL06_H4_V0.750-LD.doc (121.00 KB, application/msword)
2013-10-19 01:35 UTC, Rogier van Vlissingen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rogier van Vlissingen 2013-10-18 19:10:23 UTC
Created attachment 87835 [details]
a chapter from a book where this problem occurs.

Problem description: 

Steps to reproduce:
1. Make Comments in a file in Word (.doc)
2. Open same file in LO


Current behavior:
the last character BEFORE the highlighting of the comment will be reduced a few font sizes. When you delete the comment, the highlighting stays.

Expected behavior:
In Word the same problem does not exist, but the incompatibility does travel back. If you re-export the file to Word, the smaller character prior to the anchor of the comment will stay, and sometimes, the highlighting mysteriously disappears, even if the comment is still there.

              
Operating System: Windows 7
Version: 4.1.2.3 release
Last worked in: 3.6.7.2 release
Comment 1 Robinson Tryon (qubit) 2013-10-19 00:49:08 UTC
Partially-CONFIRMED on Ubuntu 12.04.3 + LO 4.1.2.3

REPRO STEPS:
1. Open Word file provided by Bug Reporter in LibreOffice.
2. Observe last character before comment insertion point

In my copy of LibreOffice, I see the small-sized characters as described by Bug Reporter. Deleting these characters and re-inputting them results in them staying full-sized.

ADDING COMMENTS:
I see no issues when adding additional comments to the document (Insert -> Comment) from within Writer.

TESTING IN MS-WORD:
I do not have a copy of MS-Office, so I am unable to confirm if this bug "travels back" and is visible in MS-Word (as reported).

ADDITIONAL NOTES:
I'm also seeing smaller letters at the end of other words, for example the "s" at the end of "which therefore no longer exists."

Rogier: Did the above sentence previously have a comment at the end of it?
Comment 2 Rogier van Vlissingen 2013-10-19 01:01:53 UTC
yes, there was a comment on "no longer exists." and that final small "s"
remained after the comment was deleted.

Also note that if someone did highlighting in word, which normally (within
word) disappears when the comment is deleted, in LO this highlighting
remains behind, and needs to be manually removed.

*Rogier Fentener van Vlissingen <http://viz.me/vliscony/t/7>*
*About Me <http://about.me/vliscony>*
Join Green Power Business Builder
Bootcamp<http://www.vliscony.com/green-bootcamp/>
!


On Fri, Oct 18, 2013 at 8:49 PM, <bugzilla-daemon@freedesktop.org> wrote:

>  Qubit <qubit@runcibility.com> changed bug 70630<https://bugs.freedesktop.org/show_bug.cgi?id=70630>
>  What Removed Added  Status UNCONFIRMED NEEDINFO  CC
> qubit@runcibility.com  Ever confirmed   1
>
>  *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=70630#c1> on bug
> 70630 <https://bugs.freedesktop.org/show_bug.cgi?id=70630> from Qubit<qubit@runcibility.com>
> *
>
> Partially-CONFIRMED on Ubuntu 12.04.3 + LO 4.1.2.3
>
> REPRO STEPS:
> 1. Open Word file provided by Bug Reporter in LibreOffice.
> 2. Observe last character before comment insertion point
>
> In my copy of LibreOffice, I see the small-sized characters as described by Bug
> Reporter. Deleting these characters and re-inputting them results in them
> staying full-sized.
>
> ADDING COMMENTS:
> I see no issues when adding additional comments to the document (Insert ->
> Comment) from within Writer.
>
> TESTING IN MS-WORD:
> I do not have a copy of MS-Office, so I am unable to confirm if this bug
> "travels back" and is visible in MS-Word (as reported).
>
> ADDITIONAL NOTES:
> I'm also seeing smaller letters at the end of other words, for example the "s"
> at the end of "which therefore no longer exists."
>
> Rogier: Did the above sentence previously have a comment at the end of it?
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 3 Robinson Tryon (qubit) 2013-10-19 01:09:19 UTC
(In reply to comment #2)
> 
> Also note that if someone did highlighting in word, which normally (within
> word) disappears when the comment is deleted, in LO this highlighting
> remains behind, and needs to be manually removed.

Rogier - Is there an example of this "highlighting" in the example document provided?

In my testing on LO 4.1.2.3, when I deleted a comment, the entire comment (box, text, line, and insertion triangle/caret ) would disappear. If your behavior on Windows is different from mine, please provide a screenshot of what is left behind.

Thanks!
Comment 4 Rogier van Vlissingen 2013-10-19 01:35:52 UTC
Created attachment 87840 [details]
attachment-22532-0.html

Hereby the prior version of the same file, and you'll see how passages are
highlighted to indicate what the comments pertain to. In Word, when you
delete the comment, this highlighting disappears. In LO the highlighting
stays, and needs to be manually removed.

*Rogier Fentener van Vlissingen <http://viz.me/vliscony/t/7>*
*About Me <http://about.me/vliscony>*
Join Green Power Business Builder
Bootcamp<http://www.vliscony.com/green-bootcamp/>
!


On Fri, Oct 18, 2013 at 9:09 PM, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 3 <https://bugs.freedesktop.org/show_bug.cgi?id=70630#c3> on bug
> 70630 <https://bugs.freedesktop.org/show_bug.cgi?id=70630> from Qubit<qubit@runcibility.com>
> *
>
> (In reply to comment #2 <https://bugs.freedesktop.org/show_bug.cgi?id=70630#c2>)
> >
> > Also note that if someone did highlighting in word, which normally (within
> > word) disappears when the comment is deleted, in LO this highlighting
> > remains behind, and needs to be manually removed.
>
>
> Rogier - Is there an example of this "highlighting" in the example document
> provided?
>
> In my testing on LO 4.1.2.3, when I deleted a comment, the entire comment (box,
> text, line, and insertion triangle/caret ) would disappear. If your behavior on
> Windows is different from mine, please provide a screenshot of what is left
> behind.
>
> Thanks!
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 5 Rogier van Vlissingen 2013-10-19 01:35:52 UTC
Created attachment 87841 [details]
attachment-22532-1.dat
Comment 6 Rogier van Vlissingen 2013-10-19 01:35:52 UTC
Created attachment 87842 [details]
TGL06_H4_V0.750-LD.doc
Comment 7 Kumāra 2013-12-04 06:19:36 UTC
(In reply to comment #0)
> When you delete the comment, the highlighting stays.

I notice the same behavior for the same LibO version in a DOC file editing by MS Word for Mac 2008. It's "highligted" in grey, and I can't remove it. Had to cut and paste as unformatted text.

The comment also appears strangely: The content shows up as a column of single characters on the right. Not sure if this should be reported separately.
Comment 8 Bernd Robker 2014-02-13 22:18:23 UTC
I confirm the bug as reported by Bug Reporter.

To me, this behaviour is extremely disturbing, as I have to collaboratively work on text documents with colleagues using MS Word, so .doc is our exchange format and comments are necessary to do our job.

Operating System: Windows 7
Version: 4.2.0.4 release
Comment 9 Kumāra 2014-02-14 04:19:59 UTC
Having read the report guidelines, I think it's proper to change the importance to "high". Please correct me if this is wrong.
Comment 10 Joel Madero 2015-05-02 15:43:30 UTC Comment hidden (obsolete)
Comment 11 Kumāra 2015-05-04 03:47:48 UTC Comment hidden (obsolete)
Comment 12 Bernd Robker 2015-05-21 14:45:06 UTC
This is different from Bug 72511.
Comment 13 Bernd Robker 2015-05-24 18:51:28 UTC
I re-testes with LibreOffice 4.4.3.2 - the bug persists.
Comment 14 Robinson Tryon (qubit) 2015-12-09 17:00:13 UTC Comment hidden (no-value, obsolete)
Comment 15 QA Administrators 2017-01-03 19:41:06 UTC Comment hidden (obsolete)
Comment 16 Timur 2017-04-13 07:51:16 UTC
Can someone please test as asked, also in the latest development LO versions, now it's 5.4 master?
I recommend using Separate Install GUI tool from https://flosmind.wordpress.com/si-gui/ which downloads and extracts different LO versions, without installing.
Comment 17 Timur 2017-04-13 09:05:36 UTC
This bug was not precisely reported or triaged. I understand it like this: 
"Fileopen: last character reduced in .DOC with comments attached to text ranges" 
Needs proper source document for test, which is attachment 87842 [details] from Comment 6.
It started from 4.1, maybe related to Bug 59530. Reproduced with 4.2.8.2.
No repro with 4.3.0 and later, so Comment 13 not confirmed.
I close as WFM.