Download it now!
Bug 70642 - CONFIGURATION: Menubar Configuration is not stored and therefore not usable
Summary: CONFIGURATION: Menubar Configuration is not stored and therefore not usable
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-19 09:06 UTC by dirk.schnabel
Modified: 2015-06-15 19:33 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
test spreadsheet with a simple macro, that cannot be added persistent to menubar (36.68 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-10-19 09:06 UTC, dirk.schnabel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dirk.schnabel 2013-10-19 09:06:51 UTC
Created attachment 87850 [details]
test spreadsheet with a simple macro, that cannot be added persistent to menubar

Problem description: 
Adding user defined menues for the current file is only possible for the current session. The configuration is not stored with the file.

Steps to reproduce:
1. Create a macro (sub) within CALC with the contents
   msgbox "Hello"

2. Add this macro to a new menu fot the current file (not for CALC) via Tools-Customize-Menubar and test it. It works as expected.

3. Store the file and re-open it. The menu and the entry are no longer present. You can also open the archive .ods with e.g. UNZIP and you'll see, that the configuration was not stored.

Current behavior:
No configuration of menubars is possible

Expected behavior:
I need user defined menubars.
              
Operating System: All
Version: 4.1.2.3 release
Comment 1 j.tronel 2013-11-11 08:36:22 UTC
Confirmed on LibO 4.1.3.2 (Windows 7). Most annoying.

*** Apache OpenOffice has not this bug, and files it creates are correctly displayed in LibO (with custom menu) ***
Comment 2 QA Administrators 2015-04-19 03:21:10 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 3 Buovjaga 2015-06-15 19:33:14 UTC
Works ok now.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 01a189abcd9a4ca472a74b3b2c000c9338fc2c91
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-14_07:46:28
Locale: fi-FI (fi_FI)